intel)

Getting Started with the Intel(R)
C++ Compiler Professional Edition
11.1 for Windows* OS

This guide shows you how to start Intel® C++ Compiler Professional Edition, use
Intel® Libraries with your project, and begin debugging code using Intel® Parallel
Debugger Extension.

The guide suggests common scenarios for selecting a threading technique that best
fits your application performance goals and gives directions for finding more user and
reference information.
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1 Start Intel® C++ Compiler Professional
Edition

The Intel® C++ Compiler Professional Edition 11.1 for Windows* OS integrates into
the following versions of the Microsoft Visual Studio* IDE:

e Microsoft Visual Studio 2008*.

e Microsoft Visual Studio 2005*.

e Microsoft Visual Studio .NET 2003*.
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To start the Intel® Compiler Professional Edition from Microsoft Visual Studio* IDE,
perform the following steps:

1. Launch Microsoft Visual Studio*.
2. Open or create a Visual Studio solution in the Solution Explorer pane.

3. From the Project menu, or project context menu, select Intel C++ Compiler
Pro = Use Intel C++.

4. Click Yes in the Confirmation dialog box. This configures the solution to use the
Intel® C++ Compiler (you may configure the solution to use the Intel® C++

compiler by clicking 5 on the toolbar too).
5. Select Rebuild Solution from the Visual Studio Build menu.

The results of the compilation are displayed in the Output window.

See Intel® C++ Compiler Professional Edition online help for more information on
building applications. See User and Reference Documentation to help locate additional
information and help.

Start the Compiler from the Command Line

To start the compiler from the Windows command line, use the Windows program
menu to select:

Intel(R) Software Development Tools >
Intel(R) C++ Compiler Professional 11.1.xxx >
Build Environment for...

This method opens a Windows command prompt and sets the environment variables
for the Intel compiler. To compile a C++ language source file (for example,
my_source_file_cpp), use this command:

icl my source file.cpp

Following successful compilation, an executable named my_source_Ffile._exe is
created in the current directory.
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2 Use Intel® Performance Libraries

To use the Intel® C++ project with the Intel® Integrated Performance Primitives,
Intel® Threading Building Blocks, or Intel® Math Kernel Library, do the following:

1. Open your project in the Solution Explorer.

2. On the menu bar, select Project > Intel C++ Compiler Pro > Select Build
Components (or click on the toolbar).

The Select Build Components dialog box opens:

hello - Select Build Components K E3
Project Configuration; Project Platform:
[Detug = Jwinsz =]
Wersion to use with this configuration: Default Suite wersion:
IInteI(R) Compiler Pro 11,1 build 032 j I Inkel(R) Compiler Pro 11,1 build 032

r Inkel Performance Libraries ko use with this configuration

rIntel Inkegrated Performance Primitives Inkel Math Kernel Library
¥ Use IFP Use MEL:

v Use IPP Cryptography

Sequential
rIntel Threading Building Blocks Cluster

v Use TEB

™| Instrument For use with Intel Parallel Inspector and Intel Paralle] amplifier

Ok Cancel | Apply I

The dialog box allows you to enable Intel Performance Libraries:

Action Result
Check Use IPP Enable the Common Intel® IPP libraries only.
Check Use IPP Cryptography Enable both Cryptography Intel® IPP libraries and
Common Intel® IPP libraries.
Uncheck Use IPP Disable Intel® IPP libraries.
Check Use TBB Enable Intel® TBB libraries.
Uncheck Use TBB Disable Intel® TBB libraries.
Check Use MKL: Enable Intel® MKL libraries.
Select Parallel Use parallel Intel® MKL libraries.
Select Sequential Use sequential Intel® MKL libraries.
Select Cluster Use cluster Intel® MKL libraries.
Select No Disable all Intel® MKL libraries.

Getting Started Guide
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Once you click OK or Apply in the Select Build Components dialog box, the
appropriate Intel® IPP, Intel® TBB, or Intel® MKL include paths and link libraries

for the selected architecture will be added to the project property settings.

If your target platform is 1A-64 or Intel® 64, an additional, Use ILP64 interfaces,
switch box appears. If switched on, corresponding i Ip MKL libraries will be added to
the linker command line and MKL__ILP64 preprocessor definition will be added to the
compiler command line, otherwise Ip MKL libraries will be used by default.

NOTE: See the Intel® MKL User’s Guide for explanation of the difference between LP
and ILP64 versions of the library.

Select a Threading Method

Parallel Method

Benefits

Considerations

Intel® IPP

Highest performance, scalable for
certain multimedia application domains;
does not expose parallelism in your
code.

Cryptography, image, audio,
video, compression, and the
like. Best for multimedia.

Auto-parallel

Automatic parallelization; does not
expose explicit parallel syntax in your
code.

Limited to well-formed loops.

New Parallel

Good for rapid prototyping, easy

Does not have the controls

math routines for science, engineering,
and financial applications that require
maximum performance; does not
expose parallelism in your code.

Extensions syntax, maps to OpenMP* 3.0 runtime. for shared/private variables
like OpenMP* or Intel® TBB.
OpenMP* 3.0 Well-known standard, efficient runtime, Pragma use is not common
scalable. OpenMP 3.0 support for task for some C++ developers;
construct helps function-level can be difficult for C++
parallelism; Intel support for OpenMP* objects/data; Microsoft Visual
is compatible with Microsoft Studio* 2008 supports
implementation. OpenMP* 2.5.
Intel® TBB Natural C++ solution, efficient, scalable Need to understand C++
runtime. Object Oriented
Programming: templates and
containers.
Intel® MKL Highly optimized, extensively threaded Extensively threaded math

functions: BLAS, LAPACK,
Sparse Solvers, Fast Fourier
Transforms, Vector Math,
Vector Statistics.
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Debug Your Code with Intel® Parallel
Debugger Extension

Open Samples

Intel® C++ Compiler Professional Edition provides several sample applications,
located at:

<install-dir>\Samples\<locale>\C++\<solution name>.zip

1. Unzip <solution name>.zip to a directory of your choice.

2. Locate and double-click the .slIn file or open the solution file from the Microsoft
Visual Studio* development environment.

Discussion in the steps below uses the NQueens.zip samples provided.

NOTE: If, during product installation, you accepted the default installation location,

<install-dir>is
C:\Program Files\Intel\Compiler\11l.1\<build_number>.

Prepare Example Code for Debugging

Unzip the NQueens.zip to a directory of your choice.

Open sample projects in Microsoft Visual Studio* by double-clicking the
NQueens.slin.

3. In ng-openmp-intel project, double-click hng-openmp .cpp
4. Comment out the line #pragma omp atomic to create a data sharing violation.

5. Ensure that the ng-openmp project properties show that the command argument
11 is being handed over to the program.

nq-openmp Property Pages
Configuration: | Active(Debug) |%| Platform: | Active(win3z) |¥| | Configuration Manager. .. ]
= Configuration Properties (|| Debugger tolaunch:

Local Windows Debugger

S o
General
Debug

Command
Command Arguments
Warking Directory

$(TargetPath)
11

Getting Started Guide

Fimbirnin ke

6. Ensure that the compiler command line options /Z1, /debug:parallel, and
/Qopenmp are set on the Property Pages of the project:
Configuration Properties > C/C++ > General > Debug Information
Format; Configuration Properties > C/C++ > Debug > Enable Parallel
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Debug Checks; and Configuration Properties > C/C++ > Language >
General = OpenMP Support respectively.

7. Confirm that the linker command line option /DEBUG is set:
Configuration Properties > Linker > Debugging > Generate Debug Info.

8. Rebuild the project.

|dentify Parallel Coding Issues

To identify Thread Data Sharing Events that might trigger runtime data sharing
violations, do the following:

1. Select Enable Detection from Debug > Intel Parallel Debugger Extension >

I
Thread Data Sharing Detection menu (or click ﬁb ).
2. Start the debug session by selecting the Start Debugging from the Debug menu

(or click 4 ). The program execution will be halted as soon as a thread data
sharing event is detected.

1

3. Click the Thread Data Sharing Events button i

caused the execution to be halted.

Thread Data Sharing Events

Analysis run from Tue Jul 07 2009 7:55:11 PM {2 events, enabled, I:ureak 0 active filkers)
ﬁﬁg nrOFSolutions - 0x004034ec 4 Bytes, 2 accesses from 2 threads
: \;5‘3‘ ng-openmp,cppl97) read, Thread=3956 (OpentP task==20)
b ng-openmp.cpp(37) write, Thread=3756 (OpenMP task=19)
5’&1& nrOfSolutions - Ox004094ec 4 Bytes, 3 accesses from 2 threads
i g mg-openmp.cpp{97) write, Thread=3956 (OpenMP task=20)
— &% ng-openmp.cppi97) write, Thread=3756 (OpenMP task=1%)
‘Zp ng-openmp.cpp(37) read, Thread=3756 (OpenMP task=19)

to see a log of events that

Result:

You can see from the Thread Data Sharing Events log that two different OpenMP*
threads have been trying to access the nrOfSolutions variable: thread 3956 read the
value and thread 3756 incremented the value. Since there are two different threads
modifying and relying on a single variable this is a potentially serious problem that
causes the N-Queens algorithm to produce incorrect results. Use the #pragma omp
atomic to make the nrOfSolutions++ increment thread safe.

To identify Function Re-Entrancy events, do the following:

1. Disable the data sharing event detection by clicking on the Enable Detection
L]

button ﬁ'{y so it changes to a disabled state ﬁ)@ .
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2. Select Debug > Intel Parallel Debugger Extension > Break on Re-Entrant

Call from the menu (or click| 3"0 ).

3. In the pop-up window that is being displayed enter {,,nq-
openmp.exe}setQueen. Simply entering setQueen would also suffice.

4. Select Continue Debug.

5. Upon detecting function re-entrancy, the Re-entrant Call Detected window

opens with information about the thread IDs of the threads involved.
6. Select OK.

Result:

The debugger instruction pointer sits at the function entry point of the function where
re-entrance was detected.

Fwoid secQueen(int queens[], int row, int col, int id)

o || forfint i=0; d<row; i++) {
fSf wertical attacks
if (gqueens[i]==col)] {
return;

OpenMP task 20 and OpenMP task 19 both entered the function setQueen(). Both
tasks are modifying values and using data inside this function. You need to ensure
that they do not overwrite each other’s data. If you observed a runtime problem in
the function setQueen(), this could be an important pointer telling you that
setQueen() needs to be implemented in a thread-safe manner if it is not already
thread-safe.

Other Debugging Considerations

If you are using Microsoft Visual Studio* 2005 you might first need to verify that the
Intel® Parallel Debugger Exceptions are enabled in the Microsoft Visual Studio*
Debugger.

Verify the exceptions are enabled by doing the following:

1. From the Debug pull-down menu select Exceptions.

Getting Started Guide 7
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2. Ensure that in the Win32 Exceptions tree-view list the boxes for Intel
Parallel Debugger Extension Exception are enabled.

Exceptions

Break when an exception is:

Mame

Thrown || #]
= Win32 Exceptions |:|
40010005 Control-C
40010008 Control-Break
B0000002 Datatvpe misalignment D
ala01dbo Intel Parallel Debugger Extension Exception 0
alalldbl Intel Parallel Debugger Extension Exception 1
alalidbz Intel Parallel Debugger Extension Exception 2

3. Go to the File pull-down menu, and select Save all.

User and Reference Documentation

This guide focuses on basic Intel® C++ Compiler Professional features. To explore
more features, check the following resources.

Resources Notes
Intel® C++ Use this HTML page to locate additional Intel® C++ Compiler Professional
Compiler Edition 11.1 documentation for the following:
Professional .
Edition e Intel® C++ Compiler.

Documentation

e Intel® Threading Building Blocks.

e Intel® Math Kernel Library.

e Intel® Integrated Performance Primitives.
¢ Intel® Parallel Debugger Extension.

To open this HTML page, from the Windows* Start menu, choose Intel®
Software Development Tools > Intel® C++ Compiler Professional
11.1.xxx > Documentation.

Sample code

Use sample code in a zip file provided at <install_dir>\
Samples\<locale>\C++\ to learn how to use various threading techniques.
samples.htm provides an overview of the C++ samples.

Integrated User
and Reference
Help

Open the Integrated User and Reference Help from Microsoft Visual Studio*
Help menu. Select Help > Intel C++ Compiler Pro > Intel C++
Compiler Help.

To enable Intel C++ quick start help topic, click on the toolbar.

Filter the contents and index information: select Intel from the Filtered by
drop-down list to view only the Intel® C++ Compiler Pro documentation.

Product
Information and
Technical Support

For general product information or information on support for Intel software
products, visit the Intel web site: http://www.intel.com/software/products/.
At this site, you will find comprehensive product information, including:

e Links to each product, where you will find technical information such as
white papers and articles.
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e Links to user forums.
e Links to news and events.

To find technical support information, to register your product, or to contact

Intel, please visit: http://www.intel.com/software/products/support. For
additional information, see the Technical Support section of your Release
Notes.

See the registration web site for licensing and registration guidance:
https://reqistrationcenter.intel.com/.

Getting Started Guide
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Legal Information

INFORMATION IN THIS DOCUMENT IS PROVIDED IN CONNECTION WITH INTEL® PRODUCTS. NO LICENSE,
EXPRESS OR IMPLIED, BY ESTOPPEL OR OTHERWISE, TO ANY INTELLECTUAL PROPERTY RIGHTS IS GRANTED BY
THIS DOCUMENT. EXCEPT AS PROVIDED IN INTEL'S TERMS AND CONDITIONS OF SALE FOR SUCH PRODUCTS,
INTEL ASSUMES NO LIABILITY WHATSOEVER, AND INTEL DISCLAIMS ANY EXPRESS OR IMPLIED WARRANTY,
RELATING TO SALE AND/OR USE OF INTEL PRODUCTS INCLUDING LIABILITY OR WARRANTIES RELATING TO
FITNESS FOR A PARTICULAR PURPOSE, MERCHANTABILITY, OR INFRINGEMENT OF ANY PATENT, COPYRIGHT OR
OTHER INTELLECTUAL PROPERTY RIGHT.

UNLESS OTHERWISE AGREED IN WRITING BY INTEL, THE INTEL PRODUCTS ARE NOT DESIGNED NOR INTENDED
FOR ANY APPLICATION IN WHICH THE FAILURE OF THE INTEL PRODUCT COULD CREATE A SITUATION WHERE
PERSONAL INJURY OR DEATH MAY OCCUR.

Intel may make changes to specifications and product descriptions at any time, without notice. Designers must
not rely on the absence or characteristics of any features or instructions marked "reserved" or "undefined." Intel
reserves these for future definition and shall have no responsibility whatsoever for conflicts or incompatibilities
arising from future changes to them. The information here is subject to change without notice. Do not finalize a
design with this information.

The products described in this document may contain design defects or errors known as errata which may cause
the product to deviate from published specifications. Current characterized errata are available on request.
Contact your local Intel sales office or your distributor to obtain the latest specifications and before placing your
product order.

Copies of documents which have an order number and are referenced in this document, or other Intel literature,
may be obtained by calling 1-800-548-4725, or by visiting Intel's Web Site.

Intel processor numbers are not a measure of performance. Processor numbers differentiate features within each
processor family, not across different processor families. See http://www.intel.com/products/processor_number
for details.
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* Other names and brands may be claimed as the property of others.
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