

















Tutorial: Identifying Concurrency 2

Visual Studio runs thet achyon_i denti fy_concurrency. exe. Note that execution time reduced
from 32 seconds to 19.5 seconds.

Recap

You optimized the application execution time by removing the unnecessary critical section that
consumed a lot of CPU time.

Key Terms and Concepts

e Term: hotspot
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Compare with Previous Result

You made sure that removing the critical section gave you 12.5 seconds of optimization in the
application execution time. To understand the impact of your changes per function and how the CPU
utilization has changed, re-run the Concurrency analysis on the optimized code and compare results:

e Compare results before and after optimization.
e Identify the performance gain.

Compare Results Before and After Optimization

1. Run the Concurrency analysis on the modified code.

2. Click the button on the Amplifier toolbar.

The Compare Results dialog box opens.
3. Specify the Concurrency analysis results you want to compare and click the Compare button:

The Concurrency Bottom-up window opens, showing the CPU time utilization across the two results
and the differences side by side:
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CPU time for the initial version of the code.
CPU time for the optimized version of the code.

Difference in CPU time per utilization level between the
two results in the following format: <Difference CPU
Time> = <Result 1 CPU Time> - <Result 2 CPU Time>.
By default, the Difference column is expanded to display
comparison data per utilization level. You may collapse
the column to see the total difference data per CPU time.

Comparison summary data for the two results and their
difference calculated as r002cc - r003cc= Diff.

Logical CPUs Utilized is the average utilization of all
cores during application run.

Concurrency graphs for both compared results.

Identify the Performance Gain

Click the [El button for the first three columns to expand them per utilization level.
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For the gri d_i nt er sect hotspot function, the difference is 11.207s - 0s = 11.207s of Poor CPU
utilization time, which means that this function in Result 2 (optimized) did not have Poor utilization
at all and effectively used processor cores. Respectively, the Ideal CPU utilization time has increased
significantly: 2.161s - 11.938s = -9.777s, which means that after removing the critical section all
CPU cores were effectively utilized during almost 10 seconds.

The Elapsed time data in the Summary tab shows the optimization of 13.940 seconds for the whole
application execution.

Recap

You ran the Concurrency analysis on the optimized code and compared the results before and after
optimization using the Compare mode of the Intel® Parallel Amplifier. The comparison shows that,
with the optimized version of the t achyon_i denti fy_concurrency. exe application (r003cc result),
you managed to better utilize all available cores and got 13-second speedup for the application
Elapsed time. Compare analysis results regularly to look for regressions and to track how incremental
changes to the code affect its performance. You may also want to use the Amplifier command-line
interface and run the anpl - cI| command to test your code for regressions. For more details, see the
Command-line Interface Support section in the Amplifier online help.
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Key Terms and Concepts

Term: hotspot

Concept: Concurrency Analysis

Summary

You have completed the Identifying Concurrency tutorial. Here are some important things to remember
when using the Amplifier to analyze your code for concurrency:

Step 1. Choose and Build Your Target

Configure the Microsoft* symbol server and your project properties to get the most accurate
results for system and user binaries and to analyze the performance of your application at the
code line level.

Create a performance baseline to compare the application versions before and after optimization.
Make sure to use the same workload for each application run.

Step 2. Run Analysis

Use the Amplifier toolbar or Tools menu to choose and run the analysis. You can also use the
anmpl - cl command.

If required, modify the default analysis settings from Tools > Options... > Intel Parallel
Amplifier 2011 > Collection. For example, you may limit the data collection to a predefined
amount of data or enable the Amplifier to collect more accurate CPU time data.

Step 3. Interpret Results and Resolve the Issue

Start analyzing the performance of your application from the Summary tab to explore the
performance metrics for the whole application. Then, move to the Bottom-up window to analyze
the performance per function. Focus on the hotspot functions that under- or over-utilized the
available logical CPUs during their execution and took the most CPU time. By default, the functions
that under-utilized available cores (Poor utilization level) most of all show up at the top of the
window.

Double-click the hotspot function in the Bottom-up window or Call Stack tab to open its source
code at the code line with the worst CPU utilization.
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Step 4. Compare Results Before and After Optimization

e Perform regular regression testing by comparing analysis results before and after optimization.

From GUI, click the Compare Results button on the Amplifier toolbar. From command line,
use the anpl - ¢l command.

e Expand each data column by clicking thel button to identify the performance gain per CPU
utilization level.
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Tutorial: Analyzing Locks and
Waits

Learning Objectives

This tutorial shows how to use the Locks and Waits analysis of the Intel® Parallel Amplifier to identify one
of the most common reasons for an inefficient parallel application - threads waiting too long on
synchronization objects (locks) while processor cores are underutilized. Focus your tuning efforts on
objects with long waits where the system is underutilized.

Estimated completion time: 15 minutes.

After you complete this tutorial, you should be able to:

Choose an analysis target.

Choose the Locks and Waits analysis type.

Run the Locks and Waits analysis.

Identify the synchronization objects with long waits and poor CPU utilization.
Analyze the source code to locate the most critical code lines.

Compare results before and after optimization.

Workflow Steps to Identify Locks and Waits

You can use the Intel® Parallel Amplifier to understand the cause of the ineffective processor utilization
by performing a series of steps in a workflow. This tutorial guides you through these workflow steps while
using a sample ray-tracer application named t achyon.

D NOTE. Click for a video demonstration. Show Me videos require Adobe* Flash*

Player.
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. Choose a target to analyze for locks and waits.

. Configure environment and project settings and build the target.
. Run the Locks and Waits analysis.

. Interpret the result data.

. View and analyze code of the performance-critical function.

. Modify the code to remove the lock.

. Re-build the target, re-run the Locks and Waits analysis, and compare the result data before and
after optimization.

NOUuhLWNR=

Choose Target

Before you start you need to choose the target in the Microsoft Visual Studio* environment. For this
tutorial, your target is a ray-tracer application, t achyon. To learn how to install and set up the
sample code, see Prerequisites.

D e The steps below are provided for Microsoft Visual Studio* 2005. Steps for other
versions of Visual Studio IDE may slightly differ. See online help for details.
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e Steps provided by this tutorial are generic and applicable to any application. You may
choose to follow the proposed workflow using your own application.

To choose a target:

1. From the Visual Studio menu, select File > Open > Project/Solution....
The Open Project dialog box opens.

2. In the Open Project dialog box, browse to the location you used to unzip the
tachyon_st udi o. zi p file and select the t achyon_Par al | el St udi o. sl n file.

The solution is added to Visual Studio and shows up in the Solution Explorer.

3. In Solution Explorer, right-click the analyze_locks project and select Project > Set as StartUp
Project.

analyze_locks appears in bold in Solution Explorer.

Recap

You selected the analyze_locks project as the target for the Locks and Waits analysis.

Key Terms and Concepts

e Term: target
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Build Target

After choosing the analysis target, do the following to ensure the Intel® Parallel Amplifier provides
the most accurate information on the performance of your application:

Configure the Microsoft Visual Studio* environment to download the debug information for system
libraries so that Amplifier can properly identify system functions and classify and attribute functions.

Configure Visual Studio project properties to generate the debug information for your application
so that Amplifier can open the source code.

Build the target in the release mode with full optimizations, which is recommended for performance
analysis.

Run the application without debugging to create a performance baseline.

D NOTE. The steps below are provided for Microsoft Visual Studio* 2005. Steps for other

versions of Visual Studio IDE may differ slightly.

Enable Downloading the Debug Information for System Libraries

1.

Go to Tools > Options....

The Options dialog box opens.

. From the left pane, select Debugging > Symbols.

In the Symbol file (.pdb) locations field, click the button and specify the following address:
http://msdl.microsoft.com/download/symbols.

. Make sure the added address is checked.

. In the Cache symbols from symbol servers to this directory field, specify a directory where

the downloaded symbol files will be stored.

. For Microsoft* Visual Studio* 2005, check the Load symbols using the updated settings when

this dialog is closed box.
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7. Click Ok.

Enable Generating Debug Information for Your Binary Files

1. Select the analyze_locks project and go to Project > Properties.

2. From the analyze_locks Property Pages dialog box, select Configuration Properties >
General and make sure the selected Configuration (top of the dialog) is Active(Release).

3. From the analyze_locks Property Pages dialog box, select C/C++ > General pane and specify
the Debug Information Format as Program Database (/Zi).

4. From the analyze_locks Property Pages dialog box, select Linker > Debugging and set the
Generate Debug Info option to Yes (/DEBUG).
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Choose a Build Mode and Build a Target

1. Go to the Build > Configuration Manager... dialog box and select the Release mode for your
target project.
2. From the Visual Studio menu, select Build > Build analyze_locks.

The anal yze_| ocks application is built.
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D NOTE. The build configuration for t achyon may initially be set to Debug, which is
typically used for development. When analyzing performance issues with the Amplifier,
you are recommended to use the Release build with normal optimizations. In this way,
the Amplifier is able to analyze the realistic performance of your application.

Create a Performance Baseline

1. From the Visual Studio menu, select Debug > Start Without Debugging.

The anal yze_| ocks application runs in multiple sections (depending on the number of CPUs in
your system).

D NOTE. Before you start the application, minimize the amount of other software running
on your computer to get more accurate results.
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2. Note the execution time displayed in the window caption. For the anal yze_| ocks executable in
the figure above, the execution time is 32.641 seconds. The total execution time is the baseline
against which you will compare subsequent runs of the application.

D NOTE. Run the application several times, note the execution time for each run, and use
the average number. This helps to minimize skewed results due to transient system
activity.
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Recap

You set up your environment to enable generating symbol information for system libraries and your
binary files, built the target in the Release mode, and created the performance baseline. Your
application is ready for analysis.

Key Terms and Concepts

e Term: target, baseline

e Concept: Locks and Waits Analysis

Run Locks and Waits Analysis

After building the application, you can run it to analyze its performance. In this tutorial, you run the
Locks and Waits analysis to identify synchronization objects that caused contention and fix the
problem in the source.

To run an analysis:

1. From the Amplifier toolbar, select Locks and Waits — Where is my program waiting?

2. Click the Profile button.

The Amplifier launches the anal yze | ocks executable that renders bal | s. dat as an input file,
calculates the execution time, and exits. The Amplifier finalizes the collected data and opens the
results in the Locks and Waits result tab.

D NOTE. To make sure the performance of the application is repeatable, go through the
entire tuning process on the same system with a minimal amount of other software
executing.
Recap

You ran the Locks and Waits data collection that analyzes how long the application had to wait on
each synchronization object, or on blocking APIs, such as sl eep() and blocking I/O, and estimates
processor utilization during the wait.
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D NOTE. This tutorial explains how to run an analysis from the Amplifier graphical user
interface (GUI). You can also use the Amplifier command-line interface (anpl - cl
command) to run an analysis. For more details, check the Command-line Interface
Support section of the Amplifier Help.

Key Terms and Concepts

e Term:

e Concept: Locks and Waits Analysis, Finalization

Interpret Result Data

When the sample application exits, the Intel® Parallel Amplifier finalizes the results and opens the
Locks and Waits window displaying CPU time spent on synchronization objects used in your application.
Follow these steps to interpret the locks and waits data:

e Understand the basic performance metrics provided by the Locks and Waits analysis.
e Identify synchronization objects with high Wait time values and poor CPU utilization.

D NOTE. The screen shots and execution time data provided in this tutorial are created
on a system with two CPU cores. Your data may vary depending on the number and type
of CPU cores on your system.
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Understand the Basic Locks and Waits Metrics

Synchronization objects that control threads in the
application. The hash (unique number) appended to some
names of the objects identify the stack creating this
synchronization object.

For Intel® Threading Building Blocks (Intel® TBB), Amplifier
is able to recognize all types of Intel TBB objects. To
display an overhead introduced by Intel TBB library
internals, the Amplifier creates a pseudo synchronization
object TBB scheduler that includes all waits from the
Intel TBB runtime libraries.

The utilization of the processor time when a given thread
waited for some event to occur. By default, the
synchronization objects are sorted by Poor processor
utilization type. Bars showing OK or Ideal utilization
(orange and green) are utilizing the processors well. You
should focus your optimization efforts on functions with

the longest poor CPU utilization (red B bars if the bar
format is selected). Next, search for the longest

over-utilized time (blue . bars).
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This is the Data of Interest column for the Locks and Waits
analysis results. This means that the data of this column
is used for different types of calculations, for example:
call stack contribution, percentage value on the filter
toolbar.

Number of times the corresponding system wait API was
called. For a lock, it is the number of times the lock was
contended and caused a wait. Usually you are
recommended to focus your tuning efforts on the waits
with both high Wait Time and Wait Count values,
especially if they have poor utilization.

Summary data on the application performance: 1) Elapsed Time is the execution time of
the application from start to termination; 2) Wait Time is the amount of time the application
threads waited for some event to occur, such as synchronization waits and I/0O waits; 4)
Wait Count is the overall number of times the system wait API was called for the analyzed
application; 5) Unused CPU Time is the total time for each core when it was either waiting
or not utilized by the application; 6) Core Count is the logical CPU count for your machine;
5) Threads Created by your system during the application run.

Graph representing the Elapsed time and utilization level for the specified number of running
threads. Ideally, your graph nodes should be within the Ok or Ideal utilization range.

Note the Target Concurrency value. By default, this number is equal to the number of
physical cores. Consider this number as your optimization goal.

Average CPU Usage is calculated as CPU time / Elapsed time. Use this number as a baseline
for your performance measurements. The closer this number to the number of cores, the
better.

Identify Locks

Start with analyzing the data provided in the Summary tab. The Summary tab shows that
tachyon_i dentify_concurrency. exe is a multithreaded application running three threads on a
machine with two cores. But it is not using available cores effectively. The Average CPU Usage on
the graph is about 1 while your target should be making it as closer to 2 as possible (for the system
with 2 cores).
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Hover over the second graph node to understand
how long the application ran serially. The tooltip
shows that the application ran one thread for almost
35 seconds, which is classified as Poor CPU
utilization.

Explore the Bottom-up window. You see that the
top three synchronization objects caused the longest
wait time. The red bars in the Wait Time by
Utilization column indicate that most of the time
for these objects processor cores were underutilized.

From the code knowledge, you may understand that
the first two objects are most likely related to the
join where the main program is waiting for the
worker threads to finish. This should not be a
problem. Consider the third item in the Bottom-up
window that is more interesting. It is a Critical
Section that shows much serial time and is causing
a wait. Click the plus sign * at the object name to
expand the node and see the draw_t ask wait
function that contains this critical section and Wait
Function Trees. Double-click the Critical Section to
see the source code for the wait function.

Recap

You identified a synchronization object with the high Wait Time and Wait Count values and poor CPU
utilization that could be a lock affecting application concurrency. Your next step is to analyze the
code of this function.

Key Terms and Concepts

e Term: Elapsed time, Wait time

e Concept: Locks and Waits Analysis, CPU Utilization, Data of Interest
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Analyze Code

You identified the critical section that caused significant Wait time and poor processor utilization.
Double-click this critical section in the Bottom-up window to open the Source window and analyze
the source code:

e Understand basic options provided in the Source window.
e Identify the hottest code lines.

Understand Basic Source View Options

The table below explains some of the features available in the Source window when viewing the
Locks and Waits analysis data.

Source code of the application displayed if the function symbol information is available.
When you go to the source by double-clicking the synchronization object in the
Bottom-up window, the Amplifier opens the wait function containing this object and
highlights the code line that took the most Wait time. The source code in the Source
window is not editable.

If the function symbol information is not available, the Assembly window opens
displaying assembler instructions for the selected wait function. To view the source
code in the Source window, make sure to build the target properly.
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Processor time and utilization bar attributed to a particular code line. The colored bar
represents the distribution of the Wait time according to the utilization levels (Idle,
Poor, Ok, Ideal, and Over) defined by the Amplifier. The longer the bar, the higher the
value. Ok utilization level is not available for systems with a small number of cores.

This is the Data of Interest column for the Locks and Waits analysis.
Number of times the corresponding system wait API was called while this code line was

executing. For a lock, it is the number of times the lock was contended and caused a
wait.

Source file editor button to open and edit your code in the Visual Studio editor.

Identify the Hottest Code Lines

The Amplifier highlights line 170 entering the critical section rgb_criti cal _secti on in the

dr aw_t ask function. The dr aw_t ask function was waiting for almost 28 seconds while this code line
was executing and most of the time the processor was underutilized. During this time, the critical
section was contended 472 times.

Thergb_critical section isthe place where the application is serializing. Each thread has to
wait for the critical section to be available before it can proceed. Only one thread can be in the critical

section at a time. You need to optimize the code to make it more concurrent. Click the Source
Editor button on the Source window toolbar to open the code editor and optimize the code.

Recap

You identified the code section that caused a significant wait and during which the processor was
poorly utilized.

Key Terms and Concepts

e Term: Wait time

e Concept: CPU Utilization, Locks and Waits Analysis, Data of Interest
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Remove Lock

In the Source window, you located the critical section that caused a significant wait while the processor
cores were underutilized and generated multiple wait count. Focus on this line and do the following:

e Open the code editor.
e Modify the code to remove the lock.

Open the Code Editor

Click the Source Editor button to open the anal yze_| ocks. cpp file in the Visual Studio editor
at the hotspot code line:

Remove the Lock

Thergb_critical _section was introduced to protect calculation from multithreaded access. The
brief analysis shows that the code is thread safe and the critical section is not really needed.

To resolve this issue:
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D NOTE. The steps below are provided for Microsoft Visual Studio* 2005. Steps for other

N

versions of Visual Studio IDE may slightly differ. See online help for details.

. Comment out code lines 170 and 178 to disable the critical section.
. From Solution Explorer, select the analyze_locks project.

. From Visual Studio menu, select Build > Rebuild analyze_locks.

The project is rebuilt.

. From Visual Studio menu, select Debug > Start Without Debugging to run the application.

Visual Studio runs the anal yze_| ocks. exe. Note that execution time reduced from 32 seconds
to 19.5 seconds.
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Recap

You optimized the application execution time by removing the unnecessary critical section that caused
a lot of Wait time.

Key Terms and Concepts

e Term: hotspot

e Concept: Locks and Waits Analysis
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Compare with Previous Result

You made sure that removing the critical section gave you 12.5 seconds of optimization in the
application execution time. To understand the impact of your changes and how the CPU utilization
has changed, re-run the Locks and Waits analysis on the optimized code and compare results:

e Compare results before and after optimization.
e Identify the performance gain.

Compare Results Before and After Optimization

1. Run the Locks and Waits analysis on the modified code.

2. Click the button on the Intel® Parallel Amplifier toolbar.

The Compare Results dialog box opens.
3. Specify the Locks and Waits analysis results you want to compare:

The Locks and Waits Bottom-up window opens, showing the list of synchronization objects used
in the code, Wait time utilization across the two results, and the differences side by side:
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Wait time and CPU utilization for the initial
version of the code.

Wait time and CPU utilization for the
optimized version of the code.

Difference in Wait time per utilization level
between the two results in the following
format: <Difference Wait Time> =
<Result 1 Wait Time> - <Result 2 Wait
Time>. By default, the Difference column
is expanded to display comparison data
per utilization level. You may collapse the
column to see the total difference data
per Wait time.

Wait count for the initial version of the
code.

Wait count for the optimized version of
the code.
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6 Difference in Wait count between the two
results in the following format:
<Difference Wait Count> = <Results 1
Wait Count> - <Result 2 Wait Count>.

Comparison summary data for the two results and their difference calculated as r004lw -
ro05lw= Diff.

Logical CPUs Utilized is the average utilization of all cores during application run.

Concurrency graphs for both compared results.

Identify the Performance Gain

In the Bottom-up window, locate the Critical Section you identified as a bottleneck in your code.
Since you removed it during optimization, the optimized result r005Iw does not show any performance
data for this synchronization object. If you collapse the Wait Time:Difference column by clicking
the # button, you see that with the optimized result you got almost 28 seconds of optimization in
Wait time.

The Elapsed time data in the Summary tab shows the optimization of 10.5 seconds for the whole
application execution and Wait time decreased by 57 seconds. According to the concurrency graph
in the Summary tab, before optimization the application ran serially for the most of the time poorly
utlizing available two processor cores but after optimization it ran multiple threads (two to three)
most of the time, sometimes overutilizing the cores.

Recap

You ran the Locks and Waits analysis on the optimized code and compared the results before and
after optimization using the Compare mode of the Amplifier . The comparison shows that, with the
optimized version of the t achyon_anal yze_| ocks application (rO05Iw result), you managed to
effectively utilize all available cores and got 10.5-second speedup for the application Elapsed time.
Compare analysis results regularly to look for regressions and to track how incremental changes to
the code affect its performance. You may also want to use the Amplifier command-line interface and
run the anpl - cI command to test your code for regressions. For more details, see the Command-line
Interface Support section in the Amplifier online help.

Key Terms and Concepts

e Term: hotspot, Wait time, Elapsed time
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e Concept: Locks and Waits Analysis, CPU Utilization

Summary

You have completed the Analyzing Locks and Waits tutorial. Here are some important things to
remember when using the Intel® Parallel Amplifier to analyze your code for locks and waits:

Step 1. Choose and Build Your Target

e Configure the Microsoft* symbol server and your project properties to get the most accurate
results for system and user binaries and to analyze the performance of your application at the
code line level.

e Create a performance baseline to compare the application versions before and after optimization.
Make sure to use the same workload for each application run.

Step 2. Run Analysis

e Use the Amplifier toolbar or Tools menu to choose and run the analysis. You can also run the
analysis from command line using the anpl - cl command.

e If required, modify the default analysis settings from Tools > Options... > Intel Parallel
Amplifier 2011 > Collection. For example, you may limit the data collection to a predefined
amount of data or enable the Amplifier to collect more accurate CPU time data.

Step 3. Interpret Results and Resolve the Issue

e Start analyzing the performance of your application with the Summary tab to explore the
performance metrics for the whole application. Then, move to the Bottom-up window to analyze
the synchronization objects. Focus on the synchronization objects that under- or over-utilized the
available logical CPUs and have the highest Wait time and Wait Count values. By default, the
objects with the highest Wait time values show up at the top of the window.

e Expand the most time-critical synchronization object in the Bottom-up window and double-click
the wait function it belongs to. This opens the source code for this wait function at the code line
with the highest Wait time value.

84



Tutorial: Analyzing Locks and Waits 3

Step 4. Compare Results Before and After Optimization

Perform regular regression testing by comparing analysis results before and after optimization.

From GUI, click the Compare Results button on the Amplifier toolbar. From command line,
use the anpl - ¢l command.

Expand each data column by clicking the [ button to identify the performance gain per CPU
utilization level.

85



3 Intel(R) Parallel Amplifier 2011 for Windows* OS Getting Started Tutorials

86



More Resources

Getting Help

Browsing Help
In the Visual Studio IDE, you can browse and search for topics in different ways:

e Use Help > Contents to open the Contents window and browse the Table of Contents.

e To view help for an installed Parallel Studio tool, select Help > Intel Parallel Studio 2011 > Parallel
Studio Help > Amplifier Help.

e Use Help > Index to open the Index window and access an index to Amplifier topics. Either type in
the keyword you are looking for, or scroll through the list of keywords.

e Use Help > Search to open the Search page and search the full text of topics in the help.

Locating Intel Topics in the Document Explorer

To filter the documentation so that only the Intel documentation appears, select Help > Contents from
the Visual Studio user interface. In the Filtered by: drop-down list, select Intel.

To determine where the currently displayed topic appears in the table of contents (TOC), click the &)
Sync with Table of Contents button on the Visual Studio toolbar to highlight the topic in the Contents
pane.

Activating Intel Search Filters in the Document Explorer

With Microsoft Visual Studio 2005 and 2008, you can include Intel documentation in all search results by
checking the Intel search filter box for the Language, Technology, and Content Type categories. You
must check the Intel search box for all three categories to include Intel documentation in your searches.
Unchecking all three Intel search boxes excludes Intel documentation from search results. The Intel
search filters work in combination with other search options for each category.
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Using Context-Sensitive Help

Context-sensitive help enables easy access to help topics on active GUI elements. The following
context-sensitive help features are available on a product-specific basis:

e ? Help: In Visual Studio, click the ? button, in the upper-right corner of the dialog box or pane
to get help for the dialog box or pane.

e F1 Help: Press F1 to get help for an active dialog box, property page, pane, or window.

e Dynamic Help: In Visual Studio 2005/2008, select Help > Dynamic Help to open the Dynamic
Help window, which displays links to relevant help topics for the current window.

System Requirements

For detailed information on system requirements, see the product Release Notes.

Product Website and Support

Product Website and Support

The following links provide information and support on Intel software products, including Intel®
Parallel Studio:

e http://www.intel.com/software/products/
At this site, you will find comprehensive product information, including:

e Links to each product, where you will find technical information such as white papers and
articles

e Links to user forums

e Links to news and events

e http://software.intel.com/en-us/articles/intel-parallel-studio/

Intel®Software Network, Parallel Studio Support page, with links to support forums, startup help,
knowledge base, and getting started video.

e http://software.intel.com/en-us/articles/tools/
Intel® Software Development Products Knowledge Base.

e http://www.intel.com/software/products/support/
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Technical support information, to register your product, or to contact Intel.

For additional support information, see the Technical Support section of your Release Notes.

System Requirements

For detailed information on system requirements, see the Release Notes.
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