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Legal Information
INFORMATION IN THIS DOCUMENT IS PROVIDED IN CONNECTION WITH INTEL PRODUCTS. NO LICENSE,
EXPRESS OR IMPLIED, BY ESTOPPEL OR OTHERWISE, TO ANY INTELLECTUAL PROPERTY RIGHTS IS
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OF ANY PATENT, COPYRIGHT OR OTHER INTELLECTUAL PROPERTY RIGHT. A "Mission Critical Application" is
any application in which failure of the Intel Product could result, directly or indirectly, in personal injury or
death. SHOULD YOU PURCHASE OR USE INTEL'S PRODUCTS FOR ANY SUCH MISSION CRITICAL
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your distributor to obtain the latest specifications and before placing your product order. Copies of
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http://www.intel.com/design/literature.htm

Intel processor numbers are not a measure of performance. Processor numbers differentiate features within
each processor family, not across different processor families: Go to:

Learn About Intel® Processor Numbers (http://www.intel.com/products/processor_number).

Atom, Cilk and Intel are trademarks of Intel Corporation in the U.S. and/or other countries.

* Other names and brands may be claimed as the property of others.

Copyright © 2001-2013, Intel Corporation. All rights reserved.
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Welcome to the Intel® JTAG Debugger
Usage Guide
This document provides an overview of common Intel® JTAG Debugger use cases. It comprises sections for
common use case clusters such as BIOS debugging or Linux Kernel debugging.

The document addresses users who are generally familiar with JTAG-based software debuggers. An example
of a typical user would be a BIOS engineer who wants to get started with a debugging task or strategy he
has already in mind.

The document does not cover all possible use cases and it is not an exhaustive list of all possible debugger
features. It also does not provide an introduction to system software debugging in general.
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Notational Conventions
Convention Explanation Example

Italic Italic is used for

• emphasis
• the introduction of new terms
• denotation of terms
• placeholders
• titles of manuals

Do not close the project without
saving.

The filename consists of the basename
and the extension.

The expression and/or denotes an
inclusive choice between two or more
items.

The bitmap is width pixels wide and
len pixels high.

Bold Text in boldface denotes elements of the
graphical user interface.

The Cancel button of the Start dialog
box

Monospace Monospace indicates

• filenames, directory names and
pathnames

• commands and command-line options
• function names, methods, classes,

data structures in body text
• source code

• ippsapi.h \alt\include ecl-O2
• Use the CreateObj()function to
• printf("hello, world\n");

Monospace
italic

Italic monospace indicates source code
parameters, arguments, or other
placeholders.

ippiMalloc( int width, int* pStep);

Monospace bold Bold monospace indicates what you type
as input on a command line or
emphasizes parts of source code.

• [c:] dir
• x = ( h > 0 ? sizeof(m) :

0xF ) + min;

[ ] Items enclosed in brackets are optional. Fa[c]

Indicates Fa or Fac.

{ | } Braces and vertical bars indicate the
choice of one item from a selection of two
or more items.

X{A | B | C}

Indicates one of XA, XB, and XC.

"[" "]" "{"

"}" "|"

Writing a metacharacter in quotation
marks negates the syntactical meaning
stated above; the character is taken as a
literal.

"[" X "]" [ Y ]

denotes the letter X enclosed in
brackets, optionally followed by the
letter Y.

… The ellipsis indicates that the previous
item can be repeated several times.

filename …

Indicates that one or more filenames
can be specified.

,… The ellipsis preceded by a comma
indicates that the previous item can be
repeated several times, separated by
commas.

word ,…

Indicates that one or more words can
be specified. If more than one word is
specified, the words are comma-
separated.
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Convention Explanation Example

> Indicates a menu item inside a menu. File > Close

indicates to select the Close item from
the File menu.

   Use Cases for the Intel® JTAG Debugger
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Debugging Basics 1
To debug your software using source code you need to load debug information that is used to map the
program in target memory to the original source files. To do this the debugger needs the following:

• A program loaded in target memory that has been compiled with debug information
• The load address of the program in target memory
• The program binary file (executable file)
• Debug information file for the program binary (also referred to as "symbols")
• Original program source code

NOTE With ELF/DWARF format files the debug information is generally included in the original
program binary. When using the Microsoft* Compiler, the debug information is placed in a separate
file with the .pdb extension, in this case both the executable file and the PDB file are required and
should be in the same directory.

Loading Symbols and Source Code

1. Select File > Load/Unload Symbol file from the debugger menu.
2. Specify the program binary and an optional Offset parameter:

For fixed-offset modules, such as most Linux* kernels: leave the Offset parameter blank, this will
cause the debugger to use the load offset encoded into the program binary at compile time.

For dynamically located modules, such as Kernel modules/drivers, and EFI BIOS modules, you need to
specify the base address of the image in memory. Note that in some cases the debugger provides
special helper functions to accomplish this, see also Debugging the Linux Kernel and Debugging EFI
BIOS.

Navigating and Browsing Source Files

1. Select View > Source Files from the debugger menu to display the source files described by the
debug information.

The files are displayed in a tree view corresponding to the filesystem paths encoded into the debug
information.

2. Double-click a file to open it.

In the case where the source files on the host system do not match the paths encoded in the debug
information you can use Options > Source Directories to specify either folders to search in (non-
recursive) or path replacement rules , for example, change

c:\mybuildfiles to e:\mydebugfiles.

Navigating and Browsing Debug Symbols
The debugger keeps an internal list of all symbols, such as function names, variable names and types.

Select Debug > Symbol Browser... from the debugger menu to search the list of symbols for a particular
function or variable.
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Further information
For further information about debugging with the Intel® JTAG Debugger, refer to the Intel® JTAG Debugger
User and Reference Guide.

 1  Use Cases for the Intel® JTAG Debugger
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Debugging with Instruction
Trace 2
Some software errors are hard to reproduce, can be found under certain environments and circumstances
only, are timing-based, or occur only after a longer time of using the product. Also, some errors do not occur
when the software runs under control of a debugger. To handle these situations effectively, you can use
instruction tracing to reconstruct the program execution flow.

Use Case: Tracing the Execution Until a Breakpoint
Quicksteps:

In order to trace the code path that led to a certain point:

• set a breakpoint at the interesting location
• enable the instruction trace
• run the target until it stops at the specified breakpoint
• view the instruction trace

All steps are described in detail below.

1. Make sure the target is stopped. Select Debug > Create Breakpoint... and set a breakpoint at the
desired location.

2. To enable the execution trace:
a. Select View > Instruction Trace .

The Instruction Trace window is opened.
b. Right-click in the window and select Enable Trace from the window's pop-up menu.

The Console window displays: itrace: LBR configuration: Trace enabled.
3. Run or continue the target and let it execute some code (at least one branch instruction).

The target stops at the breakpoint specified in step 1.
4. To show the collected instruction trace, enter itrace "print" in the Console window.

The Console window prints the output, for example:
xdb> itrace "print"
process.c:459    cpu_idle(void)
if (cpuidle_idle_call())
    0xC100A125    E8 B6 A7 44 00                      call 0xC14548E0 <cpuidle_idle_call(void)>
cpuidle.c:129    cpuidle_idle_call(void)
{
    0xC14548E0    55                                  push ebp
    0xC14548E1    89 E5                               mov ebp, esp
    0xC14548E3    57                                  push edi
    0xC14548E4    56                                  push esi
    0xC14548E5    53                                  push ebx
    0xC14548E6    83 EC 18                            sub esp, 0x18
    0xC14548E9    3E 8D 74 26 00                      lea esi, ptr [esi]
return -ENODEV;
    0xC14548EE    BB ED FF FF FF                      mov ebx, 0xFFFFFFED
The Instruction Trace window is automatically updated, for example:
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Debugging EFI BIOS 3
Because the EFI environment uses relocatable code modules, you need to specify the address of a code
module when loading it into the debugger. This address is usually unknown to you, so that you need a
method to locate the modules in memory.

The Intel® JTAG debugger provides two general methods for locating code modules in memory:

1. Identify the specific module located at a certain memory address (for example, at the instruction
pointer)

2. List all modules that are known by the EFI runtime so that you can choose a specific module to load
symbols for

The first class of methods relies only on the module of interest. The debugger can scan memory near the
given address and attempt to locate the module header which contains sufficient data to load symbols.

The second class of methods involves locating an EFI data structure in memory (or flash) and enumerating
the list of loaded modules described there. It is dependent on a-priori knowledge of certain data structures
such as the EFI System Table Pointer or the Flash Volume.

Use Case: Identifying and Loading Symbols for a Module at a
Certain Address
To load symbols for a specific address, use the EFI "LOADTHIS" command. This command identifies the
module at the indicated address and loads symbols for it. If no address is provided, the current instruction
pointer is used.

Note that this method is not really EFI-specific, it will detect any PE/COFF image in target memory, and it is
only dependent on the debug information compiled into the PE/COFF header, not on any other EFI data
structures.

Example 1
Using instruction pointer as the search address:
xdb> efi "loadthis"
INFO: Software debugger set to: efi64 - EFI/PI compliant BIOS (64-bit mode)
INFO: Using DRAM search semantics, align=0x00001000 range=0x00100000
INFO: Searching backwards from 0x00000000809FB6C3 to 0x00000000808FB6C3 for PE/COFF header
INFO: Found PE/COFF module at 0x00000000809FB000 - 0x00000000809FF1C0 (size: 16832 bytes)
INFO: Loading debug symbols found at: 
e:\dev.efi\work\Build\MdeModule\NOOPT_VS2008x86\X64\MdeModulePkg\Application\xdbefiutil\xdbefiutil\DEBUG
\xdbefiutil.efi

Example 2
Specifying a known address:
xdb> efi "loadthis 0xFFF98765"
INFO: Software debugger set to: efi32 - EFI/PI compliant BIOS (32-bit mode)
INFO: Using FLASH search semantics, align=0x00000004 range=0x00100000
INFO: Searching backwards from 0x00000000FFF98765 to 0x00000000FFE98765 for PE/COFF header
INFO: Found PE/COFF module at 0x00000000FFF97B04 - 0x00000000FFFA1A64 Entrypoint: 0x00000000FFF99E89 
(size: 40800 bytes)

NOTE Depending on the searched object (for example RAM or flash modules), the debugger uses
different search semantics. These can be configured, enter the command EFI "SHOWHELP" for more
information.
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Use Case: Listing Loaded Modules (DXE Phase)

1. To list all modules in the DXE phase, it is required to specify the system table pointer:

a. Enter the command EFI "SETSYSTAB address" to specify the system table pointer at a given
address.

b. Alternatively, enter EFI "SETSEARCHRANGE startaddress endaddress" to have the debugger
search for a valid system table pointer within a given address range.

2. To verify the system table, enter EFI SHOWSYSTAB.
3. Once a valid system table is located, enter EFI SHOWMODULES to display a list of all found EFI modules.
4. To load an identified module, enter EFI LOAD modulename.

Example 1
Specifying the system table at a given address:
xdb> efi "setsystab 0xaf536f18"
xdb> efi showsystab
INFO: Software debugger set to: efi64 - EFI/PI compliant BIOS (64-bit mode)
INFO: Reading EFI_DEBUG_IMAGE_INFO table, this could take a little while...
EFI System table at 0x00000000AF536F18
Configuration Tables:
________________________________________________________________________
GUID:                              Pointer:    Name:
GUID 05ad34ba, 6f02, 4214, {...}   0xae72bdb0  DXE_SERVICES_TABLE
GUID 7739f24c, 93d7, 11d4, {...}   0xaef17018  HOB_LIST
GUID 4c19049f, 4137, 4dd3, {...}   0xae72c7b0  
GUID 49152e77, 1ada, 4764, {...}   0xae72d150  EFI_DEBUG_IMAGE_INFO_TABLE
GUID 8868e871, e4f1, 11d3, {...}   0xaf7fef98  EFI_ACPI_20_TABLE
GUID eb9d2d31, 2d88, 11d3, {...}   0xaf533218  SMBIOS_TABLE

Example 2
Searching for modules in a given address range:
xdb> efi "setsearchrange 0x78500000 0x786f0000"
INFO: Software debugger set to: efi32 - EFI/PI compliant BIOS (32-bit mode)
xdb> efi showsystab
INFO: Software debugger set to: efi32 - EFI/PI compliant BIOS (32-bit mode)
INFO: Searching backwards from 0x00000000786F0000 to 0x0000000078500000 for EFI System Table...
INFO: Found valid EFI System Table Pointer at address: 0x00000000786DBF90

Example 3
Displaying found modules:
xdb> efi showmodules
INFO: Software debugger set to: efi64 - EFI/PI compliant BIOS (64-bit mode)
INFO: Using cached EFI State Information
________________________________________________________________________
ModuleID  Base                Size        Name
00000     0x00000000AE71C000  0x00013F51  DxeMain.efi
00001     0x00000000AF485000  0x000076C0  EBC.efi
00002     0x00000000AF4FF000  0x0000D120  Runtime.efi
00003     0x00000000AF3CE000  0x000B6E00  CORE_DXE.efi
00004     0x00000000AF3BE000  0x0000F960  AmiBoardInfo.efi

 3  Use Cases for the Intel® JTAG Debugger
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Example 4
Loading an identified module:
xdb> efi "load Shell.efi"
INFO: Software debugger set to: efi64 - EFI/PI compliant BIOS (64-bit mode)
INFO: Using cached EFI State Information
INFO: Loading debug symbols found at: 
e:\efi\work\Build\Shell\DEBUG_VS2008x86\X64\ShellPkg\Application\Shell\Shell\DEBUG\Shell.efi

Further Information
For further information about EFI BIOS debugging commands, enter EFI SHOWHELP.

This command displays a list of available EFI commands, for example:
xdb> efi showhelp
EFI debugger extension
Enter any of the following on the command line:
efi showconfig             - show debugger configuration
efi "setswmode <mode>"   - set the software mode of the debugger (see also showconfig)
efi showmodules            - print a list of all known modules
efi "load <modulename>"  - try to load symbols for the supplied module name (e.g. mymodule.efi)

NOTE Commands that require parameters, such as mode or modulename, must be quoted!

See also the Intel® JTAG Debugger Reference documentation.

Debugging EFI BIOS  3 
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Debugging the Linux Kernel 4
Use Case: Loading Symbols for the Linux* Kernel
To load Linux* kernel symbols:

1. Select File > Load/Unload Symbol File....
The Load dialog box opens.

2. Specify the "vmlinux" kernel image as the symbol file to load and click OK.

NOTE Leave the "Offset" parameter blank, this will cause the debugger to use the offset that is
encoded into the image to locate the executable code in target memory.

Once the symbol information is loaded the debugger refreshes and displays source code for the current
execution point (if it is halted in kernel code).

Use Case: Setting a Breakpoint at the Beginning of Kernel
Initialization
In many cases you may want to stop target execution early during kernel initialization in order to walk up to
some point of failure. The easiest way to do this is to set a hardware breakpoint on the start_kernel
function in the Linux kernel.

Quicksteps:

1. Stop the target prior to kernel execution.
2. Load the kernel symbols.
3. Create a hardware breakpoint at the start_kernel function.
4. Resume target execution until the breakpoint is hit.

All steps are described in detail below.

1. To stop the target prior to kernel execution, choose one of the following steps:

• Reset the target and stop at the reset vector.
• Boot the target to the OS boot loader or BIOS boot selection screen and stop the target execution in

the debugger.
2. Use the LOAD command to load your kernel symbols. See also Use Case: Loading Symbols for the

Linux* Kernel.
3. Select View > Source Files to open the Source Files window.
4. Double-click the file main.c and search for the start_kernel function in the source code of this file.
5. Select Debug > Create Breakpoint... to open the Create Breakpoint dialog box.
6. In the Location field, enter start_kernel.
7. Check the Hard checkbox.
8. Click OK.

The breakpoint is set and is displayed with a red icon at the start_kernel function in the Source
window of main.c.

9. Select Run > Run or Continue to resume the target execution.
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The target stops at the breakpoint you set. A yellow pointer in the Source window indicates the current
execution point is at your breakpoint.

 4  Use Cases for the Intel® JTAG Debugger
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