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Overview

 Discover how to use the Locks and Waits analysis of Intel® VTune™ Amplifier to identify one of the most
common reasons for an inefficient parallel application - threads waiting too long on synchronization objects
(locks) while processor cores are underutilized. Focus your tuning efforts on objects with long waits where
the system is underutilized.

About This
Tutorial

This tutorial uses the sample analyze_locks application and guides you through
basic steps required to analyze the code for locks and waits.

Estimated
Duration

10-15 minutes.

Learning
Objectives

After you complete this tutorial, you should be able to:

• Choose an analysis target.
• Choose the Locks and Waits analysis type.
• Run the Locks and Waits analysis.
• Identify the synchronization objects with long waits and poor thread concurrency

level.
• Analyze the source code to locate the most critical code lines.
• Compare results before and after optimization.

More Resources • Intel VTune Amplifier tutorials (HTML, PDF): https://software.intel.com/en-us/
articles/intel-vtune-amplifier-tutorials/

• Intel VTune Amplifier support page: https://software.intel.com/en-us/intel-vtune-
amplifier-xe-support/

• Intel Parallel Studio XE support page: https://software.intel.com/en-us/intel-
parallel-studio-xe/

• Intel System Studio support page: https://software.intel.com/en-us/intel-system-
studio/

Start Here
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Navigation Quick Start 1
 Intel® VTune™ Amplifier provides information on code performance for users developing serial and

multithreaded applications on Windows*, Linux*, Android, and OS X* operating systems. VTune Amplifier
helps you analyze algorithm choices and identify where and how your application can benefit from available
hardware resources.

VTune Amplifier XE Access
To access the VTune Amplifier in the Visual Studio* IDE: From the Windows* Start menu, choose Intel
Parallel Studio XE version > Parallel Studio XE version with [VS2012 | VS2013 | VS2015].

To access the Standalone VTune Amplifier GUI, do one of the following:

• From the Windows* Start menu, choose Intel Parallel Studio XE version > Intel VTune Amplifier XE
version.

• From the Windows* Start menu, choose Intel Parallel Studio XE version > Command Prompt >
Parallel Studio XE > IA-32 Visual Studio [2012 | 2013 | 2015] mode to set your environment, then
type amplxe-gui. You can also set the environment manually by running the <install-dir>\amplxe-
vars.bat file.

VTune Amplifier for Systems Access
To access the VTune Amplifier in the Visual Studio* IDE: From the Windows* Start menu, choose Intel
Parallel Studio XE version > Parallel Studio XE version with [VS2012 | VS2013 | VS2015].

To access the Standalone VTune Amplifier GUI, do one of the following:

• From the Windows* Start menu, choose Intel VTune Amplifier <version> for Systems
•

From Eclipse*, click the Launch Intel VTune Amplifier button from the toolbar or select the Intel
System Studio > VTune Amplifier > Launch VTune Amplifier menu option

Navigation Quick Start  1  
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VTune Amplifier/Visual Studio* IDE Integration

Use the VTune Amplifier toolbar to configure and control result collection.

VTune Amplifier results *.amplxe show up in the Solution Explorer under the Amplifier XE
Results folder. To configure and control result collection, right-click the project in the Solution
Explorer and select the Intel VTune Amplifier XE version menu from the pop-up menu. To
manage previously collected results, right-click the result (for example, r000hs.amplxe) and select
the required command from the pop-up menu.

Click the (change) link to select a viewpoint, a preset configuration of windows/panes for an
analysis result. For each analysis type, you can switch among several viewpoints to focus on
particular performance metrics.

Click the buttons on navigation toolbars to change window views and toggle window panes on and
off.

In the Timeline pane, analyze the thread activity and transitions presented for the user-mode
sampling and tracing analysis results (for example, Basic Hotspots, Concurrency, Locks and Waits) or
analyze the distribution of the application performance per metric over time for the event-based
sampling analysis results (for example, Memory Access).

Use the Call Stack pane to view call paths for a function selected in the grid.

  1   Tutorial: Analyzing Locks and Waits
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Use the filter toolbar to filter out the result data according to the selected categories.

Standalone VTune Amplifier GUI

Configure and manage projects and results, and launch new analyses from the primary toolbar. Click
the Configure Project button on this toolbar and use the Analysis Target tab to manage result file
locations. Newly completed and opened analysis results along with result comparisons appear in the
results tab for easy navigation.

Use the VTune Amplifier menu to control result collection, define and view project properties, and set
various options.

The Project Navigator provides an iconic representation of your projects and analysis results. Click
the Project Navigator button on the toolbar to enable/disable the Project Navigator.

Click the (change) link to select a viewpoint, a preset configuration of windows/panes for an
analysis result. For each analysis type, you can switch among several viewpoints to focus on
particular performance metrics. Click the yellow question mark icon to read the viewpoint
description.

Switch between window tabs to explore the analysis type configuration options and collected data
provided by the selected viewpoint.

Use the Grouping drop-down menu to choose a granularity level for grouping data in the grid.

Navigation Quick Start  1  
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Use the filter toolbar to filter out the result data according to the selected categories.

See Also
Click here for more Getting Started Tutorials
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Analyzing Locks and Waits 2
 You can use Intel® VTune™ Amplifier to understand the cause of the ineffective processor utilization by

performing a series of steps in a workflow. This tutorial guides you through these workflow steps while using
a sample ray-tracer application named tachyon.

Step 1. Prepare for
analysis

Do one of the following:

• Visual Studio* IDE: Choose a project, verify settings, build application,
and create a baseline.

• Standalone GUI: Build an application, create a performance baseline,
and configure a new VTune Amplifier project.

Step 2. Find lock • Choose and run the Locks and Waits analysis.
• Interpret the result data.
• View and analyze code of the performance-critical function.

Step 3. Remove lock Modify the code to remove the lock.

Step 4. Check your work Re-build the target, re-run the Locks and Waits analysis, and compare
the result data before and after optimization.

Visual Studio* IDE: Choose Project and Build Application

 Before you start analyzing your application for locks, do the following:

1. Get software tools.
2. Choose a project.

Analyzing Locks and Waits  2  
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3. Configure the Microsoft* symbol server.
4. Verify optimal compiler/linker options.
5. Build the target in the release mode.
6. Create a performance baseline.
7. Launch the VTune Amplifier from Microsoft Visual Studio

NOTE

• The steps below are provided for Microsoft Visual Studio* 2013. Steps for other versions of Visual
Studio IDE may slightly differ. See online help for details.

• Steps provided by this tutorial are generic and applicable to any application. You may choose to
follow the proposed workflow using your own application.

Get Software Tools
You need the following tools to try tutorial steps yourself using the tachyon sample application:

• Intel® VTune™ Amplifier
• zip file extraction utility
• Supported compiler (see Release Notes for more information)

Acquire Intel VTune Amplifier

If you do not already have access to the VTune Amplifier, you can download an evaluation copy from http://
software.intel.com/en-us/articles/intel-software-evaluation-center/.

NOTE
This document focuses on using the VTune™ Amplifier in Intel® Parallel Studio XE Professional Edition.
You may see minor differences if you installed a different Intel product. For more information on
product capabilities in your installed product, see the product-specific supplemental documentation in
<install-dir>/<Intel_product>/documentation/.

Install and Set Up VTune Amplifier Sample Applications

1. Download the tachyon sample application files to from the Intel Software Product Samples and Tutorials
site: https://software.intel.com/en-us/product-code-samples. The tachyon sample is available as a
separate ZIP download or as part of the Intel Parallel Studio or Intel System Studio sample bundles.

2. Extract the sample from the .zip file to a writeable directory or share on your system.

NOTE

• Samples are non-deterministic. Your screens may vary from the screen captures shown throughout
this tutorial.

• Samples are designed only to illustrate the VTune Amplifier features; they do not represent best
practices for creating code.

Choose a Project
Choose a project with the analysis target in the Visual Studio IDE as follows:

1. From the Visual Studio menu, select File > Open > Project/Solution....

The Open Project dialog box opens.
2. In the Open Project dialog box, browse to the location you used to unzip the

tachyon_vtune_amp_xe.zip file and select the tachyon_vtune_amp_xe.sln file.

  2   Tutorial: Analyzing Locks and Waits
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The solution is added to Visual Studio and shows up in the Solution Explorer.
3. In the Solution Explorer, right-click the analyze_locks project and select Set as StartUp Project.

analyze_locks appears in bold in the Solution Explorer.

Configure the Microsoft* Symbol Server
Configure the Visual Studio environment to download the debug information for system libraries so that the
VTune Amplifier can properly identify system functions and classify/attribute functions.

1. Go to Tools > Options....

The Options dialog box opens.
2. From the left pane, select Debugging > Symbols.
3. In the Symbol file (.pdb) locations field, make sure the Microsoft Symbol Servers location is

selected. Otherwise, click the Add button, specify the following address: http://
msdl.microsoft.com/download/symbols, and make sure the added address is checked.

4. In the Cache symbols in this directory field, specify a directory where the downloaded symbol files
will be stored.

Analyzing Locks and Waits  2  

11



5. Click Ok.

Verify Optimal Compiler/Linker Options
Configure Visual Studio project properties to generate the debug information for your application so that the
VTune Amplifier can open the source code.

1. Select the analyze_locks project and go to Project > Properties.
2. From the analyze_locks Property Pages dialog box, select Configuration Properties > General

and make sure the selected Configuration (top of the dialog) is Release.
3. From the analyze_locks Property Pages dialog box, select C/C++ > General pane and specify the

Debug Information Format as Program Database (/Zi).

  2   Tutorial: Analyzing Locks and Waits
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4. From the analyze_locks Property Pages dialog box, select Linker > Debugging and set the
Generate Debug Info option to Yes (/DEBUG).

5. Click Ok.

Build the Target in the Release Mode
Configure Visual Studio project properties to generate the debug information for your application so that the
VTune Amplifier can open the source code.

1. Go to the Build > Configuration Manager... dialog box and select the Release mode for your target
project.

2. From the Visual Studio menu, select Build > Build analyze_locks.

The analyze_locks.exe application is built.

Analyzing Locks and Waits  2  
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NOTE
The build configuration for tachyon may initially be set to Debug, which is typically used for
development. When analyzing performance issues with the VTune Amplifier, you are recommended to
use the Release build with normal optimizations. In this way, the VTune Amplifier is able to analyze the
realistic performance of your application.

Create a Performance Baseline
1. From the Visual Studio menu, select Debug > Start Without Debugging.

The analyze_locks.exe application runs in multiple sections (depending on the number of CPUs in
your system).

NOTE
Before you start the application, minimize the amount of other software running on your computer to
get more accurate results.

  2   Tutorial: Analyzing Locks and Waits
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2. Note the execution time displayed in the window caption. For the analyze_locks.exe executable in
the figure above, the execution time is 16.848 seconds. The total execution time is the baseline against
which you will compare subsequent runs of the application.

NOTE
Run the application several times, note the execution time for each run, and use the average number.
This helps to minimize skewed results due to transient system activity.

Launch the VTune Amplifier from Microsoft Visual Studio

To run an analysis from the Visual Studio IDE, click the New Analysis button on the VTune Amplifier
toolbar. The VTune Amplifier uses your current project as the target application and the tachyon directory as
the working directory where the analysis results will be stored.

Key Terms
Target

Next Step
Run Locks and Waits Analysis

Standalone GUI: Build Application and Create New Project

 Before you start analyzing your application for locks and waits, do the following:

1. Get software tools.
2. Build application.

If you build the code in Visual Studio*, make sure to:

• Configure the Microsoft* symbol server.
• Verify optimal compiler/linker options.
• Build the target in the release mode.

3. Create a performance baseline.
4. Create a VTune Amplifier project.

Get Software Tools
You need the following tools to try tutorial steps yourself using the tachyon sample application:

• Intel® VTune™ Amplifier
• zip file extraction utility
• Supported compiler (see Release Notes for more information)

Acquire Intel VTune Amplifier

If you do not already have access to the VTune Amplifier, you can download an evaluation copy from http://
software.intel.com/en-us/articles/intel-software-evaluation-center/.

Install and Set Up VTune Amplifier Sample Applications

1. Download the tachyon sample application files to from the Intel Software Product Samples and Tutorials
site: https://software.intel.com/en-us/product-code-samples. The tachyon sample is available as a
separate download or as part of the Intel Parallel Studio or Intel System Studio sample bundles.

2. Extract the sample from the zip file to a writeable directory or share on your system.

Analyzing Locks and Waits  2  
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NOTE

• Samples are non-deterministic. Your screens may vary from the screen captures shown throughout
this tutorial.

• Samples are designed only to illustrate the VTune Amplifier features; they do not represent best
practices for creating code.

• The steps below are provided for Microsoft Visual Studio* 2013. Steps for other versions of Visual
Studio IDE may differ slightly.

Configure the Microsoft* Symbol Server
Configure the Visual Studio environment to download the debug information for system libraries so that the
VTune Amplifier can properly identify system functions and classify/attribute functions.

1. Go to Tools > Options....

The Options dialog box opens.
2. From the left pane, select Debugging > Symbols.
3. In the Symbol file (.pdb) locations field, make sure the Microsoft Symbol Servers location is

selected. Otherwise, click the Add button, specify the following address: http://
msdl.microsoft.com/download/symbols, and make sure the added address is checked.

4. In the Cache symbols in this directory field, specify a directory where the downloaded symbol files
will be stored.

5. Click Ok.

  2   Tutorial: Analyzing Locks and Waits
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Verify Optimal Compiler/Linker Options
Configure Visual Studio project properties to generate the debug information for your application so that the
VTune Amplifier can open the source code.

1. Select the analyze_locks project and go to Project > Properties.
2. From the analyze_locks Property Pages dialog box, select Configuration Properties > General

and make sure the selected Configuration (top of the dialog) is Release.
3. From the analyze_locks Property Pages dialog box, select C/C++ > General pane and specify the

Debug Information Format as Program Database (/Zi).

4. From the analyze_locks Property Pages dialog box, select Linker > Debugging and set the
Generate Debug Info option to Yes (/DEBUG).

5. Click Ok.

Build the Target in the Release Mode
Build the target in the Release mode with full optimizations, which is recommended for performance analysis.

1. Go to the Build > Configuration Manager... dialog box and select the Release mode for your target
project.

Analyzing Locks and Waits  2  
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2. From the Visual Studio menu, select Build > Build analyze_locks.

The analyze_locks.exe application is built.

NOTE
The build configuration for tachyon may initially be set to Debug, which is typically used for
development. When analyzing performance issues with the VTune Amplifier, you are recommended to
use the Release build with normal optimizations. In this way, the VTune Amplifier is able to analyze the
realistic performance of your application.

Create a Performance Baseline
1. From the Visual Studio menu, select Debug > Start Without Debugging.

The analyze_locks application runs in multiple sections (depending on the number of CPUs in your
system).

NOTE
Before you start the application, minimize the amount of other software running on your computer to
get more accurate results.

  2   Tutorial: Analyzing Locks and Waits
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2. Note the execution time displayed in the window caption. For the analyze_locks executable in the
figure above, the execution time is 16.848 seconds. The total execution time is the baseline against
which you will compare subsequent runs of the application.

NOTE
Run the application several times, note the execution time for each run, and use the average number.
This helps to minimize skewed results due to transient system activity.

Create a Project
1. From the Start menu launch Intel VTune Amplifier version.
2.

Click the  menu button and select New > Project... to create a new project.

The Create a Project dialog box opens.
3. Specify the project name tachyon that will be used as the project directory name, browse to a location

for the project files to be stored and click Create Project.

VTune Amplifier creates the tachyon project directory under the specified directory and opens the
Analysis Target tab.

Analyzing Locks and Waits  2  
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4. From the left pane, select local host as the target system and Launch Application as the target type.

The configuration pane on the right is updated with the settings applicable to the selected target type.
5. Specify and configure your target as follows:

• For the Application field, browse to: <tachyon_dir>\analyze_locks.exe .
• For the Application parameters field, specify <tachyon_dir>\dat\balls.dat.

6. Click the Choose Analysis button on the right to switch to the Analysis Type tab.

Key Terms
• Baseline
• Target

Next Step
Run Locks and Waits Analysis

Run Locks and Waits Analysis

 In this tutorial, you run the Locks and Waits analysis to identify synchronization objects that caused
contention and fix the problem in the source.

To run an analysis:

1. On the Analysis Type tab, select Locks and Waits.

The right pane is updated with the default options for the Locks and Waits analysis.
2. Click the Start button to begin analysis.

  2   Tutorial: Analyzing Locks and Waits
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Intel® VTune™ Amplifier launches the analyze_locks executable that takes balls.dat as input and renders
an image displaying the execution time before exiting. VTune Amplifier finalizes the collected data and opens
the results in the Locks and Waits viewpoint.

NOTE

• To make sure the performance of the application is repeatable, go through the entire tuning
process on the same system with a minimal amount of other software executing.

• This tutorial explains how to run an analysis from the VTune Amplifier graphical user interface
(GUI). You can also use the VTune Amplifier command-line interface (amplxe-cl command) to run
an analysis. A simple way to get the appropriate command syntax is by clicking the Command
Line button at the bottom of the Analysis Type tab. For more details, check the Intel VTune
Amplifier Command Line Interface section of the VTune Amplifier Help.

Key Terms
• Finalization
• Viewpoint

Next Step
Interpret Result Data

Interpret Result Data

 When the sample application exits, the Intel® VTune™ Amplifier finalizes the results and opens the Locks
and Waits viewpoint where each window or pane is configured to display CPU time utilization of the
synchronization objects during a wait. To interpret the data on the sample code performance, do the
following:

1. Analyze the basic performance metrics provided by the Locks and Waits analysis.
2. Identify locks.

NOTE
The screen shots and execution time data provided in this tutorial are created on a system with 4 CPU
cores. Your data may vary depending on the number and type of CPU cores on your system.

Analyzing Locks and Waits  2  
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Analyze the Basic Locks and Waits Metrics
Start with exploring the data provided in the Summary window for the whole application performance. To

interpret the data, hover over the question mark icons  to read the pop-up help and better understand
what each performance metric means.

The Result Summary section provides data on the overall application performance per the following
metrics:

• Elapsed Time is the total time the application ran, including data allocation and calculations.
• Wait Time occurs when software threads are waiting due to APIs that block or cause synchronization.

Wait Time is calculated per thread, so the total Wait time may exceed the application Elapsed time.
Expand the Wait Time metric to view a distribution per processor utilization levels. In the sample
application, most of the Wait time is characterized with an ineffective processor usage.

• Wait Count is the overall number of times the system wait API was called for the analyzed application.
• Spin Time is the time a thread is active in a synchronization construct; the current value exceeds the

threshold, so it is classified as a performance issue and flagged. Hover over a flag to learn more about an
issue.

• CPU Time is the sum of CPU time for all threads.
• Total Thread Count is the number of threads in the application.
• Paused Time is the amount of Elapsed time during which the analysis was paused via GUI, CLI

commands, or user API.

For the analyze_locks application, the Wait time is high. To identify the cause, you need to understand how
this Wait time was distributed per synchronization objects.

The Top Waiting Objects section provides the list of synchronization objects with the highest Wait Time and
Wait Count, sorted by the Wait Time metric.

  2   Tutorial: Analyzing Locks and Waits
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For the analyze_locks application, focus on the first three objects and explore the Bottom-up pane data
for more details.

The Thread Concurrency Histogram represents the Elapsed time and concurrency level for the specified
number of running threads. Ideally, the highest bar of your chart should be within the Ok or Ideal utilization
range.

Note the Target Concurrency value. By default, this number is equal to the number of physical cores.
Consider this number as your optimization goal.

For the sample code, the chart shows that analyze_locks is a multithreaded application running maximum
4 threads simultaneously on a machine with 4 cores. But it is not using available cores effectively.

Hover over the second bar to understand how long the application ran serially. The tooltip shows that the
application ran one thread for 5.774 seconds, which is classified as Poor concurrency.

The CPU Usage Histogram represents the Elapsed time and usage level for the logical CPUs. Ideally, the
highest bar of your chart should be within the Ok or Ideal utilization range.

Analyzing Locks and Waits  2  
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The analyze_locks application was either idle or ran on one logical CPU. If you hover over the second bar,
you see that it spent 4.009 seconds using one core only, which is classified by the VTune Amplifier as a Poor
utilization. To understand what prevented the application from using all available logical CPUs effectively,
explore the Bottom-up pane.

Identify Locks
Click the Bottom-up tab to open the Bottom-up pane.

Synchronization objects that control threads in the application. The hash (unique number)
appended to some names of the objects identify the stack creating this synchronization object.

For Intel® Threading Building Blocks (Intel® TBB), VTune Amplifier is able to recognize all types of
Intel TBB objects. To exclude Intel TBB internals and focus only on the user code, you may switch
to the Only user functions call stack mode in the filter bar.

The utilization of the processor time when a given thread waited for some event to occur. By
default, the synchronization objects are sorted by Wait Time by Thread Concurrency. Bars
showing OK or Ideal level (orange and green) show effective thread concurrency for existing
number of cores. You should focus your optimization efforts on functions with the longest poor

concurrency (red  bars if the bar format is selected). Next, search for the longest over-utilized

time (blue  bars).

Number of times the corresponding system wait API was called. For a lock, it is the number of
times the lock was contended and caused a wait. Usually you are recommended to focus your
tuning efforts on the waits with both high Wait Time and Wait Count values, especially if they
have poor utilization.

Wait time, during which the CPU is busy. This often occurs when a synchronization API causes the
CPU to poll while the software thread is waiting. Some Spin time may be preferable to the
alternative of the increased thread context switches. However, too much Spin time can reflect lost
opportunity for productive work.

For the analyzed sample code, you see that the second object caused the longest Wait Time with Poor thread
concurrency. The red bar in the Wait Time by Thread Concurrency column indicates that most of the time
for this object processor cores were underutilized. It is a Critical Section that shows much serial time and is
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causing a wait. Click the arrow sign  at the object name to expand the node and see the draw_task wait
function that contains this critical section and call stack. Double-click this wait function to see the source
code.

Key Terms
• CPU usage
• Elapsed time
• Wait time

Next Step
Analyze Code

Analyze Code

 You identified the critical section that caused significant Wait time and poor processor utilization.
Double-click this critical section in the Bottom-up pane to view the source. Intel® VTune™ Amplifier opens
source and disassembly code. Focus on the Source pane and analyze the source code:

1. Understand basic options provided in the Source window.
2. Identify the hottest code lines.

Understand Basic Source View Options

The table below explains some of the features available in the Source pane for the Locks and Waits
viewpoint.

Source window toolbar. Use hotspot navigation buttons to switch between most performance-
critical code lines. Hotspot navigation is based on the metric column selected as a Data of Interest.

For the Locks and Waits viewpoint, this is Wait Time: Self by Thread Concurrency. Use the 
source file editor button to open and edit your code in your default editor.

Analyzing Locks and Waits  2  
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Source code of the application displayed if the function symbol information is available. When you
go to the source by double-clicking the synchronization object in the Bottom-up pane, the VTune
Amplifier opens the wait function containing this object. The source code in the Source pane is
not editable.

If the function symbol information is not available, the Assembly pane opens displaying
assembler instructions for the selected wait function. To view the source code in the Source pane,
make sure to build the target properly.

Processor time and concurrency bar attributed to a particular code line. The Self Time metric
shows the time the application spent at this particular source line while the Total Time includes
Self time of the function itself and Self time of all functions that were called from that function, if
any.

The colored bar represents the distribution of the Wait time according to the concurrency levels
(Idle, Poor, Ok, Ideal, and Over) defined by the VTune Amplifier. The longer the bar, the higher the
value. Ok level is not available for systems with a small number of cores.

Number of times the corresponding system wait API was called while this code line was executing.
For a lock, it is the number of times the lock was contended and caused a wait.

Wait Time during which the CPU was busy. This often occurs when a synchronization API causes
the CPU to poll while a software thread is waiting. Some Spin Time may be preferable to the
alternative of increased context switches. Too much Spin Time, however, may reflect a lost
opportunity for productive work.

Identify the Hottest Code Lines
For the sample code, the VTune Amplifier highlights line 159 entering the rgb_mutex mutex in the
draw_task function. The draw_task function was waiting for about 17 seconds while this code line was
executing and most of the time the processor was underutilized. During this time, the critical section was
contended 336 times.

The rgb_mutex is the place where the application is serializing. Each thread has to wait for the mutex to be
available before it can proceed. Only one thread can be in the mutex at a time. You need to optimize the

code to make it more concurrent. Click the  Source Editor button on the Source window toolbar to
open the code editor and optimize the code.

Key Terms
• CPU Usage
• Wait Time

Next Step
Remove Lock

Remove Lock

 In the Source window, you located the critical section that caused a significant wait while the
processor cores were underutilized and generated multiple wait count. Focus on this line and do the
following:

1. Open the code editor.
2. Modify the code to remove the lock.
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Open the Code Editor

Click the Source Editor button to open the analyze_locks.cpp file in your default editor at the hotspot
code line:

Remove the Lock
The rgb_mutex was introduced to protect calculation from multithreaded access. The brief analysis shows
that the code is thread safe and the mutex is not really needed.

To resolve this issue:

NOTE
The steps below are provided for Microsoft Visual Studio* 2013. Steps for other versions of Visual
Studio IDE may slightly differ.

1. Comment out code lines 159 and 166 to disable the mutex.
2. From Solution Explorer, select the analyze_locks project.
3. From Visual Studio menu, select Build > Rebuild analyze_locks.

The project is rebuilt.
4. From Visual Studio menu, select Debug > Start Without Debugging to run the application.

Visual Studio runs the analyze_locks.exe. Note that execution time reduced from 16.848 seconds to
2.652 seconds.
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Key Terms
Hotspot

Next Step
Compare with Previous Result

Compare with Previous Result

 You made sure that removing the mutex gave you optimization in the application execution time. To
understand the impact of your changes and how the CPU utilization has changed, re-run the Locks and Waits
analysis on the optimized code and compare results:

1. Compare results before and after optimization.
2. Identify the performance gain.
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Compare Results Before and After Optimization
1. Run the Locks and Waits analysis on the modified code.
2.

Click the Compare Results button on the VTune Amplifier toolbar.

The Compare Results window opens.
3. Specify the Locks and Waits analysis results you want to compare:

Identify the Performance Gain at the Application Level
The Summary window opens providing the statistics for the difference between collected results.

The Elapsed time data in the Summary window shows the optimization of 1.4 seconds for the whole
application execution and Wait time has decreased by 24.3 seconds.

According to the Thread Concurrency histogram, before optimization (dark blue bar) the application ran
serially for 5.343 seconds poorly utilizing available processor cores, but after optimization (light blue bar) it
ran serially only for 0.697 seconds.
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Identify the Performance Gain Per Program Unit
Click the Bottom-up tab to see the list of synchronization objects used in the code, Wait time utilization
across the two results, and the differences side by side:

Difference in Wait time per concurrency level between the two results in the following format:
<Difference Wait Time> = <Result 1 Wait Time> – <Result 2 Wait Time>. You may expand the
Difference column to display comparison data per concurrency level. By default, the total
difference data per Wait time is shown.

Wait time and thread concurrency level for the initial version of the code.

Wait time and thread concurrency level for the optimized version of the code.
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Difference in Wait count between the two results in the following format: <Difference Wait Count>
= <Results 1 Wait Count> - <Result 2 Wait Count>.

In the Bottom-up pane, locate the Critical Section you identified as a bottleneck in your code. Since you
removed it during optimization, the optimized result r001lw does not show any performance data for this
synchronization object. You see that with the optimized result you got about 17 seconds of optimization in
Wait time.

Compare analysis results regularly to look for regressions and to track how incremental changes to the code
affect its performance. You may also want to use the VTune Amplifier command-line interface and run the
amplxe-cl command to test your code for regressions. For more details, see the Command Line Interface
Support section in the VTune Amplifier online help.

Key Terms
• CPU Usage
• Elapsed Time
• Hotspot
• Wait time

See Also
Summary
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Summary 3
 You have completed the Analyzing Locks and Waits tutorial. Here are some important things to

remember when using the Intel® VTune™ Amplifier to analyze your code for locks and waits:

Step Tutorial Recap Key Tutorial Take-aways

1. Prepare for
analysis

If you used the Visual Studio* IDE:
You selected the analyze_locks
project as the target for the Locks
and Waits analysis.

If you used the standalone GUI: You
set up your environment to enable
generating symbol information for
system libraries and your binary files,
built the target in the Release mode,
created the performance baseline,
and created the VTune Amplifier
project for your analysis target. Your
application is ready for analysis.

• Configure the Microsoft* symbol server
and your project properties to get the
most accurate results for system and
user binaries and to analyze the
performance of your application at the
code line level.

• Create a performance baseline to
compare the application versions before
and after optimization. Make sure to use
the same workload for each application
run.

• Use the Analysis Target tab to choose
and configure your analysis target. For
Visual Studio* projects, the analysis
target settings are inherited
automatically.

2. Find lock You ran the Locks and Waits data
collection and identified the following
hotspots:
• Synchronization object with the

high Wait Time and Wait Count
values and poor thread
concurrency that could be a lock
affecting application parallelism.
Your next step is to analyze the
code of this function.

• Code section that caused a
significant wait and during which
the processor was poorly utilized.

• Use the Analysis Type tab to choose,
configure, and run the analysis. You can
also run the analysis from command line
using the amplxe-cl command.

• Start analyzing the performance of your
application with the Summary window
to explore the performance metrics for
the whole application. Then, move to the
Bottom-up window to analyze the
synchronization objects. Focus on the
synchronization objects that under- or
over-utilized the available logical CPUs
and have the highest Wait time and Wait
Count values. By default, the objects
with the highest Wait time values show
up at the top of the window.

3. Remove lock You optimized the application
execution time by removing the
unnecessary mutex that caused a lot
of Wait time.

Expand the most time-critical
synchronization object in the Bottom-up
pane and double-click the wait function it
belongs to. This opens the source code for
this wait function and you can navigate to
the most performance critical source lines.

4. Check your
work

You ran the Locks and Waits analysis
on the optimized code and compared
the results before and after
optimization using the Compare
mode of the VTune Amplifier. The

• Perform regular regression testing by
comparing analysis results before and
after optimization. From GUI, click the
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Step Tutorial Recap Key Tutorial Take-aways

comparison shows that, with the
optimized version of the
analyze_locks application (r001lw
result), you managed to remove the
lock preventing application
parallelism and significantly reduce
the application execution time.

Compare Results button on the
VTune Amplifier toolbar. From command
line, use the amplxe-cl command.

• Expand each data column by clicking the
 button to identify the performance

gain per thread concurrency level.

Next step: Prepare your own application(s) for analysis. Then use the VTune Amplifier to find and eliminate
locks preventing parallelism.

See Also
Click here for more Getting Started Tutorials
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Key Terms 4
baseline: A performance metric used as a basis for comparison of the application versions before and after
optimization. Baseline should be measurable and reproducible.

CPU time: The amount of time a thread spends executing on a logical processor. For multiple threads, the
CPU time of the threads is summed. The application CPU time is the sum of the CPU time of all the threads
that run the application.

CPU usage: A performance metric when the VTune Amplifier identifies a processor utilization scale,
calculates the target CPU usage, and defines default utilization ranges depending on the number of processor
cores.

Utilizatio
n Type

Default
color

Description

Idle All CPUs are waiting - no threads are running.

Poor Poor usage. By default, poor usage is when the number of simultaneously
running CPUs is less than or equal to 50% of the target CPU usage.

OK Acceptable (OK) usage. By default, OK usage is when the number of
simultaneously running CPUs is between 51-85% of the target CPU usage.

Ideal Ideal usage. By default, Ideal usage is when the number of simultaneously
running CPUs is between 86-100% of the target CPU usage.

Elapsed time:The total time your target ran, calculated as follows: Wall clock time at end of application
– Wall clock time at start of application.

finalization: A process during which the Intel® VTune™ Amplifier converts the collected data to a database,
resolves symbol information, and pre-computes data to make further analysis more efficient and responsive.

hotspot: A section of code that took a long time to execute. Some hotspots may indicate bottlenecks and
can be removed, while other hotspots inevitably take a long time to execute due to their nature.

target: A target is an executable file you analyze using the Intel® VTune™ Amplifier.

thread concurrency: A performance metric that helps identify how an application utilizes the processors in
the system by comparing the application concurrency level (the number of active threads) and target
concurrency level (by default, equal to the number of physical cores). Thread concurrency may be higher
than CPU usage if threads are in the runnable state and not consuming CPU time.

Utilizatio
n Type

Default
color

Description

Idle All threads in the program are waiting - no threads are running. There can be
only one node in the Summary chart indicating idle utilization.

Poor Poor utilization. By default, poor utilization is when the number of threads is up
to 50% of the target concurrency.

OK Acceptable (OK) utilization. By default, OK utilization is when the number of
threads is between 51-85% of the target concurrency.

Ideal Ideal utilization. By default, ideal utilization is when the number of threads is
between 86-115% of the target concurrency.
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Utilizatio
n Type

Default
color

Description

Over Over-utilization. By default, over-utilization is when the number of threads is
more than 115% of the target concurrency.

viewpoint: A preset result tab configuration that filters out the data collected during a performance analysis
and enables you to focus on specific performance problems. When you select a viewpoint, you select a set of
performance metrics the VTune Amplifier shows in the windows/panes of the result tab. To select the
required viewpoint, click the (change) link and use the drop-down menu at the top of the result tab.

Wait time: The amount of time that a given thread waited for some event to occur, such as: synchronization
waits and I/O waits.
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