Command Line and IDE Integration Support of Intel C++ Compiler for Windows*

By Jennifer L Jiang,

Published:08/26/2014   Last Updated:09/12/2017

The following table contains the minimum requirements for the Intel® C++ Compiler for Windows* to generate applications for 32-bit or 64-bit systems.

Intel C++
Compiler Version
Build Apps for
IA-32 Systems
Build Apps for
Intel 64 Systems
Build Apps for
IA-64 Systems
  Command Line IDE Command Line IDE Command Line IDE (on IA32 host only)
7.0 1 VC 6.0 or
VC .NET 2002 prof 2
VC 6.0 or
VC .NET 2002 prof 2
  --   -- PSDK   VC 6.0 with PSDK
7.1 1 VC 6.0 or
VC .NET 2002 or
VC .NET 2003 prof 2
VC 6.0 or
VC .NET 2002 or
VC .NET 2003 prof 2
  --   -- PSDK   VC 6.0 with PSDK
8.0 VC 6.0 or
VC .NET 2002 or
VC .NET 2003 std 2

VC 6.0 or VC .NET 2002 or 2003 std 2

  --   -- PSDK   VC 6.0 with PSDK
8.1 VC 6.0 or
VC .NET 2002 or
VC .NET 2003 std 2
VC 6.0 or
VC .NET 2002 or
VC .NET 2003 std 2
PSDK -- PSDK VC 6.0 with PSDK
9.0 VC 6.0 or
VC .NET 2002 or
VC .NET 2003 std 2 or
VS 2005 exp 2 (9.0.030 pkg only)
VC 6.0 or
VC .NET 2002 or
VC .NET 2003 std 2
PSDK or
VS 2005 std 2 (9.0.030 pkg only)
  -- PSDK or
VS 2005 TS (9.0.030 pkg only)
VC 6.0 with PSDK
9.1 VC 6.0 or
VC .NET 2002 or
VC .NET 2003 std 2 or
VC 2005 exp 2
VC 6.0 or
VC .NET 2002 or
VC .NET 2003 std 2 or
VC 2005 std 2
PSDK or
VC 2005 std 2
VC 2005 std 2 PSDK or VS 2005 TS VS 2005 TS
10.0 or 10.1 3 VC 6.0 or
VC .NET 2003 std 2 or
VC 2005 exp 2
VC 6.0 or
VC .NET 2003 std 2 or
VC 2005 std 2
PSDK or
VC 2005 std 2
VC 2005 std 2 PSDK or
VS 2005 TS
VS 2005 TS
10.1.019 or later VC 6.0 or
VC .NET 2003 std 2 or
VC 2005 exp 2 or VC 2008 exp 2
VC 6.0 or
VC .NET 2003 std 2 or
VC 2005 std 2or VC 2008 std 2
PSDK or
VC 2005 std 2 or
VC 2008 std 2
VC 2005 std 2 or
VC 2008 std 2
PSDK or
VS 2005 TS or
VS 2008 TS
VS 2005 TS or
VS 2008 TS
11.0 or 11.14 VC .NET 2003 std 2 or
VC 2005 exp 2 or
VC 2008 exp 2
VC .NET 2003 std 2 or
VC 2005 std 2or
VC 2008 std 2
PSDK or VC 2005 std 2 or
VC 2008 std 2
VC 2005 std 2 or
VC 2008 std 2
PSDK or
VS 2005 TS or
VS 2008 TS
VS 2005 TS or
VS 2008 TS
12.0 or 12.1 VC 2005 exp 2 or
VC 2008 exp 2
or
VC 2010 exp 2
VC 2005 std 2or
VC 2008 std 2
or
VC 2010 std 2
PSDK or VC 2005 std 2 or
VC 2008 std 2
or
VC2010 std 2
VC 2005 std 2 or
VC 2008 std 2 or
VC2010 std 2
-- --
13.x or 14.0 6 VC 2008 exp 2
or VC 2010 exp 2 or
VC 2012 exp 2
VC 2008 std 2
or VC 2010 std 2 or
VS 2012 pro 2
VC 2008 std 2
or VC2010 std 2  or
VS2012 exp 2
VC 2008 std 2 or
VC 2010 std 2 or
VS2012 pro 2
-- --
15.0

VC2010 exp 2 or
VC2012 exp 2 or
VC2013 exp 2

VC2015 exp2 (see this article on supporting details)

VC2010 std 2 or
VS2012 pro 2
VS2013 pro 2 VC2015 pro 2(see left)
VC2010 std 2  or
VC2012 exp 2
VC2013 exp 2 VC2015 exp 2(see left)
VS2010 std 2 or
VS2012 pro 2
VS2013 pro 2 VC2015 pro 2(see left)
-- --
16.07 VC2010 exp 2 or
VC2012 exp 2 or
VC2013 exp 2 or
VC2015 exp2(see this article on supporting details)
VC2010 std 2 or
VS2012 pro 2
VS2013 pro 2
VC2015 pro 2(see left)
VC2010 std 2  or
VC2012 exp 2
VC2013 exp 2
VC2015 exp 2(see left)
VS2010 std 2 or
VS2012 pro 2
VS2013 pro 2
VC2015 pro 2(see left)
-- --
17.07 VC2012 exp 2 or
VC2013 exp 2 or
VC2015 exp2
VS2012 pro 2
VS2013 pro 2
VC2015 pro 2(see left)
VC2012 exp 2
VC2013 exp 2
VC2015 exp 2(see left)
VS2012 pro 2
VS2013 pro 2
VC2015 pro 2(see left)
-- --
18.08 VC2013 exp 2 or
VC2015 exp 2 or
VS2013 pro 2
VS2015 pro 2
VC2017 pro 2(see left)
VC2013 exp 2
VC2015 exp 2
VS2013 pro 2
VS2015 pro 2
VC2017 pro 2(see left)
-- --

Not supported. Information here is for reference only. Intel C++ Compiler for Windows 7.x are not supported. The information is for back reference only.

:
    std - Standard Edition or above;
    prof - Professional Edition or above;
    exp : Express Edition or above

10.0 does not support VC .NET 2002. VC6.0 support is deprecated in 10.0.
11.0 does not support VC6.0.
12.0 does not support VC.NET 2003, does not support IA-64 architecture. The version 11.1 compiler remains available for development of IA-64 architecture applications.
*** VS2005 support is deprecated in 12.0 update 6. It is recommended to migrate to a newer version of Visual Studio. In a future major release, the support maybe removed.
Visual Studio 2008 support is deprecated in 14.0; it is not supported in 15.0.
Visual Studio 2010 support is deprecated in 16.0.
Visual Studio 2012 support is deprecated in 17.0.it is not supported in 18.0.

PSDK: Microsoft Platform SDK
9.0.030: Intel C++ Compiler 9.0 for Windows compiler update package w_cc_c_9.0.030
VC 6.0: Visual C++ 6.0 Professional or above

To use the Intel® Streaming SIMD Extensions(SSE) or SSE2 instructions or types, you need to install the Visual C++ 6.0 Processor Pack †.

VC .NET 2002 or 2003: Visual C++ .NET 2002 or 2003
VC 2005: Visual C++ 2005*
VC 2008: Visual C++ 2008*
VS 2005 TS: Visual Studio 2005* Team System Edition
VS 2008 TS: Visual Studio 2008* Team System Edition
VS 2010 std: Visual Studio 2010* Standared Edition
VS 2012 pro: Visual Studio 2012* Professional Edition 
IDE: Integrated Development Environment

For more detailed information, please refer to the Release Notes for each product.

† This link will take you off of the Intel Web site. Intel does not control the content of the destination Web Site.

See What's New in the Intel® C++ Compiler integration with Microsoft* Visual Studio* for detailed IDE integration features.

 

Product and Performance Information

1

Intel's compilers may or may not optimize to the same degree for non-Intel microprocessors for optimizations that are not unique to Intel microprocessors. These optimizations include SSE2, SSE3, and SSSE3 instruction sets and other optimizations. Intel does not guarantee the availability, functionality, or effectiveness of any optimization on microprocessors not manufactured by Intel. Microprocessor-dependent optimizations in this product are intended for use with Intel microprocessors. Certain optimizations not specific to Intel microarchitecture are reserved for Intel microprocessors. Please refer to the applicable product User and Reference Guides for more information regarding the specific instruction sets covered by this notice.

Notice revision #20110804