Intel® MPI Library and Intel® Parallel Studio XE Composer Edition Compatibility

By Gergana S. Slavova, Published: 03/31/2014, Last Updated: 02/08/2017

The following table lists all supported versions of the Intel® MPI Library and the Intel® Parallel Studio XE Composer Edition.  Use this as a reference on the cross-compatibility between the library and associated compiler.

Compatibility Matrix
Intel® MPI Library Version Intel® Parallel Studio XE 2016 Composer Edition Intel® Parallel Studio XE 2017 Composer Edition Intel® Parallel Studio XE 2018 Composer Edition Intel® Parallel Studio XE 2019 Composer Edition
5.1 X      
2017 X X    
2018 X X X  
2019   X X X

NOTE: Any older versions of the Intel® MPI Library may work with newer versions of the Intel® Compilers but compatibility is not guaranteed. If you have concerns or see any issues, please visit our Get Help page for support options.

Product and Performance Information

1

Intel's compilers may or may not optimize to the same degree for non-Intel microprocessors for optimizations that are not unique to Intel microprocessors. These optimizations include SSE2, SSE3, and SSSE3 instruction sets and other optimizations. Intel does not guarantee the availability, functionality, or effectiveness of any optimization on microprocessors not manufactured by Intel. Microprocessor-dependent optimizations in this product are intended for use with Intel microprocessors. Certain optimizations not specific to Intel microarchitecture are reserved for Intel microprocessors. Please refer to the applicable product User and Reference Guides for more information regarding the specific instruction sets covered by this notice.

Notice revision #20110804