C++ Sample doesn't build

C++ Sample doesn't build

I just installed Intel C++ Studio XE for Windows. I was trying to work my way thru the Getting Started Tutorials. The first sample is matirx_vector_multiplication_c. I selected the Intel C++ compiler but could not set all the properties the tutorial specifies. When I bring up the properties for the project the Intel Specific properties for Optimization and Language are missing. I am using Visual Studio Professional 2010.

5 Beiträge / 0 neu
Letzter Beitrag
Nähere Informationen zur Compiler-Optimierung finden Sie in unserem Optimierungshinweis.

The Getting Started tutorials mostly describe VS2008 interface. In VS2010 there is no exact "Intel specific" section. Instead of it there is another Optimization tab, that is called "Optimization [Intel C++]". So in the tree of sections under Configuration properties->C/C++ you should see:
...
Optimization
Optimization [Intel C++]
...

So you should find Intel specific properties there. Same thing with Language.

Regards,
Kirill

I don't see the Optimization [Intel C++] in the list under C/C++. I did set the projec to Use Intel C++

Changed to x64 configuration and now I see the Intel options and it builds. Although I would have thought I should be able to build 32 bit apps as well ????

There are versions of Intel Composer XE (and Intel Parallel Studio XE) for 32-bit, 64-bit and both 32 and 64-bit development. Maybe you have one for 64-bit only?
Check for icl command line here:
All programs -> Intel Parallel Studio XE 2011 -> Command prompt -> Parallel Studio XE with Intel Compiler XE ...
There are should be two shortcuts, 32-bit with VS2010 and 64-bit with VS2010. If there is no 32-bit, you have 64-bit composer only. If both persist, there maybe some issues during installation, so 32-bit composer (or VS integration)wasn't installed correctly. In this case you may try to re-install the Composer XE, if you're certain your version is both 32 and 64.

Kommentar hinterlassen

Bitte anmelden, um einen Kommentar hinzuzufügen. Sie sind noch nicht Mitglied? Jetzt teilnehmen