Compilation failure with 7.1 (fine with 7.0)

Compilation failure with 7.1 (fine with 7.0)

Bild des Benutzers kleb

Has anyone else run into the dreaded,

*Internal Compiler Error*

message when compiling with 7.1?

Our code compiles fine with 7.0.

Unfortunately I cannot seem to pare the failure down
to something tractable (or releasable).

(This is for releases -008 and -011 on RedHat 7.3.)

5 Beiträge / 0 neu
Letzter Beitrag
Nähere Informationen zur Compiler-Optimierung finden Sie in unserem Optimierungshinweis.
Bild des Benutzers Steve Lionel (Intel)

That's a rather generic error and could have any of a number of causes. If you can't cut it down, submit what you have. You may want to also try cutting back on switches to see if eliminating one or more makes the problem go away.

Steve

Steve
Bild des Benutzers kleb

Unfortunately I cannot submit what I have without a lot
of paperwork.

We've tried cutting back on switches, but it merely
dies in different places with the same generic error
message.

Apparently others at our center are also having trouble
as I just received the following from the system
administrator of one of our large Beowulf clusters:

Several problems have been reported by users regarding
the intel 7.1 compiler. These problems include
compilation issues and performance loss.
Given these problems I have moved the default intel
compiler back to version 7.0

Bild des Benutzers Steve Lionel (Intel)

Sorry to hear that. I hope you or your other users report the problems to Intel so that they can be fixed.

Steve

Steve
Bild des Benutzers kleb

The latest patch release (7.1.017, Build 20030507Z) compiles our code base again.

Melden Sie sich an, um einen Kommentar zu hinterlassen.