pax driver load error

pax driver load error

Hello, I am trying to install vtune drivers on my computer. I get the follwoing error. Can you please help me.

uname -a
Linux dirac.mer.utexas.edu 2.6.18-128.1.1.el5 #1 SMP Mon Jan 26 13:58:24 EST 2009 x86_64 x86_64 x86_64 GNU/Linux

Intel VTune Amplifier XE 2011 Update 5 (build 186533) Command Line Tool Copyright (C) 2009-2011 Intel Corporation. All rights reserved.

Error Message:

[root@dirac prebuilt]# ./insmod-sep3
Checking for PMU arbitration service (PAX) ... not detected.
Attempting to start PAX service ...
Executing: insmod ./pax/pax-x32_64-2.6.18-128.1.1.el5smp.ko
insmod: error inserting './pax/pax-x32_64-2.6.18-128.1.1.el5smp.ko': -1 Invalid module format

Error: pax driver failed to load!

You may need to build pax driver for your kernel.
Please see the pax driver README for instructions.

Error: failed to start or connect to required PAX service

17 Beiträge / 0 neu
Letzter Beitrag
Nähere Informationen zur Compiler-Optimierung finden Sie in unserem Optimierungshinweis.

Hello,

What is your Linux distribution version? You may try to build drivers from sources. You can find instructions in./sepdk/src/README.txt. Actually you need to run ./sepdk/src/build-driver and than run ./sepdk/src/insmod-sep3 to install it.

Regards,
Kirill

I did build the driver before loading:
I am using RHEL 5.2
uname -a :

Linux dirac.mer.utexas.edu 2.6.18-128.1.1.el5 #1 SMP Mon Jan 26 13:58:24 EST 2009 x86_64 x86_64 x86_64 GNU/Linux

here is the log for build:
[root@dirac src]# ./build-driver -ni --install-dir=../prebuilt
C compiler to use: [ /usr/bin/gcc ]
Make command to use: [ /usr/bin/make ]
Kernel source directory: [ /lib/modules/2.6.18-128.1.1.el5/build ]
rm -f *.o .*.o.cmd .*.o.d .*.ko.cmd .*.ko.unsigned.cmd *.gcno
rm -f sep3_4.ko sep3_4.ko.unsigned sep3_4-x32_64-2.6.18-128.1.1.el5smp.ko
rm -f Module.symvers Modules.symvers *.mod.c modules.order Module.markers
rm -rf .tmp_versions
make[1]: Entering directory `/opt/intel/vtune_amplifier_xe_2011/sepdk/src/pax'
rm -f *.o .*.o.cmd .*.o.d .*.ko.cmd .*.ko.unsigned.cmd *.gcno
rm -f pax.ko pax.ko.unsigned pax-x32_64-2.6.18-128.1.1.el5smp.ko
rm -f Module.symvers Modules.symvers *.mod.c modules.order Module.markers
rm -rf .tmp_versions
make[1]: Leaving directory `/opt/intel/vtune_amplifier_xe_2011/sepdk/src/pax'
/usr/bin/make -C /lib/modules/2.6.18-128.1.1.el5/build M=/opt/intel/vtune_amplifier_xe_2011/sepdk/src LDDINCDIR=/opt/intel/vtune_amplifier_xe_2011/sepdk/src/../include LDDINCDIR1=/opt/intel/vtune_amplifier_xe_2011/sepdk/src/inc modules PWD=/opt/intel/vtune_amplifier_xe_2011/sepdk/src
make[1]: Entering directory `/usr/src/kernels/2.6.18-128.1.1.el5-x86_64'
CC [M] /opt/intel/vtune_amplifier_xe_2011/sepdk/src/lwpmudrv.o
CC [M] /opt/intel/vtune_amplifier_xe_2011/sepdk/src/control.o
CC [M] /opt/intel/vtune_amplifier_xe_2011/sepdk/src/cpumon.o
CC [M] /opt/intel/vtune_amplifier_xe_2011/sepdk/src/eventmux.o
CC [M] /opt/intel/vtune_amplifier_xe_2011/sepdk/src/linuxos.o
CC [M] /opt/intel/vtune_amplifier_xe_2011/sepdk/src/output.o
CC [M] /opt/intel/vtune_amplifier_xe_2011/sepdk/src/pmi.o
CC [M] /opt/intel/vtune_amplifier_xe_2011/sepdk/src/sys_info.o
CC [M] /opt/intel/vtune_amplifier_xe_2011/sepdk/src/utility.o
CC [M] /opt/intel/vtune_amplifier_xe_2011/sepdk/src/core2.o
AS [M] /opt/intel/vtune_amplifier_xe_2011/sepdk/src/sys64.o
CC [M] /opt/intel/vtune_amplifier_xe_2011/sepdk/src/corei7_unc.o
CC [M] /opt/intel/vtune_amplifier_xe_2011/sepdk/src/snbunc_cbo.o
CC [M] /opt/intel/vtune_amplifier_xe_2011/sepdk/src/snbunc_imc.o
CC [M] /opt/intel/vtune_amplifier_xe_2011/sepdk/src/wsmexunc_imc.o
CC [M] /opt/intel/vtune_amplifier_xe_2011/sepdk/src/wsmexunc_qpi.o
CC [M] /opt/intel/vtune_amplifier_xe_2011/sepdk/src/wsmexunc_wbox.o
CC [M] /opt/intel/vtune_amplifier_xe_2011/sepdk/src/uncore_imc.o
CC [M] /opt/intel/vtune_amplifier_xe_2011/sepdk/src/pci.o
CC [M] /opt/intel/vtune_amplifier_xe_2011/sepdk/src/apic.o
CC [M] /opt/intel/vtune_amplifier_xe_2011/sepdk/src/pebs.o
LD [M] /opt/intel/vtune_amplifier_xe_2011/sepdk/src/sep3_4.o
Building modules, stage 2.
MODPOST
CC /opt/intel/vtune_amplifier_xe_2011/sepdk/src/sep3_4.mod.o
LD [M] /opt/intel/vtune_amplifier_xe_2011/sepdk/src/sep3_4.ko
make[1]: Leaving directory `/usr/src/kernels/2.6.18-128.1.1.el5-x86_64'
cp sep3_4.ko sep3_4-x32_64-2.6.18-128.1.1.el5smp.ko
make[1]: Entering directory `/opt/intel/vtune_amplifier_xe_2011/sepdk/src/pax'
/usr/bin/make -C /lib/modules/2.6.18-128.1.1.el5/build M=/opt/intel/vtune_amplifier_xe_2011/sepdk/src/pax LDDINCDIR=/opt/intel/vtune_amplifier_xe_2011/sepdk/src/pax/../../include LDDINCDIR1=/opt/intel/vtune_amplifier_xe_2011/sepdk/src/pax/../inc modules PWD=/opt/intel/vtune_amplifier_xe_2011/sepdk/src/pax
make[2]: Entering directory `/usr/src/kernels/2.6.18-128.1.1.el5-x86_64'
CC [M] /opt/intel/vtune_amplifier_xe_2011/sepdk/src/pax/pax.o
Building modules, stage 2.
MODPOST
CC /opt/intel/vtune_amplifier_xe_2011/sepdk/src/pax/pax.mod.o
LD [M] /opt/intel/vtune_amplifier_xe_2011/sepdk/src/pax/pax.ko
make[2]: Leaving directory `/usr/src/kernels/2.6.18-128.1.1.el5-x86_64'
cp pax.ko pax-x32_64-2.6.18-128.1.1.el5smp.ko
make[1]: Leaving directory `/opt/intel/vtune_amplifier_xe_2011/sepdk/src/pax'

Installed sep3_4 driver to /opt/intel/vtune_amplifier_xe/sepdk/prebuilt/sep3_4-x32_64-2.6.18-128.1.1.el5smp.ko .
make[1]: Entering directory `/opt/intel/vtune_amplifier_xe_2011/sepdk/src/pax'
Installed pax driver to /opt/intel/vtune_amplifier_xe/sepdk/prebuilt/pax/pax-x32_64-2.6.18-128.1.1.el5smp.ko .
make[1]: Leaving directory `/opt/intel/vtune_amplifier_xe_2011/sepdk/src/pax'

Try steps: (under vtune_amplifier_xe_2011/sepdk/src)
1. ./rmmod-sep3
2. rmmod pax
3. ./build_driver
4. ./insmod-sep3
5. ./boot-script -- install

Regards, Peter

I did all the steps you mentioned. For ./build-driver, i used the default options.

I get the same error message that i mentioned in the first post.

[root@dirac src]# ./insmod-sep3
Checking for PMU arbitration service (PAX) ... not detected.
Attempting to start PAX service ...
Executing: insmod ./pax/pax-x32_64-2.6.18-128.1.1.el5smp.ko
insmod: error inserting './pax/pax-x32_64-2.6.18-128.1.1.el5smp.ko': -1 Invalid module format

Error: pax driver failed to load!

You may need to build pax driver for your kernel.
Please see the pax driver README for instructions.

Error: failed to start or connect to required PAX service

Did you work on Virtual Box?

Have you seen sep and pax driver before running insmod-sep3?
lsmod | grep sep
lsmod | grep pax

I do not work on a virtual box. I remote login to my server, and su - to login as root. I doub if that is an issue. I did vtune install long time back, using version 9.1, i uninstalled that version now. I was to use the software then. that was about two years ago.

i get no output when i run lsmod commands.

does this information help,
I cannot seem to make much out of it but seems relavent.

[root@dirac ~]# dmesg | grep pax
pax: version magic '2.6.18-128.1.1.el5 SMP mod_unload gcc-4.5' should be '2.6.18-128.1.1.el5 SMP mod_unload gcc-4.1'
pax: version magic '2.6.18-128.1.1.el5 SMP mod_unload gcc-4.5' should be '2.6.18-128.1.1.el5 SMP mod_unload gcc-4.1'
pax: version magic '2.6.18-128.1.1.el5 SMP mod_unload gcc-4.5' should be '2.6.18-128.1.1.el5 SMP mod_unload gcc-4.1'
pax: version magic '2.6.18-128.1.1.el5 SMP mod_unload gcc-4.5' should be '2.6.18-128.1.1.el5 SMP mod_unload gcc-4.1'
pax: version magic '2.6.18-128.1.1.el5 SMP mod_unload gcc-3.4' should be '2.6.18-128.1.1.el5 SMP mod_unload gcc-4.1'

I could finally load the drivers. The problem was with the gcc version. For some reason, gcc4.1 was missing from my server, i installed a later version. I read in some fourom that if the gcc version used for bulding kernal doesnot match that used for bulding the driver, i get the erro i mentioned.

Thanks

Hi there, I have a similar problem.

I try to install vtune, and it exit with this error:

linux-2.6.32.12-0.7 # more /tmp/amplifier_sampling_load_20.10.14.23.36.03.log
Warning:  no sep3_15 driver was found loaded in the kernel.
Checking for PMU arbitration service (PAX) ... not detected.
Attempting to start PAX service ...
Executing: insmod ./pax/pax-x32_64-2.6.32.59-0.7-default-fslsmp.ko
insmod: error inserting './pax/pax-x32_64-2.6.32.59-0.7-default-fslsmp.ko': -1 Invalid module format

Error:  pax driver failed to load!

You may need to build pax driver for your kernel.
Please see the pax driver README for instructions.

Error: failed to start or connect to required PAX service

I double check the kernel, and it is using the same GCC version as well.  Is there a version of GCC that is needed?

I am using this: gcc version 4.3.4 [gcc-4_3-branch revision 152973] (SUSE Linux)

 

Hello Michael - You do appear to have the correct version of gcc.  At least the 4.3.4 version is what I find in package descriptions for SUSE 11, SP1.  Have you attempted to build the driver manually as described higher up in the thread, according to the readme?  See Kirill's response.  If so, what was the result?  Can you post the build output?

 

 

 

Before building pax driver, you need to check if Linux* kernel source matches running operation system version, then you will get expected driver name.

My case:

# uname -r
2.6.32-71.el6.x86_64

# pwd
/opt/intel/vtune_amplifier_xe_2015/sepdk/src/pax

# ls pax-*.ko

pax-x32_64-2.6.32-71.el6.x86_64smp.ko

 

The build-driver script will inform you if the sources don't match.  And which version of GCC is not so important, it's the kernel version, as Peter pointed out.

Based on the post from @Michael L., I would say he doesn't have a driver that matches.  E.g., The prompt says "linux-2.6.32.12-0.7", while the driver file says "./pax/pax-x32_64-2.6.32.59-0.7-default-fslsmp.ko".  (Assuming the prompt is correct.)

Of course, all of this should have been done during installation, assuming a recent version.  What version of the VTune Amplifier are you using, 2013 or 2015?  If 2013, which update?  Did you install it on this system as root, using sudo, or just as a user?  What happened during install?  Did you see any messages about failing to build or load the driver?

Anyway, at this point, cd in the pax directory, <vtuneinstall>/sepdk/src/pax, and attempt to build the driver (build-driver script).  Once successfully built, cd up to sepdk/src and execute the build-driver script in that directory.  If that builds everything successfully, execute the insmod-sep3 script.  (these instructions assume a current version, as well)

Regards, MrAnderson

To Peter Wang:

this is what I get:

/opt/intel/vtune_amplifier_xe_2015/sepdk/src/pax # uname -r
2.6.32.59-0.7-default-fsl
/opt/intel/vtune_amplifier_xe_2015/sepdk/src/pax # pwd
/opt/intel/vtune_amplifier_xe_2015/sepdk/src/pax
/opt/intel/vtune_amplifier_xe_2015/sepdk/src/pax # ls pax-*.ko
pax-x32_64-2.6.32.59-0.7-default-fslsmp.ko

Look like pax is using the same version as my kernel, both at 2.6.32.59-0.7

 

 

 

 

To MrAnderson:

when I try to build pax, this is what I see:

:/opt/intel/vtune_amplifier_xe_2015/sepdk/src/pax # ./build-driver

Options in brackets "[ ... ]" indicate default values
that will be used when only the ENTER key is pressed.

C compiler to use: [ /usr/bin/gcc ]

Make command to use: [ /usr/bin/make ]

Kernel source directory: [ /usr/src/linux ]
rm -f *.o .*.o.cmd .*.o.d .*.ko.cmd .*.ko.unsigned.cmd *.gcno
rm -f pax.ko pax.ko.unsigned pax-x32_64-2.6.32.59-0.7-default-fslsmp.ko
rm -f Module.symvers Modules.symvers *.mod.c modules.order Module.markers
rm -rf .tmp_versions
/usr/bin/make -C /usr/src/linux M=/opt/intel/vtune_amplifier_xe_2015.1.0.367959/sepdk/src/pax LDDINCDIR=/opt/intel/vtune_amplifier_xe_2015.1.0.367959/sepdk/src/pax/../../include LDDINCDIR1=/opt/intel/vtune_amplifier_xe_2015.1.0.367959/sepdk/src/pax/../inc modules PWD=/opt/intel/vtune_amplifier_xe_2015.1.0.367959/sepdk/src/pax
make[1]: Entering directory `/usr/src/linux-2.6.32.12-0.7'

  WARNING: Symbol version dump /usr/src/linux-2.6.32.12-0.7/Module.symvers
           is missing; modules will have no dependencies and modversions.

  CC [M]  /opt/intel/vtune_amplifier_xe_2015.1.0.367959/sepdk/src/pax/pax.o
  Building modules, stage 2.
  MODPOST 1 modules
  CC      /opt/intel/vtune_amplifier_xe_2015.1.0.367959/sepdk/src/pax/pax.mod.o
  LD [M]  /opt/intel/vtune_amplifier_xe_2015.1.0.367959/sepdk/src/pax/pax.ko
make[1]: Leaving directory `/usr/src/linux-2.6.32.12-0.7'
cp pax.ko pax-x32_64-2.6.32.59-0.7-default-fslsmp.ko

Directory to install pax driver: [ /opt/intel/vtune_amplifier_xe_2015/sepdk/src/pax ]

cp: `pax-x32_64-2.6.32.59-0.7-default-fslsmp.ko' and `/opt/intel/vtune_amplifier_xe_2015/sepdk/src/pax/pax-x32_64-2.6.32.59-0.7-default-fslsmp.ko' are the same file
make: *** [install] Error 1

when I try to install, this is the error I see:

 

Step 3 of 4 | Repairing
--------------------------------------------------------------------------------
Each component will be repaired individually. If you cancel the repairing, some
components might remain on your system. This repairing may take several minutes,
depending on your system and the options you selected.
--------------------------------------------------------------------------------
Uninstalling drivers... done
--------------------------------------------------------------------------------
Sampling driver uninstalled successfully
--------------------------------------------------------------------------------
Installing Command line interface component... done
--------------------------------------------------------------------------------
Installing Sampling Driver kit component... done
--------------------------------------------------------------------------------
Installing Graphical user interface component... done
--------------------------------------------------------------------------------
Finalizing product configuration...
--------------------------------------------------------------------------------
Preparing driver configuration scripts... done
--------------------------------------------------------------------------------
Installing drivers. It may take several minutes... done
--------------------------------------------------------------------------------
Sampling driver built successfully
Error while loading sampling driver, see /tmp/amplifier_sampling_load_21.10.14.21.40.50.log for details
Sampling driver boot script installed successfully
--------------------------------------------------------------------------------
Press "Enter" key to continue

and the log file shows this:

:/tmp/vtune_amplifier_xe_2015 # more /tmp/amplifier_sampling_load_21.10.14.21.40.50.log
Warning:  no sep3_15 driver was found loaded in the kernel.
Checking for PMU arbitration service (PAX) ... not detected.
Attempting to start PAX service ...
Executing: insmod ./pax/pax-x32_64-2.6.32.59-0.7-default-fslsmp.ko
insmod: error inserting './pax/pax-x32_64-2.6.32.59-0.7-default-fslsmp.ko': -1 I
nvalid module format

Error:  pax driver failed to load!

You may need to build pax driver for your kernel.
Please see the pax driver README for instructions.

Error: failed to start or connect to required PAX service

To Bob L

I did compile it manually - but it fail as well for pax load

I didn't capture log, so I will try again and show logs.

 

Is this a virtualized environment?  Can you execute the command 'amplxe-feedback -create-bug-report report.zip' and either send it to me via private message or open an issue at Intel® Premier Support, where you will have an account if you registered your software, purchased or eval?

Also, notice that while the pax driver did build, it did not copy it to the location that it would be loaded from:

cp: `pax-x32_64-2.6.32.59-0.7-default-fslsmp.ko' and `/opt/intel/vtune_amplifier_xe_2015/sepdk/src/pax/pax-x32_64-2.6.32.59-0.7-default-fslsmp.ko' are the same file

Try renaming the existing file, rebuilding the pax driver, and then loading it via insmod-sep3.

BTW, what does the output of 'file pax-x32_64-2.6.32.59-0.7-default-fslsmp.ko' look like?

Regards, MrAnderson

Kommentar hinterlassen

Bitte anmelden, um einen Kommentar hinzuzufügen. Sie sind noch nicht Mitglied? Jetzt teilnehmen