GPA 2.0: Get message "Instrumented driver is not installed" when attempting to use GPA

GPA 2.0: Get message "Instrumented driver is not installed" when attempting to use GPA

Bild des Benutzers Neal Pierman (Intel)
26 Beiträge / 0 neu
Letzter Beitrag
Nähere Informationen zur Compiler-Optimierung finden Sie in unserem Optimierungshinweis.

Hello,

I am trying to get GPA up and running on a new Dell system using the Intel G45/G43 chipset, 3gb RAM, Core 2 Duo 2.80GHz running Windows Vista 32-bit. I have run the Intel Driver Update Utility and verified that my driver version is up to date, 7.15.10.1688 at this time. I start the "Intel GPA Remote Server", then I start the "Intel GPA Frame Capture Tool." When I try to connect locally I get an error message "Instrumented driver is not installed." I have also attempted to connect the Frame Capture Tool from another computer on the network, with the same error.

Any thoughts or suggestions as to what I can try next?
Thanks,
Ted

Bild des Benutzers Neal Pierman (Intel)

Quoting - tedruxpin
Hello,

I am trying to get GPA up and running on a new Dell system using the Intel G45/G43 chipset, 3gb RAM, Core 2 Duo 2.80GHz running Windows Vista 32-bit. I have run the Intel Driver Update Utility and verified that my driver version is up to date, 7.15.10.1688 at this time. I start the "Intel GPA Remote Server", then I start the "Intel GPA Frame Capture Tool." When I try to connect locally I get an error message "Instrumented driver is not installed." I have also attempted to connect the Frame Capture Tool from another computer on the network, with the same error.

Any thoughts or suggestions as to what I can try next?
Thanks,
Ted

Hello,

If you haven't already rebooted since you reloaded the gfx driver and tried running GPA, please reboot again. We've occassionally seen some issues on some systems where GPA may tell you the first time that you run that the instrumented drivers are not loaded, and this message goes away after a reboot (and GPA runs fine from then on).

The next thing I'm going to ask is that you let us know which graphics device you have. For this, you'll need to go into the device manager (by right-clicking "computer" from the start menu), then under "display adaptors" right click on "Mobile Intel 4 Series Express Chipset Family", then Properties, then Details, then Hardware ID's, and let me know what hardware id's you see (should be 4 of them). (BTW, I'm looking to see if I can make this easier for the next version of the code!).

Once we have this info, this will help us ask the next round of questions...

Thanks!

Neal

Hello Neal, thank you for responding.

Yes, I did reboot a number of times while trying to get this to work. Including full-off reboots. I also tried restarting all of the tools following a failure and that still didn't solve the problem.

My hardware information is as follows:

Intel G45/G43 Express Chipset

Hardware IDs:
PCIVEN_8086&DEV_2E22&SUBSYS_02831028&REV_03
PCIVEN_8086&DEV_2E22&SUBSYS_02831028
PCIVEN_8086&DEV_2E22&CC_030000
PCIVEN_8086&DEV_2E22&CC_0300

What's next? Thanks,
Ted

Bild des Benutzers Neal Pierman (Intel)

Quoting - tedruxpin
Hello Neal, thank you for responding.

Yes, I did reboot a number of times while trying to get this to work. Including full-off reboots. I also tried restarting all of the tools following a failure and that still didn't solve the problem.

My hardware information is as follows:

Intel G45/G43 Express Chipset

Hardware IDs:
PCIVEN_8086&DEV_2E22&SUBSYS_02831028&REV_03
PCIVEN_8086&DEV_2E22&SUBSYS_02831028
PCIVEN_8086&DEV_2E22&CC_030000
PCIVEN_8086&DEV_2E22&CC_0300

What's next? Thanks,
Ted

Ted,

BTW, are you running the tools from an Admin or "regular user" account?

Also, can you please check the driver version again? We've also seen some instances where the driver install appears to go ok, but when you reboot the driver ends up not being updated.

And last but not least, does this system have dual graphics? Such as the g45 and a separate gfx card?

Neal

Admin account with UAC turned off.

Yes, the driver version and hardware ids are the same following a reboot. Actually I reboot after installing drivers as a matter of habit.

No, there are no other video cards installed in the system.

Bild des Benutzers Neal Pierman (Intel)

Quoting - tedruxpin
Yes, the driver version and hardware ids are the same following a reboot. Actually I reboot after installing drivers as a matter of habit.

No, there are no other video cards installed in the system.

The dev team is looking into why this would occur... i'll have some more info tomorrow on this.

regards,

Neal

ps-> initial indications are that for some reason the driver is saying that it doesn't support instrumentation, and we'll try to track down under what circumstances this might occur

Bild des Benutzers Neal Pierman (Intel)

Quoting:


The dev team is looking into why this would occur... i'll have some more info tomorrow on this.

regards,

Neal

ps-> initial indications are that for some reason the driver is saying that it doesn't support instrumentation, and we'll try to track down under what circumstances this might occur

Ted,

Do you have the model number of the machine you are running this on? If so, I can check if we have this in one of our labs and try to duplicate with the 1688 driver.

Also, would you be able to verify that the date on the gfx driver is 3/25/09?

Thanks!

Neal

PS-> I'm also assuming that there aren't any unusual BIOS settings on this machine that specifically mention gfx driver capabilities?

Dell Vostro 220, 3gb RAM (800MHz), Intel Core 2 Duo CPU E7400 @ 2.80GHz
Windows Vista Business 32-bit

Intel G45/G43 Express Chipset
Driver Date: 3/25/2009
Driver Version: 7.15.10.1688
32mb Dedicated Video Memory
96mb System Video Memory
1166mb Shared System Memory
Single display @ 1920x1200, 32-bit color, 60Hz
Installed drivers: igdumdx32(7.15.10.1688), igd10umd32(7.15.10.1688)

Motherboard Bios version 1.0.3
The only graphics related setting is the boot video device, which is set for the on-board adapter, instead of the PCIx device, which isn't present anyway.

Other than driver and windows updates, and development tools, nothing has been installed on this system that was not default from Dell.

While your team is looking into this, should I try installing older versions of the graphics driver? If so, where can I find them?

Thanks!

Bild des Benutzers Neal Pierman (Intel)

Ted,

There's an earlier version of the driver available (1637), but it will not work with GPA (you'll get the same "instrumented driver not installed" msg).

However, try starting up the remote server again, then startup the GPA System Analyzer, and when it displays the error message, select "save report", then save this to a file and post that file here on the forum. This will hopefully provide more detailed information that we can use to find out what's happening here.

Thanks!

Neal

Hi Neal,

I've attached the System Analyzer report as you requested, I also posted one from last week for the Frame Analyzer. If you need any more information from my side please let me know.

Thanks for continuing to look into this.
Ted

Anlagen: 

Bild des Benutzers Neal Pierman (Intel)

Ted,

The development team has created a small utility that I would like you to download and run. This will give us more information regarding your configuration that we'll need in order to be able to diagnose the issues that you are seeing.

If this is ok with you, I'll upload the utility to ftp.intel.com, and send you the info on how to upload and the pwd for it in a separate private msg.

OK?

Neal

Sounds good, I'm happy to give it a try. I'll watch for your email.

Bild des Benutzers Neal Pierman (Intel)

Thanks for trying this out... I've received the output from this utility from you, and have forwarded it to the development team for analysis (though it doesn't look like much, supposedly there's lots of good info in those few characters of output!).

Regards,

Neal

ps-> Also, I'm assuming that you are running directly on both the client and target machines, and not using "Remote Desktop Connection" to connect to the systems?

That is correct, Remote Desktop was not used at any point during my original attempts, or while running the app you provided. I thought I might with this, but I'm trying to keep the system as clean as possible. I am glad to hear that there is more info in the output that was evident.

Bild des Benutzers Neal Pierman (Intel)

Sorry for not responding more quickly... it ends up that the developer working on this has been away from the office due to illness for the past few days, and is not expected to return until late this week.

Thanks for your patience on this!

Regards,

Neal

ps-> update as of noon on May 7th; developer is back in the office and is working on this issue

Great, I'm glad the individual is feeling better. Thanks for the update!

Bild des Benutzers Neal Pierman (Intel)

Ok, I just heard back from the driver team, and they are wondering if on your Dell system you have the option of setting a BIOS parameter named MCHBAR? Would you be able to check this and let us know?

thanks!

Neal

Bild des Benutzers Neal Pierman (Intel)

As an update for those watching this thread, we're doing some more checking on this particular system; we're trying to narrow down whether it's an issue with the system configuration (namely the BIOS parameters), or the graphics driver.

Thanks!

Neal

Bild des Benutzers Neal Pierman (Intel)

We've been able to acquire one of these systems, and will begin testing shortly to try and duplicate the problem.

Neal

Bild des Benutzers Neal Pierman (Intel)

Hello,

I believe we have a solution to this problem. It requires an upgrade to your BIOS to the latest version (1.1.4).

You can download the BIOS installer from this link.

The Dell support page contains the link above and BIOS installation instructions.

Please let me know if this solves your issue.

Regards,

Neal

Best Reply

Installing the latest BIOS has solved this problem! Thanks to you and your team for the effort!

Deleted posting by myself

Bild des Benutzers Neal Pierman (Intel)

Hello,

BTW, the driver team will soon be releasing a fix for desktop systems using the G45 chipset (the laptop version is still WIP). I'll post download info on this when it is officially released.

Specifically, this new version uses a different method for accessing the GPA metrics -- this method will work independent of the BIOS settings, so you won't have to try different BIOS versions until you find one that works.

Regards,

Neal

Bild des Benutzers Neal Pierman (Intel)

Hello,

I was just checking to ensure that there were no "open" items, and noticed that I never explicitly followed up on this.

So I just wanted those watching these threads to know that the updated drivers were released and have been available for download for some months now. Also, we've not had any further reports of similar problems, so I believe that this item is no longer an issue.

Regards,

Neal

Melden Sie sich an, um einen Kommentar zu hinterlassen.