ifc8.0, mkl6.1 and libguide.so

ifc8.0, mkl6.1 and libguide.so

Bild des Benutzers L. D. Marks

It looks like the versions of libguide.so which come with ifc 8.0 and mkl6.1 are different; the one with ifc 8.0 cannot be used for mkl6.1 since it does not have all the required routines. This is for a redhat 9.0 system where I cannot do a -static link. I can only get the code to run by setting LD_LIBRARY_PATH to look first at the mkl6.1 library. Has anyone worked out the "best" strategy to this?

N.B., in calculations on a dual-memory 3.4G P4 attempts to use more than one thread seem to be really bad, slowing down the code by 50% -- perhaps due to inconsistencies....

1 Beitrag / 0 neu
Nähere Informationen zur Compiler-Optimierung finden Sie in unserem Optimierungshinweis.