Download failed of MeeGo QEMU Target and Download MeeGo Toolchain

Download failed of MeeGo QEMU Target and Download MeeGo Toolchain

Hello, I wanted to start developing on my ExoPC tablet from the AppUp talk in Barcelona but I'm having some problems. Firs trying to install your SDK in Ubuntu from this link: (by the way, try to update other links to the last sdk please!) I've got my first error message: W: GPG error: Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 0BC7BEC479FC1F8A I got it working thanks to a wiki page: who said to do: gpg --keyserver --recv 0BC7BEC479FC1F8A gpg --export --armor 0BC7BEC479FC1F8A | sudo apt-key add - (This could be useful for someone!) But now I can't continue because I get: Part 4 (of 5): Download MeeGo QEMU Target (~690MB file) -------Image version is 1.1.90..2.20110209.4-------------------------------------- --2011-02-17 21:37:15-- Resolving Connecting to||:80... connected. HTTP request sent, awaiting response... 404 Not Found 2011-02-17 21:37:19 ERROR 404: Not Found. Download failed! ------------------------------------------- Part 5 (of 5): Download MeeGo Toolchain (~280MB file) ------------------------------------------- --2011-02-17 21:37:19-- Resolving Connecting to||:80... connected. HTTP request sent, awaiting response... 404 Not Found 2011-02-17 21:37:19 ERROR 404: Not Found. Download failed! It seems the files aren't there because of the 404 error. Could someone fix this please? PS: I hope this is where I should post this. PS2: How can I know what version of the MeeGo SO is running on my Tablet? (I think its the last one, because I downloaded it, put it in a pendrive and booted from it and looks the same). PS3: I got some complaints about the performance of MeeGo on the tablet, should I open another post here?
15 Beiträge / 0 neu
Letzter Beitrag
Nähere Informationen zur Compiler-Optimierung finden Sie in unserem Optimierungshinweis.

Hi AwesomeBytes:

Thanks for attending our Barcelona AppLab. And thanks again for diving in.

First off, let me clarify 2 things:
1) If you want to make use of our AppUp SDK, it only supports our Window version of MeeGo SDK for now. The Linux version of MeeGo SDK is not currently compatible with our AppUp SDK yet.

2) If you have our MeeGo 1.2 Tablet UX Pre-Alpha Release installed, it is very possible for you to just develop directly on your ExoPC. GNU compiler toolchain is installed by default. You can also use our Intel compiler available at

This should solve your Linux SDK installation problem.

And yes this forum is open for any question. Please feel free to continue this thread for your needs/questions. Opening a new thread is also possible.



About 1) Ok, I hope we can enjoy soon a Linux version :) (And a Windows 7 64bit version too! thats my system!)

About 2) I'll try that, I'll search for some documentation to do that. But... my ExoPC freezees in a black screen randomly. Sometimes happens in 10min sometimes in 30min. I just can't do anything that is not pushing the power button. Any hint on unblocking it?

Thanks for your help Vincent :)


Hi Sam:

In your case, now that I know about your setup :), I think there is a 3rd option:

a) Go to this link again:

b) download MeeGo SDK 1.2 for Windows

c) download AppUp SDK for MeeGo (a little bit below the MeeGo SDK on the same page)

d) follow instructions on this page:
to start developing/compiling your app using Qt Creator IDE that comes with MeeGo SDK.
Since your system is Window 64-bit, you are not going to be able to run your app using Qemu. So you can only develop and compile.

e) After you compile, under Qt Creator IDE, there is a "compile output" window. In that window, it will tell you the RPM that it has built for you.
You will only get that RPM if it is a successful compilation. Note down the location of this RPM

f) Copy that RPM file onto an USB key and install it on your ExoPC for testing.

Step (f) may have a slight detour if you have integrated with our AppUp SDK (steps above are assuming you have not integrated with AppUp SDK API).
If you have integrated with AppUp SDK API, let me know and I will give you (f).1, (f)2., (f).3 etc...

Hope this helps.

Hi all!

I don't want to create new topic and ask here.

I trying to install MeeGo SDK 1.2 for windows. And during the target download I have this problem:

mad-admin create -f meego-tablet-ux-ia32-
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
59 331M 59 199M 0 0 194k 0 0:29:06 0:17:26 0:11:40 0
curl: (18) transfer closed with 139380980 bytes remaining to read
Download failed!

I tried several times but had the same result. Has anybody ideas, what I can to do?

Hi Alexey:

Thanks for downloading our SDK and sorry for the error.

I just confirm the same command in my madde terminal and I am able to get tablet-ux for meego created/downloaded.
Can you confirm two things for me:

1) Can you try to run/launch madde terminal as administrator? If you press right mouse button next to the madde terminal option from start-menu, there should be an option that says "run as administrator"

2) Can you describe your network setup? Is it wifi over a DSL line or something else? This should not matter but trying to root cause the situation.



Hi Vincent

1) Doesn't help
2) I'm in corporative network over proxy, but I already do export http_proxy=x.x.x.x:8080 before run mad-admin create

I it's problem on my side than I will ask for my it support department.


Hi Alexey:

Are you able to get a network connection without any proxy environment?
This is just so we can eliminate the proxy as the culprit.



Unfortunately not.

I too have faced this issue in the past and have always felt that it was related to a bad internet connection. I did get the failure message once or twice during certain but later on the download got done.

The major issue however was that the entire download was always restarted. There is no 'resume' feature within MADDE, I think.

So, is it possible to download the target and runtimes from outside MADDE, from some sort of a repository. Atleast that may allow us to 'Download Accelerator with resume features', assuming that 'resume' is supported.

Am I thinking along the right lines?

Please advise.

It should be possible to download runtimes externally and put them in the cache directory. (At least, that worked for me when I noticed that there were around 400 megs to go on an image that I'd already downloaded earlier for a botched attempt at installing the SDK by hand - but I don't remember the exact steps taken.).

curl also supports resuming - putting '-C -' in the .curlrc of the account running madde may work, though I haven't tried it myself.

@Bosco You can run mad-admin fetch command to get actual URLs of all the Targets and Runtime files. Once you have the URL you can download the files using DAP or any other downloaded helper with resume support.

After you have downloaded those files you need to put those files in cache directory as Spiky pointed out. After placing the files in cache directory inside the MADDE installation directory, you can run the create commands and it will detect the file is already downloaded and will start installing straightway preventing you from all those broken downloads and half-downloads situations.

You can get more info about various MADDE commands at -

Hope this helps. I installed the development environment using this approach on my machine and it worked. Also if you plan to install on multiple machines, you can copy the cache directory on another machine and run various commands and your installation will be finished in jiffy as no download will be required.


Sachin Palewar

Which among folowing is the runtime and terget for netbook and tablet

I got it after running "mad-admin fetch"

Available URL_ALIAS names:


























Hi Bapi,

Sorry since forums don't have email notifications for replies, I didn't know that you asked another question. Just checked your question.

Incase you haven't already figured out the right files names, here are filesnames from our cache directory for both netbook and tablet:


Thank you for this information.

Melden Sie sich an, um einen Kommentar zu hinterlassen.