Possible problem with IVF 2013.0.089 Compiler in Debug Mode

Possible problem with IVF 2013.0.089 Compiler in Debug Mode

I was in the process of recompiling one of my programs which had no previous compiling errors in 2011.11.344.  I was in the debug mode and I got several syntax errors on the following data statement:

 C     
      DATA COEFF/5.316,0.14285E-01,-0.8362E-05, 0.1784E-08,             CO2
     &7.70,0.04594E-02,0.2521E-05,-0.8587E-09,                                 H2O
     &6.903,-0.03753E-02,0.1930E-05,-0.6861E-09,                              N2
     &6.157,0.1384E-01,-0.9103E-05,0.2057E-08,                                 SO2
     &6.085,0.3631E-02,-0.1709E-05,0.3133E-09,                                 O2
     &6.726,4.001E-04,1.283E-06,-5.307E-10/                                      CO

The syntax errors were like this: "Error 7  error #5082: Syntax error, found REAL_CONSTANT '.70' when expecting one of: ( * , % [ / E:\Fortran Projects\XXXX600\XXXX600\XXXs600.for 1094 7.70".  This happened on every continuation line of this statement.  The errors do not occur in the Release mode.

What I found causing this is the compound names (CO2, H2O, etc) which start in column 73.  My program is set up for fixed formating.  If I remove them or add a comment "!" in front of them the error does not occur.  Also there were no tab setting.  Please let me know what you find.

10 Beiträge / 0 neu
Letzter Beitrag
Nähere Informationen zur Compiler-Optimierung finden Sie in unserem Optimierungshinweis.
Bild des Benutzers bmchenry

you don't mention if you used the option for Fixed Form Line Length :132 Columns (/extend_source:132)
If so, then it may be a bug. You might try to be sure that column 72 is blank and see if that avoids the issue.
if not, then Fortran expects things to end at column 72 for fixed formatting.
ahhh...just remembered the ole days wherein the line number was on fields 73-80
and you are using those fields for 'comments'...
guess i'll defer to Intel folks on this one as i haven't used fixed formatting in decades..

Bild des Benutzers Steve Lionel (Intel)

Also, you may have used a text editor that changed blanks to tabs. The compiler considers a tab to be one column. I tried copying and pasting the code you had here but didn't see a problem.

Steve

Fixed length is 72. I am using editor in VS2010. I have been working on this program over the last couple of months and this is the first issue I have had with IVF compiling it. The release mode is also set up for 72 columns fixed length and I get no errors.

Bild des Benutzers Steve Lionel (Intel)

Please ZIP the file in question and add to the ZIP file the buildlog.htm from the Debug subfolder. Attach the ZIP to a reply here so that I can look at it.

Steve

Here is the subroutine and both the release and debug log files zipped. I can not attach the full program.

Anlagen: 

AnhangGröße
Herunterladen compiler-error.zip5.05 KB
Bild des Benutzers Robert van Amerongen

Ken,

I have compiled your SUBROUTINE DELHH but found no error. With the option /warn:all the compiler complains on truncation of lines (#5194) and variables without explicit type (#6717) but that's all.

Robert

Bild des Benutzers Steve Lionel (Intel)

Ken, you attached only the subroutine, not the whole source file. I suspect there is something else in your source file that triggers this problem, and I have a guess as to what it is. What happens if you turn off "Check routine interfaces" under Diagnostics? Please click "Send Author A Message" and attach a ZIP of the whole source file in a private message to me so that I can investigate.

Steve
Bild des Benutzers Steve Lionel (Intel)

Ken gave me sufficient source to reproduce the problem. It requires there to be another subroutine/function in the source that does a CALL (doesn't matter what to) and for generated interface checking to be enabled, as it is by default in a Debug configuration on Windows. I have escalated this to development as issue DPD200236944 and asked them to fix it as soon as possible. It may be too late to get in to Update 1, but I expect it to be fixed for Update 2. Workarounds include 1) Disabling generated interface checking, 2) Enabling preprocessing for this file.

Steve
Bild des Benutzers Steve Lionel (Intel)

I expect the fix for this to be in Update 2 (January or maybe February.)

Steve

Melden Sie sich an, um einen Kommentar zu hinterlassen.