How to solve - Debugg Assertion Failed

How to solve - Debugg Assertion Failed

Bild des Benutzers Ajain A.

Hello All,

I am getting following error in this line while debugging my main.90 file

call call_mg1g1_load(Mg1g1FileStr)

Note:

character(256)    :: Mg1g1FileStr = ''

Mg1g1FileStr = 'c:/Users/Ajain/My Documents/Visual Studio 2008/Projects/mg1g1_perfo/input/PrgOpt.Batch      '       '                                                                                                                                                               

Error:

1)Debugg Assertion Failed  

Expression (stream!=Null)

Abort Retry Ignore

VSS Quick watch Option Shows:

call_mg1g1_load | Undefined variable call_mg1g1_load

 

Class View Contains: (while running)

1)Global Functions and variables (This contains this function: call call_mg1g1_load and other c functions)

2)Macros and Constants

 

 

call_mg1g1_load fuction is written/defined in C project source files (project is in release mode)

I am calling this funtion from main.90(fortran main file). This fortran solution is in debug mode

My program is crashing on this line, somebody please help how to move ahead & what is the reason???

 

My VSS Solution Explorer:

solution mg1g1(2 projects)

1)mg1g1 (C project) ---- (it is kept in release mode) & no binary built for this.

2)test_lib(fortran f90 project)  -- this is a testing environment for above C project ( for speed optimization). This is kept in debug mode

Somebody please help me.....

 

16 Beiträge / 0 neu
Letzter Beitrag
Nähere Informationen zur Compiler-Optimierung finden Sie in unserem Optimierungshinweis.
Bild des Benutzers Steve Lionel (Intel)

I think this is an error reported about the Visual Studio environment and the Fortran debugging support. It should not, in itself, result in your program crashing. If you simply run the program under the debugger without stopping at breakpoints, etc., does this error occur? Or a different error?  What did you do in the debugging session that triggered the error?

Steve
Bild des Benutzers Ajain A.

Dear Steve,

Thanks a lot for your reply.

 "What did you do in the debugging session that triggered the error?"

I  put breakpoints on folloowing line and debugging by pressing F5/f10/f11 which will cause the above mentioned error

otherwise it will give

Native' has exited with code 0 (0x0). ( sucess return code)

Bild des Benutzers Steve Lionel (Intel)

Ok, so it was some interaction with the debugger that made the error appear.  Are you able to provide a ZIP of the project and a list of the exact things you did to make the error appear?

Steve
Bild des Benutzers jimdempseyatthecove

>>
1)Debugg Assertion Failed 
Expression (stream!=Null)

 The C runtime library, Stream I/O code likely contained

_ASSERT(stream!=Null);

Meaning the stream handle was not opened (iow was NULL).

So you failed to open the stream on which you were outputting.

Jim Dempsey

www.quickthreadprogramming.com
Bild des Benutzers Steve Lionel (Intel)

Jim,

This is not an error from the user program - it is an error reported by the Visual Studio integration. It is likely due to some bug in the Fortran integration, but without a test case we can try there's little we can do about it.

Steve
Bild des Benutzers Ajain A.

Dear Steve,

Thanks a lot Steve, I will come back to u soon.

Bild des Benutzers Ajain A.

Dear Jimm,

Thank u very much for the answer, it is informative.

 

Bild des Benutzers Ajain A.

Dear Steve,

I have sent a message with my project zip, waiting for your reply. Kindly respond.

Thanks

Bild des Benutzers Steve Lionel (Intel)

I sent you my response earlier today. You'll have to go check for it - email notifications have been disabled temporarily. That said, I couldn't reproduce any problem with the current version - you're using 11.1 and we have made many improvements since then.

Steve
Bild des Benutzers Ajain A.

Dear Steve,

Sorry I didn't understand you actually!!!! Is my attachment contain any security risk???? OR Is it working fine at your end??

I am asking as per your below post, Hope you are saying that you replied about this one below....

"No scanning on attachments is done. But there are risks with most any file type nowadays."  Mon, 01/21/2013 - 06:26

If there is anything else please let me know. kindly reply

Should I scan it and send you once again???

Thanks you very much for your response.

Bild des Benutzers Steve Lionel (Intel)

My comments about scanning in another thread were not directed to you.

Steve
Bild des Benutzers Ajain A.

Dear Steve,

Thanks you very much for your answer, it is very informative to me. As per you suggested, I have some queries. Can please reply  to my following questions?

1)      “You are using a no-longer supported version of the compiler. “

 

  • How can I prove that I am using wrong FORTRAN compiler version.
  • My VSS MSDN help displays “Intel® Visual FORTRAN Compiler Professional Edition 11.1”. As per my given system requirements, Version 11.1 should run the project.
  • Can you suggest which version of compiler is fit to my project purpose?
  • If so, can you please help me with download link?

          Note: My compiler initially installed was Intel FORTRAN 9.1. later on, it updated with some patches or other files by my network admin. Now they made the version as 11.1

2)      “You can use our tools such as Intel VTune Amplifier XE to analyze the performance”

 

  • Are these tools freeware?
  • Is there any extra coding to be done for analyze the C performance? (If it integrates and works automatically other than some external tool configuration, which will be great to reduce the coding time)

 

 

 

3)      “I recommend consistently using the debug libraries for both in a Debug configuration”

 

  • How can I establish the debug configuration to both of my project at the same time? Will it be feasible to my current existing project model?
  • Should I create Exe for my C project as well? Can I resolve this issue in this way?

 

Bild des Benutzers Steve Lionel (Intel)

The current product version is Intel Visual Fortran Composer XE 2013, compiler version 13.0. You are using version 11.1 from 2009 which is no longer supported by Intel. The error you are seeing from Visual Studio is, I think, fixed in a Fortran version newer than what you have. I also could not reproduce the runtime error using the current version.

Intel VTune Amplifier XE is not freeware, but you can download and install a free 30-day trial copy from http://software.intel.com/en-us/intel-parallel-studio-XE-2013-evaluation...

To make the library setting consistent, set the C project property C/C++ > Code Generation > Runtime Library to "Multithreaded (/MT)" and set the Fortran project property Fortran > Libraries > Runtime Library to the same thing.

Steve
Bild des Benutzers Ajain A.

Dear Steve,

As you suggested, I am planning to install the trial version of "Intel Visual Fortran Composer XE 2013, compiler version 13.0". My question is, since I am using this fortran 11.1  for last couple of weeks will the new version install in the same machine & how long will it work(next 30days?).

Can you kindly answer?

Bild des Benutzers Steve Lionel (Intel)

You asked this in a separate thread and I answered there.

Steve

Melden Sie sich an, um einen Kommentar zu hinterlassen.