KNC General Exploration in VTune loops over 4 times

KNC General Exploration in VTune loops over 4 times

Hello,

I hope someone from Intel familiar with VTune could comment. When I use the "General Exploration" analysis for the Knights Corner architecture in Vtune 2013 Update 4, my code is being run by VTune four times instead of just once (magic number 4?). This does not happen when I do "General Exploration" for Sandy Bridge: my code is run just once in this case. I found this behavior in the GUI, but later reproduced it in the command line. The listing below shows it all. Thanks!

[avladim@dublin prog]$ cat test-general-exploration.cc 
#include <omp.h>
#include <cstdio>
#include <unistd.h>
int main() {
#pragma offload target(mic)
 {
 printf("Hello!\nThreads: %d\n", omp_get_max_threads());
 fflush(0);
 usleep(3e6);
 printf("Good bye!\n");
 fflush(0);
 }
}
[avladim@dublin prog]$ 
[avladim@dublin prog]$ icpc test-general-exploration.cc -o test-general-exploration -O3 -g
[avladim@dublin prog]$ 
[avladim@dublin prog]$ # This is the Sandy Bridge General Exploration. It works fine.
[avladim@dublin prog]$ amplxe-cl -collect snb-general-exploration -- ${PWD}/test-general-exploration
Hello!
Threads: 236
Good bye!
amplxe: Using result path `/home/avladim/prog/r000ge'
amplxe: Executing actions 33 % Resolving information for `libstdc++.so.6.0.13' 
amplxe: Warning: Cannot locate symbols for file `/usr/lib64/libstdc++.so.6.0.13'.
amplxe: Executing actions 35 % Resolving information for `libc-2.12.so' 
amplxe: Warning: Cannot locate symbols for file `/lib64/libc-2.12.so'.
amplxe: Executing actions 36 % Resolving information for `libpthread-2.12.so' 
amplxe: Warning: Cannot locate symbols for file `/lib64/libpthread-2.12.so'.
amplxe: Executing actions 37 % Resolving information for `ld-2.12.so' 
amplxe: Warning: Cannot locate symbols for file `/lib64/ld-2.12.so'.
amplxe: Executing actions 50 % Generating a report 
Summary
-------
Elapsed Time: 5.891
CPU Usage: 0.530
amplxe: Executing actions 100 % done 
[avladim@dublin prog]$ 
[avladim@dublin prog]$
[avladim@dublin prog]$ # This is the Knights Corner General Exploration. It loops over 4 times for unknown reasons.
[avladim@dublin prog]$ amplxe-cl -collect knc-general-exploration -- ${PWD}/test-general-exploration
Hello!
Threads: 236
Good bye!
Hello!
Threads: 236
Good bye!
Hello!
Threads: 236
Good bye!
Hello!
Threads: 236
Good bye!
Hello!
Threads: 236
Good bye!
amplxe: Using result path `/home/avladim/prog/r001ge'
amplxe: Executing actions 34 % Resolving module symbols 
amplxe: Warning: Cannot locate file `/lib64/ld-2.14.90.so'.
amplxe: Executing actions 34 % Resolving information for `ld-2.14.90.so' 
amplxe: Warning: Cannot locate file `/boot/vmlinuz-2.6.38.8-g32944d0'.
amplxe: Executing actions 35 % Resolving information for `vmlinux' 
amplxe: Warning: Cannot locate file `/lib64/libc-2.14.90.so'.
amplxe: Executing actions 35 % Resolving information for `libc-2.14.90.so' 
amplxe: Warning: Cannot locate file `micscif.ko'.
amplxe: Executing actions 37 % Resolving information for dangling locations 
amplxe: Warning: Cannot locate file `/lib64/libcoi_device.so'.
amplxe: Executing actions 50 % Generating a report 
Summary
-------
Elapsed Time: 22.305
CPU Usage: 0.179
amplxe: Executing actions 100 % done 
[avladim@dublin prog]$ 
[avladim@dublin prog]$ amplxe-cl --version
Intel(R) VTune(TM) Amplifier XE 2013 Update 4 (build 270817) Command Line Tool
Copyright (C) 2009-2013 Intel Corporation. All rights reserved.
[avladim@dublin prog]$

5 Beiträge / 0 neu
Letzter Beitrag
Nähere Informationen zur Compiler-Optimierung finden Sie in unserem Optimierungshinweis.

There is a setup option to allow multiple runs so as to collect each of the required event counters over a complete copy of the run.  If that option is set off, it should automatically alternative among collection of the various counters ("multiplex ?"), so as to collect all of them at different times in a single run of the workload.

Multiple runs might be preferred for a very short running workload, if it is possible to replicate accurately, while alternating among counters is likely preferable for runs of an hour or more, or runs where default sampling intervals accumulate too much data in repeated run mode.

A prerelease version of this VTune ignored this setting and made multiple runs regardless.

Thank you, Tim! I found this option, it is in "Project Properties" in section "Advanced" (hidden by default), the name of the option is "Allow multiple runs". The check box is not checked in my setup, but VTune performs multiple runs nevertheless. I must be using a version that ignores it: Update 4 (build 270817).

Hey Andrey,

This was a common problem in update 4, instead of multiplexing, VTune did multiple runs. Try update 5, should be fixed there.

Best,

Michael

Thanks, Michael. I had missed the fact that update 5 has been released. Everything works as it should in update 5.

Melden Sie sich an, um einen Kommentar zu hinterlassen.