MPI only works when connected to remote hosts via RDP

MPI only works when connected to remote hosts via RDP

Bild des Benutzers Ian G.

Hello, I am experiencing an issue where MPI only executes the work on remote hosts when I am connected via RPD to those hosts.

I have a large processing job which has been split into parcels and farmed out to hosts. I can see from the log files generated by each host and written back to my central repository (mapped drive passed with the -mapall switch) that the hosts receive the instructions but then appear to stall. If I stop the job, connect to the hosts via RDP and then restart the job the hosts will happily process away.

From what I have read the MPI authentication is closely connected to RPD but it appears to be more than an authentication problem as I have added the -login switch to force me to authenticate and it doesn't make a difference.

Does anyone have a suggestion as to how to I can identify the issue?

Regards
Ian

4 Beiträge / 0 neu
Letzter Beitrag
Nähere Informationen zur Compiler-Optimierung finden Sie in unserem Optimierungshinweis.
Bild des Benutzers James Tullos (Intel)

Hi Ian,

I'll need some additional information.  What version of the Intel® MPI Library are you using?  How are you launching the job?  Can you provide the output with I_MPI_DEBUG=5?

Sincerely,
James Tullos
Technical Consulting Engineer
Intel® Cluster Tools

Bild des Benutzers Ian G.

Thanks for getting back to me James. Subsequent testing has revealed that the issue is not with MPI but rather access to a third-party license server. When there is an open session on the remote computer MPI can access the license and process the job but if the remote computer doesn't have an open session it stalls on access.

Regards
Ian

Bild des Benutzers James Tullos (Intel)

Understood.  Thanks for the update.

Melden Sie sich an, um einen Kommentar zu hinterlassen.