Intel AMT unreachable after power off

Intel AMT unreachable after power off

Bild des Benutzers vladimir b.

Hello,

I've been trying to solve an issue with AMT for couple of days and have nowhere to turn anymore, so I'm trying here. 

My problem is simple: After I turn OFF PC which has AMT configured AND AFTER OS has loaded (VMware ESXi), AMT becomes unreachable.
AMT is set up with Power Policies : Desktop: ON in S0, ME Wake in S3, S4-5 active.

If I power OFF system BEFORE OS has loaded, AMT is accessible after PC has been turned OFF.

Im using Gigabyte GA-Q87M-D2H motherboard (which has Intel I217-LM NIC on-board) with i7-4770S CPU, 32G RAM and Seasonic 80+Gold PSU. I've tried changing PSU, removing UPS ( directly connecting PC to power outlet ) without any difference.

When PC is ON, i can access all AMT features such as KVM, turn it ON, power cycle, reset etc. I can also turn OFF the PC, and if I do it BEFORE OS loads ( or if I remove OS drive altogether ) I can reach AMT while PC is OFF and turn it back ON. But once OS is loaded, and i shutdown PC (graceful or just long press on the power button ) AMT is unreachable until powering on the PC.

Any advise I can try ? I've tried loading safe and optimized BIOS defaults without any difference.

 

9 Beiträge / 0 neu
Letzter Beitrag
Nähere Informationen zur Compiler-Optimierung finden Sie in unserem Optimierungshinweis.
Bild des Benutzers vladimir b.

I've re-installed ESXi, imported all VM's as they were previously and now AMT is accessible after I power OFF the PC.
So now I have two USB sticks with pretty much same OS configured (ESXi)

  • If I boot  the old one, and shut down the PC, AMT will not be reachable after power OFF.
  • If I boot  the new one, and shut the PC down, AMT WILL BE reachable after power OFF. 

Since this is so easily reproducible, how is it possible that OS can bring down AMT ?

Bild des Benutzers Gael Hofemeier (Intel)

It kind of sounds as if the OS is not sharing the IP address once it starts (in the old configuration.)   It sounds like a network issue/ip address assignment issue.

In the old configuration can you access the WebUI?  Is respond to ping on? If you look at your DHCP server, can you "see" the ME's IP address, or does the ME physically get shut off?  Maybe for some reason it is not waking on lan in this situation.  I assume you are using dynamic IP and you have the option to share the IP address between the host and the ME turned on.  I don't know what is different between your "old" usb config and the new one.  What version of AMT is this and this is a desktop client - from your NIC, it sounds like AMT 9?

Follow me on Twitter: @GHIntelBlogs Facebook: https://www.facebook.com/gh.intelblogs
Bild des Benutzers vladimir b.

Thanks for your response.

1, It is AMT 9 (it is Haswell CPU)
2, I'm using static IP's for AMT (192.168.1.99) and Static IP for ESXi host (192.168.1.100)
3, When i wrote AMT is not reachable, i meant the WebUI. It is not reachable AFTER the OS shuts down. During power ON (even with old USB system) WebUI is accessible.

I've just checked the LEDs on the back of the motherboard (NIC LEDs) and difference is quite obvious. When I shut down ESXi with 'old' system, LED's on the NIC card in the back go completely dead. No flashing lights on any network activity.

When I shut down ESXi with 'new' system, LEDs on the back keep flashing, showing random network activity and obviously AMT WebUI is accessible. 

Bild des Benutzers Gael Hofemeier (Intel)

I'm guessing that your "old" and "new" systems are not identical.  Have you ever used tools such as wireshark to monitor the network traffic?  Maybe you would be able to see what is happening.  Is there anything in the even log?

Follow me on Twitter: @GHIntelBlogs Facebook: https://www.facebook.com/gh.intelblogs
Bild des Benutzers vladimir b.

Sorry for late response I was on business trip for awhile...

I had some time to play with the Haswell system again this weekend and unfortunately it keeps happening no matter what OS is installed. After random shutdowns, i can not load ( or ping ) IP:16992 . There is not much I can do with Wireshark since system is completely unresponsive after shutdown so I have no way to turn it back on remotely.

Hardware configuration is exactly same, i havent touched the system between the shutdowns and system is plugged into the wall. I've tried 'dumb' UPS as well. Sometimes AMT is reachable after the shutdown but mostly its not.

I thought the whole point of vPro and AMT in general was to be able to connect to the Workstation as long as it has Network connectivity and power. Which logs would I need to pull to trbleshoot this further ?

Bild des Benutzers Gael Hofemeier (Intel)

Can you verify that you have the correct version of MEI drivers/ LMS software on your system? You should have version 9.x on your Haswell system. And do you have the latest FW?  

Follow me on Twitter: @GHIntelBlogs Facebook: https://www.facebook.com/gh.intelblogs
Bild des Benutzers leo h.

Using gigabyte Q87M-D2H, bios version 4.

Running esxi 5.5 with a custom e1000e.vib v.2.3.2.

If not the esxi can't detect the i217-LM nic.

I began facing the same problem whereby the power will be cut completely upon shutdown.

Then I realised I turned off the wake up on LAN for the i217-LM under the

BIOS| Peripherals | Intel i217-LM | NIC Configuration | Wake on LAN ( change from disabled back to Enable ).

It became ok after this.

I'm using a antec earthwatts 650W psu.

May I know whether you are using a newer e1000.vib ?

Or how did you get exsi to recognize the i217-LM nic. Thanks.

 

 

 

Bild des Benutzers vladimir b.

Thanks, I will check that out.

 

As far as ESXI 1217-LM driver... see here

http://shell.peach.ne.jp/~aoyama/wordpress/download/net-e1000e-2.3.2.x86...

 

It's discussed in the comments of this article 

http://www.vladan.fr/haswell-esxi-whitebox/

 

Melden Sie sich an, um einen Kommentar zu hinterlassen.