ifort: error #10037: could not find 'link'

ifort: error #10037: could not find 'link'

Hi everyone,

I have installed Intel Composer XE 2013 SP1 (evaluation version), since I need it for a shortterm project.

I also installed Visual Studio 2012 today before installing the Intel Composer.

Now when I try to run a simple 'Hello_world.f' program (with the command 'ifort Hello_world.f'), I get the following error:

ifort: error #10037: could not find 'link'

I have been searching today for an answer, which led me to making changes to 'compilervars_arch.bat' and 'compilervars.bat'. In the end it still had no results, and therefore I reinstalled both VS2012 and Intel Composer again.

I have included "C:\Program Files (x86)\Intel\Composer XE 2013 SP1\bin\intel64;" to the PATH environment variable, because otherwise I would get the error that the ifort command is not found.

I hope you guys can help me, and if you need more information, feel free to ask.

4 Beiträge / 0 neu
Letzter Beitrag
Nähere Informationen zur Compiler-Optimierung finden Sie in unserem Optimierungshinweis.

How are you starting the command prompt session? You should not have to edit the .bat files.

Use Start > All Programs > Intel Parallel Studio XE 2013 > Command Prompt > Parallel Studio XE with Intel Compiler XE 14.0 > Intel 64 Visual Studio 2012 Mode

If from this session you still get errors, please copy the entire session log, starting from the beginning, into a reply here.

Steve - Intel Developer Support

Thanks for the quick response!

I was running a normal Windows Command prompt session...

Now it does indeed work!

Thanks again.

From a plain command prompt session, you'll need to do a "call <path to>compilervars.bat intel64 vs2012"

Steve - Intel Developer Support

Kommentar hinterlassen

Bitte anmelden, um einen Kommentar hinzuzufügen. Sie sind noch nicht Mitglied? Jetzt teilnehmen