Problem with Xcode 5.0.1 and XE Composer SP1

Problem with Xcode 5.0.1 and XE Composer SP1

Bild des Benutzers Claude Perron

I just purchased Composer XE 2013 SP1 (C,C++ and Fortran) update 1  after mooving to OS X Maverick and Xcode 5.0.1.

It seems to have installed properly i.e. files are at the right location i.e. /opt/intel/... , the command line works, but it seems Xcode 5.0 does not "see" the compiler.  Whenever I build and try to execute I get the : SBTarget invalid.  I tried to re-install the compiler , without success.

Anyone could help?

2 Beiträge / 0 neu
Letzter Beitrag
Nähere Informationen zur Compiler-Optimierung finden Sie in unserem Optimierungshinweis.
Bild des Benutzers Ronald W Green (Intel)

It sounds like you need to set up the Build Rule 'Default Fortran rule'. 

First, follow steps 1, 2, and 3 here http://software.intel.com/en-us/node/463118 to create a project and add a simple Fortran file.  Don't proceed to the build step as we know this won't work just yet.  Next, set up the Default Fortran Rule:

  1. Select the target you want to change and click Build Rules.

  2. From the Xcode menus, select menu 'Editor' -> menu item 'Add Build Rule'.

  3. Under "Process" selector, change 'Source files with names matching' to 'Fortran source files'.

  4. Under "Using" selector, change "Customer Script" to Intel® Fortran Compiler XE 14.0.

  5. Select the target to be built under Targets.

  6. Now you should be able to build.

Melden Sie sich an, um einen Kommentar zu hinterlassen.