ifort: error #10037: could not find 'link'

ifort: error #10037: could not find 'link'

Hi, I got started to use windows version intel fortran - I have used linux intel fortran +10 years

1.

after installing w_ics_2013.1.039.exe, all programs -> intel parallel studio xe 2013 -> command prompt -> parallel studio xe with intel compiler -> intel 64 visual studio 2010 mode,

C:\Temp>ifort hello.f90
Intel(R) Visual Fortran Intel(R) 64 Compiler XE for applications running on Inte
l(R) 64, Version 14.0.0.103 Build 20130728
Copyright (C) 1985-2013 Intel Corporation. All rights reserved.

ifort: error #10037: could not find 'link'

2.
I reset environmental variables as

C:\Program Files (x86)\Intel\Composer XE 2013 SP1\bin>call compilervars.bat intel64 vs2010
Intel(R) Parallel Studio XE 2013 SP1
Copyright (C) 1985-2013 Intel Corporation. All rights reserved.
Intel(R) Composer XE 2013 SP1 (package 103)
The specified configuration type is missing. The tools for the
configuration might not be installed.

So Neither of them works - it seems that when intel cluster tools are installed, MS visual studio 2010 files for intel and shell are installed together but nothing is working. Any comment?

Best,

Byoungseon

5 Beiträge / 0 neu
Letzter Beitrag
Nähere Informationen zur Compiler-Optimierung finden Sie in unserem Optimierungshinweis.

I haven't done a Cluster Studio install - do you have a separate shortcut for Visual Studio 2010 in the Start menu?

I suggest logging in to Intel Registration Center and selecting the Intel Visual Fortran Composer XE (with Microsoft Visual Studio) download - the full install - and installing that. You'll get a newer compiler version, anyway. Let us know if that helps.

Steve - Intel Developer Support

I haven't tried such an old version of Cluster Studio; I think a current one (or even the previous, final 13.1 compiler version) would be preferable.

There still seem to be issues with installing Cluster Studio if independent installations of some of the same Intel software tools are present.

If the Microsoft X64 tools don't show up (CL.exe, link.exe, .....) when you have a qualifying Visual Studio (Pro or above) installed and working, it looks like the situation where \windows\system32\ isn't set in PATH.  Normally, Visual Studio depends on this setting in your windows boot environment variables.  You will find several discussions of this in a web search if you don't tie it to Intel tools.  vcvarsall.bat (called by compilervars.bat) has to be working with the amd64 option.

Among the confusing factors is that it may be possible to install or repair or apply service packs on Visual Studio and have everything working until you restart Windows, then, if PATH isn't set up correctly, Visual Studio X64 tools can't be restarted.

After several trial and error, including re-installation, I figured out that there is an old VC directory at Program Files (x86)\Microsoft Visual Studio 10.0\
I just renamed it as vcx or whatever, now ifort is working good. Probably solution at https://software.intel.com/en-us/forums/topic/278506 will work on the problem of this post as well.

Glad to hear it.

Steve - Intel Developer Support

Kommentar hinterlassen

Bitte anmelden, um einen Kommentar hinzuzufügen. Sie sind noch nicht Mitglied? Jetzt teilnehmen