Intel® Cluster Ready

Intel MPI 3.2.2.006 and Supported OS and number of cores per machine

Has intel made a statement as to the last know good version of Red Hat that supports Intel MPI 3.2.2.006.  We have a new cluster with 20 cores/per node and have observed a fortran system call failing when more than 15 core per node are used.  This machine is running Red Hat 6.6 x86_64.

Alternatively are their known conditions where Intel MPI 3.2.2.006 will fail.

Bug Report : MPI_IRECV invalid tag problem

Hi, there,

In MPI_5.0.3, the MPI_TAG_UB  is set to be 1681915906.  But internally, the  upper bound is  2^29 = 536870912, as tested out by the code attached.

Same code will run just fine in MPI 4.0.3.

Just to let you guys know the problem.

Hope to see the fix soon. Thanks.

Xudong

Encl:

2-1. Source Code

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

mpivars.sh to build path automatically

Looks like on Linux the intel MPI runtime hardcodes the path of mpivars.sh, eg:
I_MPI_ROOT=/opt/intel/impi/4.1.3.049; export I_MPI_ROOT

On windows on the other hand the path is dynamically generated:
SET I_MPI_ROOT=%~dp0..\..

Is there any reason to why the path cannot also be automatically generated on Linux?
http://stackoverflow.com/questions/242538/unix-shell-script-find-out-whi...

License File Activation

I just received my serial number of single user Intel Cluster Studio 2015 (Linux).  I had done product registration and generated a license file.  However, the license file generation page didn't show any information or steps of "how to apply the license file"...

I am using an evaluation version of Intel Cluster Studio 2015 in Linux workstation.   So, I want to use the above license file.  I copy the license file into /opt/intel/license folder.  Do I need to execute any command?  Is there any guidelines or info.

Thx.

MPI 5.0.2.044 Library Link Error

Hi, Everyone,

Under Linux OS, I built my MPI application with Intel MPI 5.0.2.044.  There is no error in compiling but there are following error in linking MPI library.

I am using the Intel MPI's  libmpifort.a and libmpi_mt.a for linking my application.

LIBS          = -L/opt/intel/composer_xe_2013_sp1.2.144/mkl/lib/intel64 -lmkl_intel_lp64 \
                -lmkl_intel_thread -lmkl_core /net/rdnas/home/dingjun/intel/impi/5.0.2.044/intel64/lib/libmpi_mt.a /net/rdnas/home/dingjun/intel/impi/5.0.2.044/intel64/lib/libmpifort.a

Intel MPI

Hello.

I am developing fault tolerant communicaction layer (MPI-like). So  this layer is slow now. 

Can I learn something about internal Intel MPI architecture to understand basic principles of big data transfering over different networks.

Can I also contact to developers of Intel MPI library to share experiences.

Nicolay.

Problem lauching mpiexec

Hello,

I do not succeed in lauching mpiexec. I'm working with Intel Fortran Compiler 11.1, and Intel parallel studio XE 2015, on windows 7.

In fact I'm using mpiexec to launch a hydraulic simulation with TELEMAC software (http://www.opentelemac.org). This software uses for parallel simulation MPICH2.

When I launch the command "mpiexec -n 4 xxx.exe", I'm asking to give my Account and my password. Is this password the password of the user of the computer? Or is it a password given by Intel with the installation?

Trying to use I_MPI_PIN_DOMAIN=socket

I'm running on an IBM cluster with nodes that have dual socket Ivy Bridge processors and 2 Nvidia K40 Tesla cards.  I'm trying to run with 4 MPI ranks using Intel MPI 5 Update 2 with a single MPI rank for each socket.  I'm trying to learn how to do this by using a simple MPI Hello World program that prints out the host name, rank and cpu ID.  When I run with 2 MPI ranks, my simple program works as expected.  When I run with 4 MPI ranks and use the mpirun that comes with Intel MPI, all 4 ranks run on the same node that I launched from.  I am doing this interactively and get a set of two node

Intel® Cluster Ready abonnieren