Intel® VTune™ Amplifier XE

VTune overflow "collection data limit, MB" while Paused?

It seems that "VTune Amplifier XE 2016 Update1" consumes sample buffer even while it is paused

"The specified data limit of 500 MB is reached. Data collection is stopped." even before I Resume collection, and be able to start profiling.

I would like to delay sample collection untill the point my application is fully loaded and initialized, but have to specify too big sample data buffer over 1GB which is extremely slow at the later processing time.

How to profile the communication between Host and Mic during Offload Mode

Recently I need to know exactly the data communication(exactly how much and when) between the Host and MIC while running an offload application.

Unlike Nvidia, Intel doesn't provide a tool like NV Profiler.

So I guess maybe Vtune Amplifier XE can do this job. But unfortunately I get to know that when Amplxe only analyze MIC's performance while I analyse an offload application.

So I come to get help from the forum. Is there anyone who can help me? 

Failed to build kernel module on Ubuntu 15.10

Everything was working fine on 15.04 ubuntu but when I ugpraded to 15.10 vtune is broken. It won't do a simple analysis (says that 0 samples were collected)

 uname -a

Linux danielrh-desktop 4.2.0-16-generic #19-Ubuntu SMP Thu Oct 8 15:35:06 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

root@danielrh-desktop:/opt/intel/vtune_amplifier_xe/sepdk/src# lsb_release -a

No LSB modules are available.

Distributor ID:        Ubuntu

"Source/Assembly Code is not available" while doing a General Exploration


I am trying to open and view the results of general exploration analysis using VTune Amplifier 2015 for Systems, Update 3 (build 407750) on Windows 7 Enterprise 64-bit Service Pack 1. I had collected the data by running my application on a Linux machine, kernel version 3.13.0-57-generic. I had compiled my application with the debug information (-g flag). This was the command I had used to collect the data :

Does Intel VTune Amplifier 2016 for Systems support arm 64bit android system?

When using for android system (64bit system arm cpu) , error occured : 

C:\Program Files (x86)\IntelSWTools\VTune Amplifier 2016 for Systems\bin64>amplxe-cl -collect hotspots -target-system=android:VSEYVKW86SU8DAQK
amplxe: Using target: android:VSEYVKW86SU8DAQK
amplxe: Error: /data/local/tmp/[24]: /data/local/tmp/ not executable: magic 7F45
amplxe: Error: Amplifier cannot detect Android device configuration.

vtss.sys blue screens after approximately a week of uptime

What it says in the topic. This appears to be essentially 100% reproducible, but it took me a while to figure out what's going on. It does not occur when the VTSS service is stopped (e.g. "net stop vtss"). 

I don't have a recent minidump (that last crash didn't produce one for some reason). Running WinDbg "!analyze -v" on an older minidump reports an "EXCEPTION_CODE: (NTSTATUS) 0xc0000094 - {EXCEPTION}  Integer division by zero" in vtss.sys.

Crashes with version 2016 update1

Since installing Intel VTune Amplifier XE 2016 update1, I crash regularly when running the tool from within Visual Studio 2013.  I am running on WIndows 10.  I start the profiler, let it run for a while, and then stop it (doesn't matter whether I press the "stop" button or exit the program normally).  The event viewer logs have:

Cache Miss Ratio for L1,L2,L3. Please Help?


I need help to find the miss rate equation using the attached events. I found many equations but I don't know which one is correct. Also in some equations I didn't find the events in my results. 

So please whats the equations that I used to find the miss rate using the events in my attached results.

My Processor is E5-2640. Operating System: Microsoft Windows 7.

See the attached images for the results.



Intel® VTune™ Amplifier XE abonnieren