Intel® Tools for UPnP* Technology (Archived)

Crash in ILibWebClient.c (linux)

Greetings,
First, thanks for the latest release. Just to make
sure I'm up-to-date, I'm running 10.2777 build "24761". If there is a newer build. Please let me know.

I've been using a 1.0.2777.24761 for about a month and
you've done a great job on stability (I run in linux and as a control point/DMR) . Occasionally, I seen a crash in ILibWebClient.c, line 1703 and was wondering if you have
any ideas.

The parent is null (see stack and info below). I suspect that

error LNK2001: unresolved external symbol

Dear Sir/Madam,

I have installed UPnP tools and then I created a simple controling device with one service which names Export control
point project on the windows environment. When I compiled this project by
visual studio 6.00 then I faced with so many errors and most of them were
incompatibility of names in source file and headers. I have solved them and now the
only errors that remain are in UPnPMicrostack and they are:

UPnPMicroStack.obj : error LNK2001: unresolved external
symbol _UPnPSampleService1_SampleAction

c# - getloadlevelstatus - getstatevariable

hello

maybe i'm missing something but i tried and tried and can't get it to work, so maybe someone can help me

when i'm using the upnp-tools "device spy" and "network light" i can perfectly switch on/off the light or get/set the loadlevelstatus of the dimmingservice

the problem is the following: when i'm using the upnp-c#-sdk, i can also switch on/off the light or set the loadlevel BUT i can't get the current state or loadlevel (not with the method and also not with GetStateVariable) - no matter what i try, i always get null as a result

TRANSITIONING Problem

Hi,


I have got a problem with writing/executing a UPNP mediaserver written in C#. I use the class Intel.UPNP.AV.MediaServer.DV.MediaServerDevice, add a DvMediaContainer and a MusicTrack to the server's resources. The file is a mp3 audio file on the server's harddisk.

When I open the AV Media Controller-Tool it instantly finds my server with the container and the file. Then I start the AV Media Renderer WM9 and send the file to it.

Discpvery of devices

We installed 2 device stacks and ran them on 2 differnet systems. But the device spy tool running on 1 system wouldnt detect the upnp device on the other system.


Both the systems are on the same subnet. What exactly is the reason for this kind of behaviour. Is there something we are missing and can someone please suggest us.


Thanks in advance


Project team upnp


how to make the generated code and interface to work on a single thread

hi,


iam new to this upnp technology and i was given a proj named "content distribution in a home network using upnp"........ i have generated a code using launch code wizard which is a tool of upnp. now we r building a interface between application and generated code. can anyone explain me how to invoke various actions and whats the code needed to be written in call back function of browse action r search action ......and how to make this interface and generated code as a single thread...........

problem in invoking browse action of upnp

hi,
i have a problem in invoking browse action in a code generated by
LAUNCH CODE WIZARD which is a intel tool of upnp. the command to invoke
browse
is

void MediaServerCP_Invoke_ContentDirectory_Browse(struct UPnPService
*service,void (*CallbackPtr)(struct UPnPService *sender,int
ErrorCode,void *user,char* Result,unsigned int NumberReturned,unsigned
int TotalMatches,unsigned int UpdateID), void* user, char* ObjectID,
char* BrowseFlag, char* Filter, unsigned int StartingIndex, unsigned
int

Intel® Tools for UPnP* Technology (Archived) abonnieren