Can't see my icon after encapsulation

Can't see my icon after encapsulation

Hi everybody, I tried to develop my first app in HTML with the encapsulator, all was fine except one thing. I put correctly my icon.png file in the root folder but my encapsulated app doesn't have the icon when I install it. In the app there is the correct icon, but in the window shortcut no, there isn't any icon. I tried with many kind of png, but noone is working (8bit, 24bit, 32bit and also a png from here I also tried with different size (100x100, 128x128, 400x400, 32x32, 24x24) but no result.. everytime in the window app was ok but in the shortcut no.. Last change, I tried with an ico file.. but still the same problem.. Any ideas??? Thank u, Enrico
6 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.


Although your icon looks valid you may want to try using another tool like IcoFx to generate the icon to rule out the format.

Unfortunately I also tried different programs.. but nothing change.. that file wasn't mine, was a file that another user used in the encapsulator correctly.
But in my case the problem persist.. like the encapsulator forget to assign the Icon to the Shortcut, because inside the app the icon is present correctly.
Anything else?

Hi Enrico - I'm one of the developers working encapsulator. John gave me a heads up about your problem. I'll check out your icon.png file and try to figure out what is going on here.

I apologize for the frustration in getting your app built.

I'll reply here again once I have done a little debugging...


Hi Enrico - I tried your icon file on my side ..and that appears to be the icon file that we even sent you through email (one of our tech support staff or validation folks?). I was the one who originally made that icon.

Anyhow.. I used that exact icon.png in a test app and the icon appear on the desktop, menu and in the upper left corner of the app.

I'm on windows 7, 64bit - can you remind me the exact OS and version you're testing on?

make sure your files are not in subfolders ..

Leave a Comment

Please sign in to add a comment. Not a member? Join today