Environment not set correctly for non-Intel(R) Composer XE products in compiler command prompts

Reference Number: DPD200519258 

Version: 2015 (Compiler 15.0)

Product: Intel® Composer XE (affects Intel® VTune™ Amplifier XE, Intel® Inspector XE, and Intel® Advisor XE)

Operating System: Windows*

Problem Description: When using the 15.0 compiler command prompts from the Start Menu (under Start->Intel Parallel Studio XE 2015->Command Prompt->Parallel Studio XE with Intel Compiler XE v15.0 Pre-Release (Beta)), the environment set in these shells will point to the version 2013 paths for Intel® VTune™ Amplifier XE, Intel® Inspector XE, and Intel® Advisor XE, not the version 2015 paths. This may result in either commands/files not being found (if a version 2013 is not installed) or an older version being referenced instead of the 2015 version. Any files/commands with Intel Composer XE will be the correct 2015 versions. This problem does not affect users of Intel Composer XE only.

Workaround: If you need to use Intel® VTune™ Amplifier XE 2015, Intel® Inspector XE 2015, or Intel® Advisor XE 2015 at the command line, use the command prompt for non-compilation provided in the start menu, or call the appropriate product's setup script directly.

Screenshot of Intel Software Tools 2015 beta start menu.

Resolution Status: The problem is currently under investigation.

For more complete information about compiler optimizations, see our Optimization Notice.