error: expected a ";" icc 10.1 failure on Mac OS X 10.5.x with iPhone support

 

Introduction :
With the latest Mac OS* X 10.5.x and Xcode 3.1.x, support for the iPhone was added.  This causes a compilation error with Intel compiler version 10.1.  Below is an example of the error.
/System/Library/Frameworks/CoreServices.framework/Frameworks/CFNetwork.framework/Headers/CFNetworkErrors.h(53): error: expected a ";"

CFN_EXPORT const CFStringRef kCFErrorDomainCFNetwork __OSX_AVAILABLE_STARTING(__MAC_10_5,__IPHONE_1_2);


Version : Intel® Compiler version 10.1.x , Xcode* 3.1.x, Mac OS X 10.5.x


Resolution:   This issue will be fixed in the next version of the Intel Compiler version 11.0.  For version 10.1, the work around is to use the latest version 10.1.017, and pass the option -mmacosx-version-min=10.5 to the command line option.
For more complete information about compiler optimizations, see our Optimization Notice.