Intel® Code Builder for OpenCL™ API

Intel® Code Builder for OpenCL™ API 2014 R3 for Linux*
With support for Intel® Xeon Phi™ coprocessors
                                                                  Download

Intel® Code Builder for OpenCL™ API 2015 for Red Hat* and SLES* (64-bit)
With support for Intel® Core™ and Intel® Xeon® processors
                                               Download

Intel® Code Builder for OpenCL™ API 2015 for Ubuntu* (64-bit)
With support for Intel® Core™ and Intel® Xeon®
                                                                 Download

By downloading these packages, you accept the End User License Agreement.

You might also find useful:

What is the Intel® Code Builder for OpenCL™ API?

Intel® Code Builder for OpenCL API provides development environment for OpenCL API on Intel® Xeon® Processors and Intel® Xeon Phi™ coprocessors for Linux* OS.

See more information in the product release and installation notes.

How to install?

Before you download the Intel® Code Builder for OpenCL™ API, read the installation notes part of the release notes.

Verify that you have the corresponding OpenCL runtime. You should directly download the runtime from the OpenCL runtime page.

To install both the Code Builder and the OpenCL runtime packages for Linux*, use the following public key: Intel-E901-172E-EF96-900F-B8E1-4184-D7BE-0E73-F789-186F.pub

For Intel® Xeon Phi™ coprocessor support, you must install the OpenCL runtime 14.2 here, and the Intel® Manycore Platform Software Stack (Intel® MPSS) 3.3 here. For more information, refer to the OpenCL™ Runtime - release notes.

Need support for other operation systems and platforms?

OpenCL support at Intel is now integrated into various development tools under the new name of OpenCL™ Code Builder:

Tailored to your development environment.

For more information refer to the products list at: https://software.intel.com/en-us/intel-opencl

For the full list of development tools and features, refer to the OpenCL™ Code Builder User Manual

Which Code Builder version and runtime to use?

Use the table below to choose the code builder version and runtimes that best fit your need.

 

Target devices

Host OSs

Target Drivers

Intel® Code Builder for OpenCL™ API 2014 R3 for Linux

  • Intel® Xeon Phi® coprocessors
  • Intel® Xeon® processors
  • Red Hat Enterprise Linux*
  • SUSE Linux Enterprise Server*
  • OpenCL runtime 14.2 (CPU+Intel Xeon Phi)

Intel® Code Builder for OpenCL™ API 2015 for Linux

  • Intel® Xeon® processors
  • Intel® Core™ processors
  • Red Hat Enterprise Linux*
  • SUSE Linux Enterprise Server*
  • Ubuntu*
  • OpenCL runtime 15.1 (CPU only)

For Windows* OS OpenCL development for Intel® Xeon Phi™ you can directly use the Intel® Xeon Phi™ windows driver from here.

For more complete information about compiler optimizations, see our Optimization Notice.