Intel® Compilers - Supported compiler versions

The following compiler versions are supported:

  • Intel® C++ and [Visual] Fortran Compiler 17.0 (Intel® Parallel Studio XE 2017)
  • Intel® C++ and [Visual] Fortran Compiler 16.0 (Intel® Parallel Studio XE 2016)
  • Intel® C++ and [Visual] Fortran Compiler XE 15.0 (Intel® Parallel Studio XE 2015)

The general policy is that the current version and two previous major versions are supported.

Interactive support via Online Service Center is provided for these compiler releases with Commercial or Academic licenses. Older compiler versions are not supported. Typically, bug fixes are provided for the latest version only, unless an explicit support contract for older versions exists. Users of all versions and license types are welcome to post questions in our User Forum.

Unsupported Product Compiler and Library Versions are available for download for a limited time. 

If you have any questions about this policy, file a request at Online Service Center.

For more complete information about compiler optimizations, see our Optimization Notice.