Intel® Data Analytics Acceleration Library 2016 System Requirements

Please see the following links to the online resources and documents for the latest information regarding Intel DAAL:

System Requirements

The Intel® DAAL supports the IA-32 and Intel® 64 architectures. For a complete explanation of these architecture names please read the following article:
Intel Architecture Platform Terminology for Development Tools.

The lists below pertain only to the system requirements necessary to support application development with Intel® DAAL. Please review your compiler (gcc*, Microsoft Visual Studio* or Intel® Compiler Pro) hardware and software system requirements, in the documentation provided with that product to determine the minimum development system requirements necessary to support your compiler product.

Supported Operating Systems

  • Windows 8* (IA-32/Intel® 64)
  • Windows 8.1* (IA-32/Intel® 64)
  • Windows 7* (IA-32/Intel® 64) - Note: SP1 is required for use of Intel® AVX instructions
  • Windows Server* 2008 R2 SP1 and SP2 (IA-32/Intel® 64)
  • Windows HPC Server 2008 R2 (IA-32/Intel® 64)
  • Windows Server* 2012 (IA-32/Intel® 64)
  • Red Hat* Enterprise Linux* 6 (IA-32 / Intel® 64)
  • Red Hat* Enterprise Linux* 7 (IA-32 / Intel® 64)
  • Red Hat Fedora* core 20 (IA-32 / Intel® 64)
  • Red Hat Fedora* core 21 (IA-32 / Intel® 64)
  • SUSE Linux Enterprise Server* 11
  • SUSE Linux Enterprise Server* 12
  • Debian* GNU/Linux 6 (IA-32 / Intel® 64)
  • Debian* GNU/Linux 7 (IA-32 / Intel® 64)
  • Ubuntu* 12.04 (Intel® 64)
  • Ubuntu* 13.04 (IA-32 / Intel® 64)
  • Ubuntu* 14.04 LTS (IA-32/Intel® 64
  • Ubuntu* 15.04 (IA-32 / Intel® 64)
  • OS X* 10.10 (Xcode 6.0)

Note: Intel® DAAL is expected to work on many more Linux distributions as well. Let us know if you have trouble with the distribution you use.

Supported C/C++* compilers for Windows* OS:

  • Intel® C++ Compiler 15.0 for Windows* OS
  • Intel® C++ Compiler 16.0 for Windows* OS
  • Microsoft Visual Studio* 2012 - help file and environment integration
  • Microsoft Visual Studio* 2013 - help file and environment integration

Supported C/C++* compilers for Linux* OS:

  • Intel® C++ Compiler 15.0 for Linux* OS
  • Intel® C++ Compiler 16.0 for Linux* OS
  • GNU Compiler Collection 4.9 and later

Supported Java* compilers:

  • Java* SE 7 from Sun Microsystems, Inc.
  • Java* SE 8 from Sun Microsystems, Inc.

MPI implementations that Intel® DAAL for Windows* OS has been validated against:

MPI implementations that Intel® DAAL for Linux* OS has been validated against:

SQL

  • MySQL 5.0-5.7
  • MySQL 4.0-4.1

Hadoop* implementations that Intel® DAAL has been validated against:

  • Hadoop* 2.6.0

Note: Intel® DAAL is expected to work on many more Hadoop* distributions as well. Let us know if you have trouble with the distribution you use.

Spark* implementations that Intel® DAAL has been validated against:

  • Spark* 1.2

Note: Intel® DAAL is expected to work on many more Spark* distributions as well. Let us know if you have trouble with the distribution you use.

Deprecation Notices:

  • Red Hat* Enterprise Linux* 5 is deprecated
    • Support for Red Hat* Enterprise Linux* 5 has been deprecated and will be removed in a future release.
  • Visual Studio* 2010 is deprecated
    • Support for Visual Studio* 2010 has been deprecated and will be removed in a future release.
For more complete information about compiler optimizations, see our Optimization Notice.