Known Issues

Intel® MKL 11.3.3 patch

There are two listed below limitations with Intel® Math Kernel Library (Intel® MKL) 11.3 Update 3 which were discovered recently. The official fix of these issues will be available the nearest update Intel MKL 11.3.4.

If you require an immediate Intel MKL update to address these issues, please submit a ticket at Intel Premier Support (https://premier.intel.com) for the Intel MKL product.

Known Limitations: 

  • FreeBSD*
  • Linux*
  • Microsoft Windows* (XP, Vista, 7)
  • Microsoft Windows* 10
  • Microsoft Windows* 8.x
  • Unix*
  • Fortran
  • Advanced
  • Beginner
  • Intermediate
  • Intel® Math Kernel Library
  • Intel® Advanced Vector Extensions
  • sgemm
  • DGEMM
  • Intel® AVX2
  • MKL PARDISO
  • Баги и фичи

    Уважаемые читатели и авторы русскоязычных блогов Сообщества Разработчиков Intel, с сентября 2012 года блоги работают на новой площадке - Intel Developer Zone (IDZ), используют новый "движок", дают новые возможности, и, к сожалению,.... новые баги. Так, в течение нескольких недель вместо русскоязычных блогов на соответствующей странице IDZ отображались блоги на английском языке, а RSS-подписчикам однажды даже довелось получить посты на китайском языке. Существуют проблемы и с отображением блогов и с их созданием. Хотя их число постепенно и неуклонно уменьшается, но пока оно больше нуля.

    Intel® MPI Library 2017 Known Issue: MPI_Bcast Hang on Large User-Defined Datatypes

    Symptom:

    On certain platforms (KNL and BDW), using MPI_Bcast on a user-defined datatype larger than 16 KB will cause the Intel® MPI Library 2017 to hang.  This has been seen in Qbox and miniDFT in Quantum Espresso, as well as in the Intel® Math Kernel Library ?gebr2d class of subroutines.

    Workaround:

    Changing the default algorithm for large messages for the impacted platforms will avoid the hang.  Set the following environment variable:

  • Linux*
  • Microsoft Windows* (XP, Vista, 7)
  • Microsoft Windows* 10
  • Microsoft Windows* 8.x
  • C/C++
  • Fortran
  • Intel® MPI Library
  • Message Passing Interface (MPI)
  • Cluster Computing
  • ipo: warning #11021: unresolved symbols referenced a dynamic library

    Reference number: DPD200411050

    Product versions:
        Intel® Parallel Studio XE 2015

    OS affected:
        Linux*

    Problem description:

    During the final linkage stage of an application built with option "-ipo" there may be warning messages like:

  • Professional
  • Professors
  • Students
  • Linux*
  • C/C++
  • Fortran
  • Advanced
  • Beginner
  • Intermediate
  • Intel® Parallel Studio XE
  • Intel® Parallel Studio XE Composer Edition
  • Intel compiler tools
  • Cloud Computing
  • Data Center
  • Development Tools
  • Enterprise
  • Intel® Distribution for Python* Known Issues

    Intel® Distribution for Python* can become unstable and potentially crash because of the following:

    Installing in OS X*:

    • When trying to install, the message “intelpythonXX-2017.0.007.app is damage and can’t be opened” will be displayed.
      Solution: Execute the following command and run the application again:
      xattr –rc <path_to_intelpythonXX-2017.0.0.07.app>

    Conda package manager for Linux 2.7.11:

  • Python*
  • Intel® Parallel Studio XE
  • What's New in the 2016 R2 Intel RealSense SDK?

    The second release in 2016 (2016R2) of the Intel® RealSense™ SDK (for Windows) is v10.0.26.0396.  
    The minimum versions of the  Intel® RealSense™ camera DCMs have been raised for R200  to 2.1.24.9476 and for SR300 to 3.1.25.1077 with F200 requiring 1.4.27.41944 or later.
    The supported version of Unity has been raised to 5.2.3.p3 or later (previously v4.1). Note: Unity 5 requires 64 bit libraries.

    Intel RealSense SDK Changes for User Facing Cameras

    Below  please find a high level list of changes between releases of the Intel® RealSenseTM SDK for the front facing (user facing, short range) Intel® RealSenseTM  cameras F200 and SR300.

    Note: Version numbers and release numbers are unfortunately not the same. This article will refer to the version number which until 2016 is equal to the release number + 2 (so R5 is v7),  and 2016 R1 is version 8.

    Intel® Parallel Studio XE 2016 installer freezes when updating Intel® Cluster Checker 3.0 in some instances

    In the Intel® Parallel Studio XE 2016 Installer for Linux*, when updating to Intel® Parallel Studio XE 2016 Update 2 Cluster Edition through Intel® Software Manager, the online installer may freeze.

    This will happen when the following two conditions are met:

  • Partners
  • Professional
  • Professors
  • Students
  • Linux*
  • C/C++
  • Fortran
  • Intel® Parallel Studio XE Cluster Edition
  • Intel® Cluster Checker
  • Cluster Computing
  • Known Issue with CSH Environment Variable Scripts

    In Intel® Parallel Studio XE 2016 Updates 1 and 2 for Linux*, there is an issue with the cshell environment variable scripts.  The mpsvars.sh environment variable script contains a mistake which can cause errors.  In order to avoid this, the psxevars.csh script does not call the itacvars.csh script.  If you wish to enable the itacvars.csh script to be called from psxevars.csh script, please make the following modifications:

  • Linux*
  • Intel® Parallel Studio XE
  • Subscribe to Known Issues