Enabling Wireless Display (WiDi) on Windows 8 RTM

Hi everyone,

Windows 8 has just launched, so Intel just released the new WiDi software v3.5.40.0 to support Windows 8. Therefore, in order to enable WiDi officially on your Windows 8 device, follow the steps below:

1. Download the latest graphics driver for your Intel HD graphics from the following link. As of writing this message, the latest version is 15.28.7.2867 (9.17.10.2867). Choose x86 if you are running a 32-bit version of Windows 8, or x64 if you are running a 64-bit version of Windows 8: http://downloadcenter.intel.com/SearchResult.aspx?lang=eng&ProductFamily...

2. Download the latest Intel Wireless ProSet driver and software for Windows 8 from the following link. As of writing this message, the version is 15.5.6. Choose x86 if you are running a 32-bit version of Windows 8, or x64 if you are running a 64-bit version of Windows 8: http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=21999&lang=eng&wapkw=proset+15.5.6

3. Download the latest Intel WiDi Software v3.5.40.0 from the following link: http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=22016&ProdId=3227&lang=eng&OSVersion=Windows%208%2C%2064-bit*&DownloadType=Software%20Applications

4. After installing the WiDi software, run it and you should find your WiDi adapter. Connect to it, and it will show you a "Device Pairing" screen. Enter the 4-digit security code you see on your TV screen, and press continue.

5. The Windows "Add a device" screen will show up, asking you to "Choose a device or printer to add to this PC". Click on "IntelWiDiAdapter", and click Next.

6. A new Window will show asking you to "Enter the WPS PIN for your television". An 8-digit number may be already showing. Make sure the number is the same as the one you see on your television, and click Next.

7. The Intel WiDi software will take a bit of time the first time it connects to your WiDi adapter, and then will notify you that there is a firmware update. It will say that it wants to update your adapter to firmware v3.5.28.0. Click Update.

8. 7 files will be copied to your WiDi adapter, and your WiDi adapter will soon start updating itself and then restart.

9. After the adapter restarts after updating, and shows that it is ready to accept connections, connect to it again from the Intel WiDi software. The "Device Pairing" screen will show up again. Click continue.

10. The Windows "Add a device" screen will show up again, asking you to "Choose a device or printer to add to this PC". Click on the device that shows the name of your WiDi Adapter (if you haven’t changed this manually before, for NetGear WiDi adapters, this will probably be Living Room-PTV2000).

11. An 8-digit number will show on your television. Enter this number into the "Add a device" Window and click Next.

12. You will get connected to the WiDi adapter, and your computer's screen will be duplicated on the television, but the resolution might change and become lower. If this happens, right click on your desktop, and click on "screen resolution" and change your resolution to one that is appropriate for your television.

Attached in this blog is a video of me going through all these steps on my Ultrabook with an Intel Centrino Advanced-N 6235 card.

By the way, if you still have other computers running windows 7 and an older version of the WiDi software, you will still be able to connect it to the WiDi adapter and enjoy WiDi, even though the adapter was just upgraded to firmware v3.5.28.0

Hope to hear back from you guys about your experiences.

Enjoy WiDi on Windows 8! :)

Rami Radi

For more complete information about compiler optimizations, see our Optimization Notice.

Comments

rradi (Intel)'s picture

For the guys that are getting errors installing the graphics drivers especially on Toshiba and Dell systems: I am honestly not sure, but maybe that is because the Intel graphics driver notices that you are on a system that requires a specific OEM version? This might be true, because i dont see anything higher than 8.15.10.2858 on dell's driver site here http://www.dell.com/support/drivers/us/en/19/Product/xps-15, which is the version you are using. And previously there was always a special version of the WiDi software for Toshiba users (http://www.intel.com/support/wireless/wtech/iwd/sb/CS-031109.htm)

One thought came to mind: Try installing the Intel HD graphics driver as follows: download the zip version of the driver (Win64_15287.zip for example if you have a 64-bit version of Windows 8), extract it to a folder on your system, and install it via the device manager using the "have disk" method.

If this doesnt work, then it looks like you will need to wait till newer Toshiba and Dell versions of the the Intel Graphics driver and WiDi software come out. But i really think this will be soon, because t's in the best interest for these companies to release updates for Windows 8 anyway.

For the guys that didnt have problems installing the drivers, but get errors connecting to the device like "please restart the program or restart the device", can you try resetting your adapter to factory settings, making its firmware is back to version 2.x.x.x. Turn off the adapter, turn it upside down to expose the reset button and then using a paper Clip to hold the reset button down and holding the Power button Down simultaneously for about 10sec. The LED on the adapter will start to flash, at that time you can release both the reset and power button and the adapter will revert to the manufacturing version of the FW.

As for the last question on Windows RT devices. No, WiDi is not a feature on these devices. WiDi requires a system with these specifications: http://www.intel.com/support/wireless/wtech/iwd/sb/CS-031059.htm

I hope this helps.

's picture

Thanks for explaining and for your patience. When i reset the adapter, i was able to connect to it, and then did the update, Working fine now! This is from my Samsung S7 tablet.

's picture

Great Documentation! Worked exactly as described on my lenovo! Yet I got the graphics driver error on my dell laptop too. Guess we have to ping and wait for Dell.

's picture

Hey Rami, thanks for your effort. I had a similiar issue with my Dell. The default Intel WiDi Software Package refused to install (plattform not compatible), the Dell Package worked. There ya go:
https://www.dell.com/support/drivers/us/en/19/DriverDetails/Product/latitude-e6430?driverId=2DH9G&osCode=W864&fileId=3080101557

's picture

I take it back, it is not working. The Dell Release of the WiDi software is just a repacked older version which can be installed but it is not working.

I checked the logfile which is mentioned in the error message while installing the newest intel widi package (shortened):

21:11:56:888,[t:0x24bc] : >>[DDE_Enabled()] [L=6][M=CleanUp][F=pdl.cpp: 851]
21:11:56:888,[t:0x24bc] : DDE_Enabled - Loaded igddexx.dll [L=6][M=CleanUp][F=pdl.cpp: 876]
21:11:56:888,[t:0x24bc] : InitDDECommunications with DDE interface version 3 [L=6][M=CleanUp][F=pdl.cpp: 979]
21:11:56:889,[t:0x24bc] : DDE_Enabled - InitDDECommunication (using DDE version 3) failed with hr=0x80004005 [L=6][M=CleanUp][F=pdl.cpp: 982]
21:11:56:889,[t:0x24bc] : InitDDECommunications with DDE interface version 2 [L=6][M=CleanUp][F=pdl.cpp: 979]
21:11:56:889,[t:0x24bc] : DDE_Enabled - InitDDECommunication (using DDE version 2) failed with hr=0x80004005 [L=6][M=CleanUp][F=pdl.cpp: 982]
21:11:56:889,[t:0x24bc] : InitDDECommunications with DDE interface version 1 [L=6][M=CleanUp][F=pdl.cpp: 979]
21:11:56:889,[t:0x24bc] : DDE_Enabled - InitDDECommunication (using DDE version 1) failed with hr=0x80004005 [L=6][M=CleanUp][F=pdl.cpp: 982]
21:11:56:889,[t:0x24bc] : <<[DDE_Enabled()] [L=6][M=CleanUp][F=pdl.cpp: 851]
21:11:56:889,[t:0x24bc] : CLASS_TYPE_VIDEOCONTROLLER_EXT_DDE: *** WiDi COMPATABLE [L=6][M=CleanUp][F=pdl.cpp: 507]
21:11:56:889,[t:0x24bc] : CLASS_TYPE_VIDEOCONTROLLER_EXT: DDE_CAPABLE_GFX_DRIVER: FAIL [L=6][M=CleanUp][F=pdl.cpp: 531]
...
21:11:56:918,[t:0x24bc] : WiDi COMPATABLE: 1 - Processor [L=6][M=CleanUp][F=pdl.cpp: 712]
21:11:56:918,[t:0x24bc] : WiDi COMPATABLE: 1 - VideoController [L=6][M=CleanUp][F=pdl.cpp: 713]
21:11:56:918,[t:0x24bc] : WiDi COMPATABLE: 0 - GFX Compatable [L=6][M=CleanUp][F=pdl.cpp: 714]
21:11:56:918,[t:0x24bc] : WiDi COMPATABLE: 1 - WirelessNIC [L=6][M=CleanUp][F=pdl.cpp: 715]
21:11:56:918,[t:0x24bc] : WiDi COMPATABLE: 1 - WirelessDriver [L=6][M=CleanUp][F=pdl.cpp: 716]
21:11:56:918,[t:0x24bc] : WiDi COMPATABLE: 1 - OS [L=6][M=CleanUp][F=pdl.cpp: 717]
...
21:11:56:919,[t:0x24bc] : WiDi Supported ==== 0 [L=6][M=CleanUp][F=pdl.cpp: 781]
...

's picture

I also am getting the WiDiApp has stopped working" message and program failure after following your instructions to the letter. I am using a Samsung Slate 7 with windows 8 pro on it. Has this been successfully run on a Samsung slate series 7?

's picture

Thank you for your efforts and documentation! i confirm this exact process worked on my Samsung S7 tablet from //Build conference last year after changing the original Option card with a Intel Advanced-N 6235 card. Thanks!!

's picture

When I started to install windows 8 it said I would have to uninstall Intel wireless display that it wasn't compatible with windows 8. With your procedure do I uninstall WIDI, install Windows 8 and the install the WIDI drivers and software? Or do I install the Windows 8 WIDI drivers etc and then uninstall WIDI. Thanks for your help.

's picture

For those with the Samsung 7, if you are getting the WiDiApp has stopped working - it appears to be related to the fact that the ProSet Drivers listed above (15.5.6) do not include a driver for the 6230 adapter and it fails with the inbox driver from Microsoft. I tried to use some of the other adapters listed in the .inf file from 15.5.6, but they appeared to work until I got the the point of connecting - then I would get the message that "This device is not compatible with WiDi on Windows 8". After some trial and error, I used the newly released ProSet drivers for Windows 8 (15.3.50) and was able to get them to work with the new Widi 3.5.40 software listed above.

15.3.50 - http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=22005&lang=eng&OSVersion=Windows%208%2C%2064-bit*&DownloadType=%0A%09%09%09%09%09%09%09Software%20Applications%0A%09%09%09%09%09%09

Oddly enough in the release notes for 15.5.6, it states the 6230 is not supported under Windows 8. I'm scratching my head on this one, since Intel released a supported version on the same day in another package? Any thoughts on this rradi?

's picture

I've been experiencing nothing but problems since upgrading to Windows 8.

I upgraded to windows 8 partly on the advice in this column.

Here is a post I;ve made over on the Intel forums detailing my experience thus far, can anyone suggest anything?
http://communities.intel.com/message/170648#170648

Anonymous - What is the method of getting it to work with the ProSet Drivers you listed?

Uninstall everything, and re-start the installation process in the same order using 15.3.50 instead of the 15.5.6?

Pages