How we can get the "Hello World GTK C Autotools Project" template?

How we can get the "Hello World GTK C Autotools Project" template?

GreetingsHow we can get the "Hello World GTK C Autotools Project" template? to use it with the eclipse plugin like the video training "Developing_applications_on_Yocto" demostrates.
And I was wondering if there is something like "QT4 template"? for using QT4
Best regards,

11 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

I'm sorry there is no qt4 template support in Yocto Eclipse plugin. You may use the poky build system itself o build the qt4 application. See for how to create a "helloworld qt4 application" recipe.

As for the Hello World GTK template, you can create the project directly in eclipse IDE by "File->New Project-> C Project->Yocto Project ADT Project->Hello World GTK C Autotools Project".

Thanks, I was using a c++ project.

Hi, I have some questions regarding executing applications in the QEMU through the eclipse plugin:1.- Can I execute my application using the "Hello World C++ Autotools Project" template and adding the libraries of QT4 and OpenCV? or I have to create a recipe for my application and build all the image again?. If it is not possible, there is an easy way to execute you application in the QEMU without building all the image again? becuase it's time consuming.2.- Is it possible to connect a web camera in the QEMU?Best Regards,

>2.- Is it possible to connect a web camera in the QEMU?
Not sure. Nobody in the yocto community tried it as far as I know.
But looks qemu itself has the support to webcam according to my quick googling that.

I couldn't say that you can't use the"Hello World C++ Autotools Project" template as a start point to adding the libraries of QT4. I'm sorry that I don't have such information about this, but my first thought is that you have to do is to tweak the autotools and to make sure it can generate the correct Mafefile for your application to make sure it can find the correct qt directory and the necessary qt libraries can be linked against.
If you really don't want to build the image, you may compile your own qt4 aplicaitons using bitbake and directly copy your application binaries/libraries into the qemu, as long as you're sure that all the needed qt libraries are already in the qemu. i.e. If you have created your qt4 recipe named, please "bitbake foo" and you could find your built-result at ${WORKDIR}.

When I tried to reconfigure the project I got the following problems:Description Resource Path Location TypeMissing PROG dlltool gtk -1 Configure ProblemMissing PROG i586-poky-linux-dlltool gtk -1 Configure ProblemMissing PROG i586-poky-linux-mt gtk -1 Configure ProblemCheers,

Have you changed the

Could you post the configure log file config.log?

No, I haven't changed that file but when I opened the file I found the following error:*The second argument of AC_INIT must be a version numberThis is theconfigure log file config.log:,

1. How did you get those cross tool chain installed? (using meta-toolchain tarball or ADT installer?) Which version did you use?2. Could you try run configure in a command line terminal? Using the following command:source /opt/poky/1.2/environment-setup-i586-pok-linuxCFLAGS='-m32 -march=i586 --sysroot=/home/andrestoga/qemux86-sato' ./configure--with-libtool-sysroot=/home/andrestoga/qemux86-sato --host=i586-poky-linux

Hmm, you just make a new Remote Launch configuration for your project and load it to your board.
Actually QEMU can connect external devices. Try to alt+1, alt+2 , alt+3. However, I know QEMU a little

Leave a Comment

Please sign in to add a comment. Not a member? Join today