display can‘t be displayed

display can‘t be displayed

After connecting the monitor and starting the minnowboard, but the display can't be displayed.

what i use is a usb for keyboard and active adapter cable.

6 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi kong,

    Have you ever tried a direct micro-hdmi to hdmi cable to an hdmi display? I once stuck with a micro micro-hdmi to vga adapter which won't light up the display in most of the time.

Quote:

zhou f. wrote:

sorry,I don't have hdmi display.The most important thing is the other's minnowboard showed normally in the same condition. 

hallo, kong d.Have you ever solved your promble? I have the same trouble with you.

I have the same problem.

On the Minnowboard official website there is a known issue for Minnowboard MAX about HDMI output 

http://wiki.minnowboard.org/MinnowBoard_MAX#Weak_HDMI_signal_causing_som...

BUT they say that the problem is solved on TURBOT.

http://wiki.minnowboard.org/MinnowBoard_Turbot#Weak_HDMI_signal_causing_...

but actually it doesn't work. I also tried POWERED micro-HDMI to VGA adapter, but there's still no signal.

Seems that somebody succeeded using a DVI adapter. I'll have a try.

Yeah, I faced the same problem.
I try to connect the Debug Serial Port to the board, but I find it doesn't work well.

On normal Board, After powering on, it should be 
>>>>SecStartup
>>>>MemoryInit Done
>>>>BdsEntry

However, in our board, it has frozen at "MemoryInit Done".
It means that the output is just:
>>>>SecStartup
>>>>MemoryInit Done
No ">>>>BdsEntry" shows.

I search the keyword at Google, I think maybe it is a UEFI firmware problems.
And maybe the final way to solve it is to refresh the firmware via SPI.
But we don't have the Dediprog SF-100 to refresh it.

The way of connecting serial port is shown at http://elinux.org/Minnowboard:MinnowMax
By searching the keyword "4-Wire Serial Console", you can get the right connection way.
Maybe you can try to connect the serial port to see what happened when booting to the OS.

====================================

我也碰到了同样的问题.
我尝试连接调试用串口到板子来看启动过程中发生了什么, 但是我发现好像并没有成功启动.

在正常的板子上, 上电以后应该是
>>>>SecStartup
>>>>MemoryInit Done
>>>>BdsEntry

可是, 在我们的板子上, 它就在"MemoryInit Done"的时候卡住了.
也就是说输出是这样子的:
>>>>SecStartup
>>>>MemoryInit Done
并没有">>>>BdsEntry"出现.

我在谷歌上查了一下. 感觉上像是UEFI固件的问题.
然后, 可能最后的解决方法是通过SPI重刷固件.
但是我们并没有可以刷固件的Dediprog SF-100设备.

连接调试串口的方法在Wiki上有, 查一下"4-Wire Serial Console"就可以看到.
或许你们可以尝试一下看看串口的启动信息?

Leave a Comment

Please sign in to add a comment. Not a member? Join today