problem with running sample code

problem with running sample code

Hello everyone.

I have installed Intel® Parallel Studio XE for Linux and added path to the ~/.bashrc (/opt/intel/composer_xe_2013/bin). At this point, i can compile given code, and get executable file - run. After starting (./run 4 4 img2.bmp 001template.bmp 002template2.bmp), i got this: 

error while loading shared libraries: cannot open shared object file: No such file or directory. 

Ok, i have solved that by exporting LD_LIBRARY_PATH (export D_LIBRARY_PATH=/opt/intel/composer_xe_2013/lib/intel64:$LD_LIBRARY_PATH).

I hope that at this point, i have managed to set everything properly.

After running executable file run, i get CORE DUMPED error.

Does anyone have similar problem? 

7 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

After the installation of parallel studio, did you do the following command?

source /opt/intel/bin/ intel64

Yes, i have done that. When i run this : ./run 4 4 img.bmp 001template.bmp 002template2.bmp

I get : Segmentation fault (core dumped).

If i change scale and number of thread to 1: 

./run 1 1 img.bmp 001template.bmp 002template2.bmp
i get this:

I didn't change anything in code. Strange :/

It is hard to say without any other information.

Have you try a make clean? Be sure to remove all .obj and executbles and then recompile the program. 

I had a similar problem, and I fixed it by editing the /home/<linux user>/.bashrc and adding the following lines:

export PATH=/opt/intel/bin:/opt/intel/composer_xe_2013_sp1.1.106/pkg_bin/intel64:/usr/include:$PATH
/opt/intel/bin/ intel64
/opt/intel/tbb/bin/ intel64
export LD_LIBRARY_PATH=/opt/intel/Compiler/11.1/073/lib/intel64:/opt/intel/composer_xe_2013_sp1.1.106/debugger/gdb/intel64/py26/lib:/usr/include:$LD_LIBRARY_PATH

I hope it Fix your problem too.

Kind Regards,

Medic, if you're on Ubuntu 64bit and compiling/executing program from terminal (not from Eclipse) try this:

gedit ~/.bashrc

paste at the end of the file these lines:

# set environment vars for Intel Parallel Studio XE
source /opt/intel/bin/ intel64
source /opt/intel/advisor_xe/ > /dev/null
source /opt/intel/inspector_xe/ > /dev/null
source /opt/intel/vtune_amplifier_xe/ > /dev/null
source /opt/intel/mkl/bin/intel64/ > /dev/null

, and restart your computer.

Regards, Dusan.

Medic, today i've experienced same error as yours. It was caused by passing invalid path to the image file (002template.bmp instead of 002template2.bmp). I've not traced on which line program crashed because i've immediatly noticed that invalid path was given to the program.

, regards, Dusan.

Leave a Comment

Please sign in to add a comment. Not a member? Join today