Android 4.3 Intel x86 Image Problem

Android 4.3 Intel x86 Image Problem

I have a problem with the image of the x86 version of Android 4.3. I downloaded the image with Android SDK Manager and created a new virtual device with AVD. I set 18 as a platform and API for Intel x86 CPUs. When I start the device the screen remains black without showing anything ... No error message is displayed on the screen even if the boot image from Windows CMD with the command emulator -avd DEVICENAME! Has anyone encountered the same problem? Any suggestions?. 

9 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi Carlo,

Can you connect with adb to the running emulator? If yes do you get an output from logcat? 

I can't reproduce the error on my system. Did you tried to remove the AVD and add it again?


Hi Alex, i've removed AVD device and re-add it but nothing... Don't work!

In attachment is the log message when i run emulator.exe with -verbose option


Downloadtext/plain log.txt5.22 KB

I've executed AVD with -verbose option for emulator.exe, the command is: emulator -avd x86 -verbose, the output is in attachment!


Downloadtext/plain log.txt5.22 KB


can you try to remove/rename the file "" in the SDK/tools/lib directory? This helps sometimes. 


If you want to do further debugging try the following:

emulator-x86.exe -avd test -show-kernel
emulator-x86.exe -avd test -debug all

Hi Alexander, for the first command the result is:

D:\Sviluppo\Eclipse\android\tools>emulator-x86.exe -avd x86 -show-kernel
emulator: ERROR: Could not load OpenGLES emulation library: Could not load DLL!
emulator: WARNING: Could not initialize OpenglES emulation, using software renderer.
emulator: device fd:576

HAX is working and emulator runs in fast virt mode
serial0 console

For the second command the output is in the attachment!


Downloadtext/plain log.txt13.14 KB

Exactly same problem for me, crash at the very same log file row (after ping ddms.bat).

Unsuccessfully tried the following:

  • remove and download again 4.3 image through avd manager
  • remove and download again 4.3 image manually from intel site
  • re-created several time AVD every time with different settings
  • launched AVD with different settings
  • launched AVD from command line

4.2.2 x86 image works fine with HAXM

My system:

  • ASUS notebook N53SV
  • Windows 7 Home Premium SP1 64-bit
  • CPU i7-2630 6GB RAM
  • Intel HD Graphics 3000


Downloadtext/plain api18-x86-crash.txt14.85 KB

Thanks to today's comment in I finally solved the problem, that actually is an SDK manager bug.

Even if SDK manager shows that last release of Intel HAXM is installed, actually in the system there is always the first that you installed (1.0.0 in my case) instead of last available (1.0.6 in my case).

1. Manually uninstall 1.0.0 in control panel

2. Download HAXM 1.0.6 from Intel and install

Leave a Comment

Please sign in to add a comment. Not a member? Join today