HAXM OS X 10.9 Mavericks

HAXM OS X 10.9 Mavericks

Attempting to run the current version of HAXM on Mavericks causes a kernel panic. Is this a known issue and any idea when you are plannig on releasing a fix? I understand that the GM version of Mavericks has only just been released to devs so this is more a heads up and a request for for info rather than a complaint.

49 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi Sena,

thanks for raising this issue. Can you provide a kernal crash log for this issue?


No problem, there is a StackOverflow question about it but I figured it would be best to notify you directly. I didn;t store my crash details as I have a deadline to hit but the original poster on StackOverflow has pasted their log here.


Downloadtext/plain log.txt10.17 KB

I wanted to ask if there is alrady a fix available?

Same here... kernel panics. Anything we can do to help?


thanks for your replies. We are investigating into this issue at the moment. Please note that OS X 10.9 is not an supported OS version for the actual version of HAXM. I will update this thread as soon as I have new information or a fix/workaround is available.


Having the same issue here, an update will be much appreciated as developing on android without HAX is too slow and i think that a lot of developers will start moving to mavericks pretty soon.



+1, if I had known this was an issue I would not have upgraded. productivity-- :(

I am running into the same issue with Mavericks and the newest version of HAXM. It really make Android development tough without access to this. If you require any crash logs or anything else to expedite a fix please let us know.

I'm bummed that HAXM isn't working on Mavericks yet, but I know you guys are on the case. In case it helps, here is my Console.app output when I tried to start an x86 android simulator.


Downloadtext/plain haxm-crash-log.txt2.6 KB


We identified the root cause of this issue. The Intel HaXM team is testing an update to support newly released OSes (Microsoft Windows* 8.1 and OS X Mavericks*).  Look forword on our upcoming update. 


Thats great Alexander. Looking forward to seeing it.



Thanks, Alex,

Do you have an ETA on the update?

Thanks for listening the community!

The comunity support is very nice!


Hi, can we get an estimate for when the update will be available?



kindly please help with this issue,

can we get an estimated time for the update?

Thank you


I assume we release a fix somewhere between a few days and two weeks. We know that a lot of people are waiting for the fix, so we try to release it as fast as possible.

Thanks for your patience!

Thanks for the upadate Alexander, I'd er on the side of a quick release. Its a show stopper for the current Mac OS X version and considering that the OS update is free the migration rate is much faster than previous OS X updates.


Great news: The hotfix is available for download! Please go to http://software.intel.com/en-us/articles/intel-hardware-accelerated-execution-manager/ . There is a hotfix for Microsoft Windows* 8.1 and one for OS X 10.9. 
Let us know if the hotfix is working for you. 

Thanks all for helping us resolving this issue!

I just tried installing the hotfix for OS X 10.9 and towards the end of the installation the installer seemed to hang and then the macbook pro unexpectedly restarted.  Is there a log I can send you from the install that would help?

Edit - I just PM'ed a log to you

Works fine now, thanks for your team's hard work!

Should HAXM enable support for Open GL on the android emulator?

Or have i misunderstood what HAXM is for?

Thanks again.

Many thanks to you and your team.  This was one of the best online support exchanges I have ever seen.  Truly a model that all tech / dev teams should strive for.

Thanks Alex,

I managed to install it fine and it's working on my 10.9 MacBook Air. The only issue I had was this scary-looking warning message at the end of the installation process.

Thanks for the support. It's great being so closely in touch with those that are fixing problems!

It is working...

Many thanks & BRAVO.

Sorry, it doesn't work like expected.

Positiv: OSX Maverick doesn't freeze anymore

Negativ: I see in my Emulator only the start 'Android' logo. That's it, nothing more. Reboot, emualtor restart ... nothing helps. Emulator doesn't start

Hannes A, can you please provide the system image version? What API level it is?

Wow, thanks for the hard work :D !!!


I had the same issue that you're seeing. What fixed it for me was a reinstallation of OS X. I'm guessing there was some incompatability between the two "GM" releases of Mavericks: http://en.wikipedia.org/wiki/OS_X_Mavericks#Releases After upgrading from 13A598 to 13A603, it's now working as expected for me.

Might be worth a try if you're on the older build.

Hi, if you prefer, you can to install a virtual machine and run linux or windows OS to install the software that you required.


@JudLup: I think you don't get the point here - it's not about installing a software onto Windows or Linux VM; we're talking about using HAXM on OSX to use the Intel chipset to RUN e.g. Android emu...

That's an entirely different thing...

BTW: Using 13A603 everything runs fine with the HASM-hotfix.

Thanks Intel-Team!!

@Andy F , excuse me, only i did give you my opinion....


@JudLup: don't get me wrong, but your comment isn't anywhere near the problem. So if you want to offer an 'opinion' (or better: a solution), please make sure you understand the problem first.

Thank you @Darren

reinstall OS X is not an option for me. I wait till I receive 13A603 (or a following) via Apple store. In the meantime I make an workaround and use Android 4.2.2 instead of 4.1.2. This works for me


I can't seem to find the hotfix at all - I have seen links to an extra-intel-haxm-macosx-r03_1.zip, which looks like a hotfix (since r03.zip is dated around April 2013), but when I download it - with various browsers - it seems to only ever be a complex HTML file, whether I'm logged in or not.

Can anyone provide me with the actual binary reference?



PS - for the record, should mention that r03.zip is causing my machine to drop to the verbose console and hang... (I have verbose boot on by default).


Are you right clicking on the download link and choosing Save As? That link actually takes you to a license agreement page, where the actual download lives. 

Try just left clicking. I just tried it from the main HAXM page, got to the Mac EULA and download page, and downloaded a valid binary (it's a PKG inside a DMG inside a ZIP, but it worked :-).

Try that, and let me know if you're still having problems downloading HAXM.

In all cases I'm just clicking, not attempting to do a right-click save-as or the like.

The page I'm looking at is:


Which is under the text:

    There are downloads available under the Intel® Hardware Accelerated Execution Manager End-User License Agreement license

on the page:


I used this link because the .zip files linked earlier in that page are all to the r03.zip version, which causes the machine hang in 10.9.

After following that, if I click on either the download or the link:


I end up downloading a 'zip' file which is actually a HTML file, and not the r03_1.zip file that it suggests...

On download, I get:

   $ file extra-intel-haxm-macosx-r03_1.zip
   extra-intel-haxm-macosx-r03_1.zip: HTML document text

Looking inside that I see a "Page not found" message now (after mv-ing it to a .html extension).

So neither the original pages link, or this provide me with a HAXM that works on 10.9.

I have also looked at the page:


And on that page too, which also give me a HAXM that doesn't work on 10.9 for me - you can see there that
people are also complaining of broken links.

Regardless, all I really would like is a direct link to the 'hotfix' for 10.9, or a proper fix if there is one, that
I can use without hanging my machine. Text above seems to suggest that a version exists, but I just can't seem
to locate it.

Thanks :)


Thank you for describing so perfectly the exact quandary I am in.  The release of HAXM at the links you provided is not working for me, on OSX 10.9 (Mavericks).  I am wondering what I am doing wrong, but also curious about the release date of R3 preceding the release of the elusive fixes.

Hoping for some help on this.  Sending a note to the Intel rep on this thread.



Darren K. wrote:

In all cases I'm just clicking, not attempting to do a right-click save-as or the like.

The page I'm looking at is:


Which is under the text:

    There are downloads available under the Intel® Hardware Accelerated Execution Manager End-User License Agreement license

on the page:



To clarify, this page states the fix is HAXM version 1.0.7.  A link is provided to this page for downloading 1.0.7.  However, the download for Mac OS* X at that page is 1.0.6.  This is a wth scenario.

Any help you can provide will be much appreciated.

I'm working with our support team to figure out what's going on with the HAXM downloads here. Sorry for the frustration. I'll post an update soon.

We think the broken link issues have been resolved - let us know if you're still having problems. You should be able to get all of the downloads referenced on this page with no problem. Sorry for the inconvenience.

For Mavericks, the download you want is (mis) labeled "Hotfix for OS X 10.9 Only", at this page:


This is the 1.0.7 version. I'm going to update the descriptions on that page to be more accurate. Again, sorry for the confusion, and thanks for being patient while I get it sorted out. :-)

Please let me know if you're having any more issues.

I've updated all of the HAXM download pages to include the version numbers, so you know whether you're downloading 1.0.6 or 1.0.7. Hope that helps.

The download looks much better now - thanks - have installed the 1.0.7 hotfix now, and will give it a spin later.



Just got accidental kernel panic on haxm(1.0.7). It worked before and after this boot.

Update: Seems crashes on is related to bootcamp, every restart after Windows session, i got this kernel panic


Would you be willing to try uninstalling HAXM as a troubleshooting step? That is, uninstall HAXM, try to recreate the kernel panic by booting into Windows, booting back into OS X, and launching an emulator to see if the kernel panic still happens. Then try reinstalling HAXM and see if you can reproduce the issue.

I've shown the HAXM engineering team this issue, and this was their suggestion. If we can definitively pin this down as a HAXM issue, we can escalate to them and see about getting it resolved. Let me know how it goes, and thanks!

To uninstall Intel HAXM on a Mac, open a terminal window and execute this command:

sudo /System/Library/Extensions/intelhaxm.kext/Contents/Resources/uninstall.sh

You will be prompted for your current user password. Follow the uninstaller prompts to remove Intel HAXM.

Warning: Close all instances of the Android* x86 emulator before removing Intel HAXM. Intel HAXM cannot be removed while in use.

Is this working as expected for everyone with Mavericks and HAXM 1.0.8?  Unfortunately its not for me.  The emulator just sits there not responding.

I can't get the emulator to work at all with x86 images and HAXM... Intel Core2Duo Mac, 8GB Ram, Mavericks, latest Android Studio and APIs, plus HAXM 1.1.1 hotfix: the emulator runs ARM images fine, but x86 images all display "HAX is working and emulator runs in fast virt mode",  and the emulator starts up and freezes on a white screen. I can't find anything useful in the console, and I don't know where to look for HAXM logs.

kextstat | grep intel


  140    0 0xffffff7f826d1000 0x14000    0x14000    com.intel.kext.intelhaxm (1.1.1) <7 5 4 3 1>

I've tried uninstalling HAXM, reinstalling (the 10.9 and above , allowing unsigned kext files, using the official Intel x86 Android Studio Emulator Accelerator (HAXM Installer)... etc. to no avail.

I read in the HAXM 1.1.1 (rev5) release notes : "Intel HAXM can only accelerate Android x86 system images for emulator-x86" whereas the emulator displays "emulator-x86_64" as the title, and this seems to be the only emulator that Android Studio will use. It also says on intel.com that "Intel x86 Android* emulator images will automatically be executed using the "emulator-x86" binary". Could that be the problem? 

Thanks for any help or info,


Leave a Comment

Please sign in to add a comment. Not a member? Join today