Unable to install HAXM

Unable to install HAXM

On my Laptop (Lenovo X1 Carbon), though I have enabled Virtualization in the BIOS, I am unable to install HAXM. I get the error message - This Computer does not support Virtualization Technology (VT-x). Any help/suggestion appreciated.

12 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Can you please tell what operating system are you running?

Also try this if you are running windows from vista up: run a terminal as adminmitrator.

In that terminal type bcdedit /set nx AlwaysOn and reboot the system

Best Reply


I am trying to install on Windows 8.1

I figured out what the issue was. If Hyper-V Platform is installed on the machine, it blocks other apps from using the VT-x feature of the processor. Once I uninstalled Hyper-V, I was able to install HAXM.


Downloadimage/png hyper-v.png17.57 KB

Hi, can you to install a virtual machine for install and run your software, is the easiest solution.

@JudLup: That's what he's doing - but with Hyper-V blocking VT-x the VM won't run...

mmm friend, in your setup Bios, i believe that exist a option to enable and disable this characters on you pc, if you want you can see if this is enable or disable, other option is update your Bios Software.

No - Hyper-V settings are definitely NOT in a PCs BIOS. Each Hyper-V VM has it's own vm-BIOS (which has nothing to do with your hardware's native BIOS).

mmmm friend then I not might help you, i don't know more about this. I wait that you will find help with this theme.

@JudLup Luna, @Andy - Thanks for the suggestions.

As I mentioned, the only option is to disable the Hyper-V which I have already done (Snapshot attached with my post). Just posted the message on this forum so that it might help other looking on this forum.

@Ghanashyam S - Thanks for your post. I had the exact same issue. As you advised, disabling Hyper-V worked for me on Win 8.1 Pro, on my ASUS G750JH ROG laptop

On a side note - I tried stopping and disabling (from services.msc) the only "running" Hyper-V service first, but this did not help. Hyper-V seems to want exclusive control. I had to do exactly as you advised to get it working, and disable Hyper-V using the "Turn Windows Features On or Off" option from within Control Panel.

You are correct - Client Hyper-V has to be disabled in order for HAXM to work. Hyper-V wants exclusive access to the VT-x capability of the hardware, and I haven't seen a configuration that allows them both to work at the same time.

@Ghanashyam S your welcome, and i'm sorry for i don't help you.

Leave a Comment

Please sign in to add a comment. Not a member? Join today