Intel@ Android USB driver support on Linux

Intel@ Android USB driver support on Linux

Dear Intel team and community,

is there a port of the Intel@ Android USB driver

for Linux operating systems?

My intention is to use this driver in combination (among) with the Android SDK tools like “fastboot” and “abd”. By the way, adb works fine - without a specific driver. However, fastboot does not work – specific driver will be needed.

Any kind of feedback will be welcome.

Thanks in advance!

Best regards Tom

14 posts / 0 new

Hi Tom,

there is no need for a fastboot driver under Linux. You might just need to setup some additional udev rules to modify access rights. Can you first check if fastboot works as root or in a sudo environment?

sudo fastboot devices

If this works first unplug your device, use "lsusb" to get the list of attached USB devices and second connect your device in fastboot mode with your host and use lsusb again. You will see one additional device. In my case this looks like:

Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 004: ID 17ef:1003 Lenovo
Bus 002 Device 003: ID 05c6:9204 Qualcomm, Inc.
Bus 002 Device 002: ID 8087:0020
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 016: ID 8087:09ef
Bus 001 Device 005: ID 17ef:480f Lenovo
Bus 001 Device 004: ID 0a5c:217f Broadcom Corp.
Bus 001 Device 003: ID 147e:2016 Upek Biometric Touchchip/Touchstrip Fingerprint Sensor
Bus 001 Device 002: ID 8087:0020
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Where line 6 is the additional device. You see the vendor ID is 8087 and the device ID is 09ef . For you this might be different. 

Next you need to create an udev rule. To do so edit or create the file /etc/udev/rules.d/51-android.rules and add the following content (don't forget to use your Vendor ID and your device/product ID):

SUBSYSTEM=="usb", ATTRS{idVendor}=="8087",ATTRS{idProduct}=="09ef", MODE="0666"

To apply this rule you need to restart udev:

sudo service udev restart

Let me know if that helped!

Hello Alexander,

thank for the fast response.

Sorry but I don't think that my issue has something to do with right permissions.

However, I have already tried several udev rules and also as root/su without success.

Following guide was taken as a reference - -

Please noticed – in bootloader mode my device, a Asus MeMo Pad FHD 10, has the same product ID as yours! Which device did you use?

Can I do something else to solve my issue or enclose the failure root cause?

By the way, my Android SDK environment (adb and fastboot) works with an other Android device without any problem – no Intel device, Sony Xperia P.

Thank in advance!

Best regards


Hi Tom,

I'm out of ideas here. Based on your description I also don't think it's an permission issue. Have you contacted Asus already? 

The device I'm using is an internal one. I will try out on an Asus Fonepad 7 tomorrow and see if I can reproduce and further investigate on your issue.


Hi Tom,

my Asus Fonepad 7 is recognized in  bootloader mode without any issues. Same device IDs. Connected it rebooted in bootloader mode with adb reboot-bootleader and fastboot instantly recognized the device. 

fastboot devices

	Medfield45D61...        fastboot

Sorry, I can't help you further to debug this issue.


Hello Alexander,

thank in advance for your support.

Today I have try my Android SDK envoriment, fastboot and adb, with an other Intel Atom device – it was a Smartphone Motorola Razr i.

Result, boths tools work fine without any limitation.

I have no further ideas to solve my issue!

Any comments will be welcome.

Best regards


This problem exist on Dell venue tablets also, Intel should do the right thing and either correct their fastboot mode or release a Linux fastboot binary that can work with this fastboot.

@Leonel: Thanks, but I have already tried several rules without success.

@T K.: What does it mean? Do you found out a workaround?

Best regards



No there isn't a work around, other than use windows, the problem is clearly on intel's end and they should address it, either fix their devices to work with current Linux fastboot binaries, or release a Linux binary that works with their devices.

Ok, finally compiled a linux fastboot binary that works on my Dell Venue 8, now no need to use windows for fastboot commands, not sure when I can release the binary, due to working and moving, so internet is limited to cell phone, binary needs testing also before release.

@T K.
That sounds good – please keep me up to date!
Let me test your binary!

Best regards

Sure here you go. works on all intel devices, i have tried it on, you need to add user rules for your user if they don't have access to fastboot, root can use no problem.

Had the same issue, noticed that android drivers kernel flag was disabled.

You should recompile your kernel with the following kernel flag to yes :

Enable support for various drivers needed on the Android platform

Symbol: ANDROID [=y]
Type  : boolean

Prompt: Android Drivers

-> Device Drivers
     -> Android    

Leave a Comment

Please sign in to add a comment. Not a member? Join today