Can't install HAXM on WIndows 8.1 Pro

Can't install HAXM on WIndows 8.1 Pro

Hello.

I'm trying to install HAXM on Windows 8.1 Pro and every time I get the message "This computer meets the requirements for HAXM, but Intel Virtualization Technology (VT-x) is not turned on.". I have a ASUS K75JV notebook with Intel Core i7 3610QM processor and 8GB RAM.

I have tried all found solutions and it still won't install:

  • I have the latest BIOS for my notebook
  • VT-x and VT-d are turned on in BIOS
  • I don't have Hyper-V installed on my system
  • I've tried "bcdedit /set nx AlwaysOn" and reboot
  • Tried HAXM 1.0.6 and 1.0.7 (Win 8.1 hotfix)
AttachmentSize
Download haxm_install_log_2.txt287.13 KB
44 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

It seems that DriverPackageInstallW function returned true(success).In one or two previous cases of failed instalation driver installing function returned false.Unfortunately there is still message which says that VT-x is not turned on.

Oh! Hi ;)

I'm going to write in this topic, because I have exactly the same problem... And I also have tried the same solutions as Wojciech ;) What's more after using this command with bcdedit /set nx AlwaysOn I had problems with NVIDIA card I think... Because I couldn't start a game with this card. So I used this command: bcdedit /set nx OptIn and now is everything like before. But I still can't install HAXM...

I have Lenovo Z580 with Intel Core i5-3210M and 8GB RAM and also Windows 8.1 Pro. In attachment I send you my install log.

Attachments: 

AttachmentSize
Download haxm_install_log_3.txt280.51 KB

It looks bcdedit /set nx AlwaysOn does not have any effect on some systems.I think that it could be BIOS dependent issue.

But as I know I have the newest version of BIOS... Any ideas how to resolve this problem?

I think that HAXM developers could shed more light on those issues.

So I see we can't count on your help? Any right solutions? I think its bad because our hardware isn't so old and it should works fine... Eh :(

Let me ask around with the HAXM support team, and see if I can get someone to look at this, and hopefully find you an answer.

I contacted the HAXM support team, and they suggested the following.

Download CrystalCPUID to your system and run it. Check in the bottom right corner of the results screen, and let us know if you see "VT" enabled there, or if it's greyed out, like this:

Let me know what you see there. Thanks!

Thanks for help :)

Below screen of this program to give you/them more info ;)

Quote:

Josh Bancroft (Intel) wrote:

I contacted the HAXM support team, and they suggested the following.

Download CrystalCPUID to your system and run it. Check in the bottom right corner of the results screen, and let us know if you see "VT" enabled there, or if it's greyed out, like this:

Let me know what you see there. Thanks!

Hello.

Thanks for your interest in this subject. Here's my info, the VT and NX are on...

Quote:

Przemysław F. wrote:

So I see we can't count on your help? Any right solutions? I think its bad because our hardware isn't so old and it should works fine... Eh :(

Hi

I wish I could help you to solve this problem.

I wonder if ISDM contains any info about VT technology and how to access it(register mappings etc...)

Thanks to both of you for the CrystalCPUID results. It does appear that VT is enabled on your systems. I've shared them with the HAXM support team, pointing out that you're reporting this issue on Windows 8.1 Pro (and that HAXM has worked previously on this machine under Windows 7), and asking them to look in that direction. I'll let you know what I hear from them (it will probably be next week before we get a response). Thanks for your patience while we get this figured out. 

For reference (and anyone else who might happen across this thread in the future), here's a page with more detailed hardware requirements for HAXM, and some troubleshooting steps for making sure VT and XD are supported and enabled. 

Installation Instructions for Intel® Hardware Accelerated Execution Manager - Microsoft Windows

It may not be directly applicable to the issue you're reporting, but it would be good to check.

In my case I have no idea if HAXM worked on previous versions of Windows... I didn't need to install this then ;)

From the support team:

Check to see if Client Hyper-V is enabled - it's required for HAXM. 

To check, go to Control Panel -> Programs and Features -> Turn Windows features on or off

See this video for a demonstration. Let me know what you find.

It is disabled. But I read something different... That when it is enabled HAXM is not going to install. However if support team says that it should be enabled I will test it and give you an information in the afternoon :)

With Hyper-V installed the HAXM installer doesn't even start...

Attachments: 

AttachmentSize
Download haxm_install_log_4.txt69.92 KB

It is hard to troubleshoot if only relying on log file.

Pls has any progress been made really need this haxm running developing android app with the emulator as it is is unbearable slow

Pls has any progress been made really need this haxm running developing android app with the emulator as it is is unbearable slow

 

still no change from the last post date, it is no 23/02/2014.

is there a way round method or fix as yet?

If you're willing to try an engineering build of the HAXM installer, we could try that. If it doesn't resolve the issue, it will generate log files that will be helpful for the HAXM engineering team to find out what's going on.

Contact me via private message (click "Send Author a Message") and give me an email address that can receive attachments, and I can send you a license agreement and an engineering build to try.

Hey guys.

I cant install HAXM because "This computer doesnt support Intel Virtualization Technology VT-x"

 I have a Intel® Xeon® Processor E3-1230 v2 (8M Cache, 3.30 GHz).

I have enabled Virtualization on the BIOS and have enabled Hyper-V on Windows Programs and Features.

 

What am I missing?

Please help.

Thanks in advance.

Ignacio-

Try disabling Hyper-V. having that enabled will capture the VT capability, and it won't be available to other programs that want to use it (like HAXM). Disable Hyper-V and try the HAXM installer again. Let us know how it goes. Once it's installed, you won't be able to run a HAXM-enabled emulator and Hyper-V at the same time, since they both need exclusive access to VT.

Thanks Josh.

That was it :)

Quote:

Wojciech F. wrote:

Hello.

I'm trying to install HAXM on Windows 8.1 Pro and every time I get the message "This computer meets the requirements for HAXM, but Intel Virtualization Technology (VT-x) is not turned on.". I have a ASUS K75JV notebook with Intel Core i7 3610QM processor and 8GB RAM.

I have tried all found solutions and it still won't install:

  • I have the latest BIOS for my notebook
  • VT-x and VT-d are turned on in BIOS
  • I don't have Hyper-V installed on my system
  • I've tried "bcdedit /set nx AlwaysOn" and reboot
  • Tried HAXM 1.0.6 and 1.0.7 (Win 8.1 hotfix)

Also I agree with this quote from Wojcech F., so same here problem. There solution doesn't fix my problem, so what i should do? 

PS. I putted into here my screenshots and installation log. PC: Notebook Lenovo Y510p with Intel Core i7 4800MQ, 8GB RAM.

Attachments: 

I've the same problem! I'm on Windows 8.1 64bit. I've done the same things as Maciej, but I've still the same problem

  • I have the latest BIOS for my notebook
  • VT-x and VT-d are turned on in BIOS
  • I don't have Hyper-V installed on my system
  • I've tried "bcdedit /set nx AlwaysOn" and reboot
  • Tried HAXM 1.0.6 and 1.0.7 (Win 8.1 hotfix)

Please find here some screen shots and advise how to proceed!

Regards,

Simmaco

 

Attachments: 

AttachmentSize
Download CPUID.png15.75 KB
Download IMG_0884.JPG2.64 MB
Download IMG_0885.JPG2.59 MB
Download HaxLogs.txt188 bytes

Simmaco-

I've sent you a private message regarding something we can try. Please have a look, and we can go from there.

Uh, Now Installer HAXM Hotfix for Windows 8.1 has been done successfully! :) That's why happens after updating system using Windows Update.

Maciej, are you saying that you installed some Windows updates, and how the HAXM installer is able to complete successfully? That's very interesting, if true. Could you let me know for sure that's what happened (and a list of installed updates, if possible, would be great!). Thanks!

Yep, On emulator app is working as much faster than before.

List of installed updates from 2014-03-18 :
KB2913760 - http://support.microsoft.com/kb/2913760/en (I think here is fix )
Other updates: KB2938527, KB2919442, KB2909210, KB2901125, KB2929961

(Other case) Two days ago I installed the software Assessment and Deployment Kit from Microsoft, but it takes so much space around 3GB. I thinked that it can solve problem if something does not work.

Quote:

Josh Bancroft (Intel) wrote:

Simmaco-

I've sent you a private message regarding something we can try. Please have a look, and we can go from there.

 

hi,

i have the same problem as Simmaco F, i have tried 1.0.8 and 1.0.5.

  • I have the latest BIOS for my notebook(Toshiba R30)
  • VT-x is turned on in BIOS
  • I don't have Hyper-V installed on my system
  • I've tried "bcdedit /set nx AlwaysOn" and reboot

Do you have a solution now?

Appreciate it.

 

 

Hi

I had the same problem but found help on another site.
If you have avast antivirus installed this can be the problem.

I uninstalled Avast and rebooted. Then I was able to install HAXM. After the installation of HAXM i reinstalled avast.

 

 

Quote:

Olof P. wrote:

Hi

I had the same problem but found help on another site.
If you have avast antivirus installed this can be the problem.

I uninstalled Avast and rebooted. Then I was able to install HAXM. After the installation of HAXM i reinstalled avast.

 

 

Hi Olof P. you just saved my life!! I've successfully installed it after uninstall Avast. Heaps of thanks!

Hello everyone. I had exactly the same problem. And this is how I could fix it.

Step 1: Turn virtualization on in BIOS settings.

Step 2: Control Panel -> "Programs" -> "Turn Windows features on or off" (under "Programs and Features") and locate "Hyper-V", uncheck, reboot.

Step 3: In Avast->Settings->Troubleshooting. Uncheck "Enable hardware-assisted virtualization" & "Enable avast self-defense module"

Final step and the main: Go to MyPC / right click / Advanced System Settings / Advanced / In Performance click SETTINGS / Data Execution Prevention and enable DEP for all programs and services.

The last step helped me to solve this problem. Hope you too.

Quote:

Olof P. wrote:

Hi

I had the same problem but found help on another site.
If you have avast antivirus installed this can be the problem.

I uninstalled Avast and rebooted. Then I was able to install HAXM. After the installation of HAXM i reinstalled avast.

 

 

Thanks Olof. Avast was the culprit for my situation as well. 

And I couldn't just disable Avast. I had to uninstall it, reboot, and then HAXM installed without a problem...

Same problem.

Windows 8.1 64-bit, completely up to date with Windows Updates.

Not running Avast.

ASUS motherboard.

Intel i5-4590S, 3GHz CPU.

16G RAM.

VT enabled in BIOS.

Crystal CPU shows VT enabled.

C:\Windows\system32>wmic OS Get DataExecutionPrevention_SupportPolicy
DataExecutionPrevention_SupportPolicy
1 (always on)

I get that same error message whether Hyper-V is enabled or disabled (and yes, I reboot when changing it).

When I go to Advanced System Settings / Advanced / Performance / Data Execution Prevention, the options are greyed out. Is that good/bad/neither?

Does anyone from Intel monitor this forum? If so, can Intel help users get virtualization working on our systems? I need this in order to developer for Android.

Hi Jim,

If VT and XD are enabled in BIOS, then check Hyper-V on Windows feature. Did you tried HAXM 1.1.1?

Hi Jim

Open Task Manager and go to performance tab.

In the lower  right corner of the window check the Virtualization  status and post it here please.

 

Attachments: 

AttachmentSize
Download 1.png5.6 KB

I've sent a bunch of screenshots via private message to Intel support (Ionel Mitel).

Couldn't post them here because this forum decided it was spam and blocked me.

There is no Virtualization status in the right corner of Task Manager -> Performance.

Hi JIm

I saw the pictures you send to Ionel and my guess is that VT is not enabled. How did you check if VT is enabled? Did you enter in Bios\Advance Menu\Cpu Configuration and checked that "Intel Virtualization Technology" is enabled? Software like Crystal CPU is no showing the status of the feature, in our case VT. I only shows if the CPU support the feature VT. The only way to see if it is enabled you need to check in bios.

Thank  you very much for the clarification! It turned out that Intel Virtualization Technology was in fact disabled in the BIOS. I could have sworn that I'd enabled it, but alas. I am up and running ow.

Leave a Comment

Please sign in to add a comment. Not a member? Join today