Problem with GPU and Android x86 Emulator

Problem with GPU and Android x86 Emulator



I'm programming with Android and Eclipse but I can not run android emulator with Intel technology, I bring you information:

Elements involved:

Portatíl DELL Inspiron 640m

Intel(R) Core(TM)2 CPU T7200 @ 2.00GHz

Mobile Intel(R) 945 Express Chipset Family

Supports Intel Virtualization and HAXM have installed and supported.



Eclipse en ADT Bundle para Windows

Problem description:

When I run the Android Emulator, I have already installed the Android Manager according iso x86 android api adequate. I always have the same screen Android emulator occurs at a given time changes from black to white and freezes well. Never I access the Android system. Report in creating the AVD under the checkbox "GPU".



Please if someone kind enough to help me or direct me to reach a solution. thanks

16 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

What happens if you start an Android Virtual Device, but don't check the "Use Host GPU" option? Does the emulator launch and work OK?

It could be that your specific graphics chipset doesn't support Host GPU acceleration in the emulator. Let us know what happens if you don't use the Host GPU option.

Thank, Josh Bancroft :)

- What happens if you start an Android Virtual Device, but don't check the "Use Host GPU" option?

Yes, it work.

- Does the emulator launch and work OK?


- It could be that your specific graphics chipset doesn't support Host GPU acceleration in the emulator. Let us know what happens if you don't use the Host GPU option.

No, it not work. no cpu with enabled Host GPU. But:

sc query intelhaxm

You should see a status message including the following information:

SERVICE_NAME: intelhaxm
       STATE              : 4  RUNNING

I think we're talking about two different things here. HAXM is not the same as Host GPU acceleration.

HAXM is hardware based acceleration for the emulator, and runs independently from Host GPU acceleration. You can tell if HAXM hardware acceleration is active when an Android Virtual Device starts up in the emulator, and you see the message "HAX is working and emulator runs in fast virt mode", You can see more about setting up an Android Virtual Device with HAXM in this post:

Graphics Acceleration ("use host GPU") is a feature of the Android SDK, and is not the same thing as HAXM. The Google documentation for the Android SDK (, section title "Configuring Graphics Acceleration") has this to say about Graphics Acceleration:

As you can see, Graphics Acceleration is an experimental feature of the Android SDK, and doesn't work with some types of applications or in conjunction with some other features (like snapshots). 

If you're still having trouble getting host GPU acceleration to work, your best option is probably to check with the official Google Android Developer Tools reference/support site ( and the support community there. if you have any questions or issues getting HAXM working, I'd be happy to help. Good luck!

Thanks again

Please follow if you would be so kind helping me.

All you have told me I've already done properly.

My question is, and chances are you do not know help me. It's like I can know if my GPU acceleration in order to apply the android emulator.

Is there any command in windows console application or Intel application that it can test, as when testing my Intel microprocessor.

I guess that's what I want for what you so kindly told me already knew. Although we sincerely appreciate your attention.


I think I understand what you're asking, but I can't find anything in the Android documentation to determine if GPU Host acceleration will work other than "try it, and see if it works." I know that's not very helpful - if I find anything else that might help you determine whether host GPU acceleration will work on your configuration, I'll share it here.

Thank you, +10

Too bad, lately programming and hardware is only for the rich and it is becoming less accessible than proprietary code or tools are designed to sound economies.

If I can not have proper hardware nor do I schedule I'm afraid I'm going to go hungry and my family, this is my destiny in my country.

I say that to use such an emulator for android I have to wait 1 hour for a Windows Phone emulator can only Windows Phone 7.5 version 8 that is impossible and everything is economics as Microsoft does not remember programmers without resources, well ..., just remember others.

It is you who programais in united states do you not remember a suitable emulator for weak hardware.

GPU host acceleration is a completely optional feature, and shouldn't stop you from using the Android emulator, or the HAXM hardware accelerated driver. Your machine should be able to run HAXM just fine (your earlier posts show that it is, in fact, running on your hardware), which speeds up the emulator and makes it easier to use. Try running the emulator without GPU Host Acceleration, and let me know how it goes. From what you've told me about your development machine, it should be sufficient to develop an app, run the emulator, etc. If there's another problem you're having, please let us know, and we'll do whatever we can to help. Good luck!

None of the Intel x86 Android emulators will run without crashing this is with or without Host GPU being enabled.  The ARM emulators work fine.  I have followed this thread and done the following:

Ensure all options for VT enabled in the BIOS
Installed the latest HAXM release r4
Downloaded/Updated Android SDK ensuring that I have the latest API releases from 15 - 21

My configuration is:
Windows 8.1 Enterprise
64bit OS
x64 Processor
Hyper-V is enabled

Starting any Android Intel (x86) based Emulator with or without Host GPU on fails/crashes upon start when the emulator shows Android image as if it is loading OS.  I have tested this with various options selected and the emulator crashes every time.
This is hindering progression being made on projects.  Please advise.

Best Reply

 You might want to check out this blog:

You need to disable Hyper-V. Let us know if it still does not work.

Hi Gael:

I disabled Hyper-V to install the latest HAXM release but re-enabled it after HAXM was successfully installed.  It should be noted, however,  that prior to these recent errors and crashes in being able to run the Android Intel emulators; I could successfully run the Android Intel Emulators from the AVD manager even though Hyper-V was enabled AND with running Windows Phone emulators (requires Hyper-V) side by side to the Android Intel Emulator without having any crashing issues of the Intel Android Emulator.  This being the case, it would be surprising that in the past couple of weeks that the Hyper-V would be the issue when I have had this configuration (Hyper-V & Android Intel Emulator) running happily for over a year.

I have not done anything major to my environment outside of the updating my IDE. So this would led me to believe that something else is wrong, and it seems pervasive as several persons with my same type of development configuration have been having issues with the Android Intel recently when they have not had issue previously. 

Please advise, if there could be something else going on that I should review.


Hi T.W.-

My name is Josh Bancroft, and I'm the community manager for Android here on the Intel Developer Zone. I'm sorry you're having crashes with the Intel images in the Android SDK. It sounds like you've checked most of the obvious causes, and if you don't mind, I have a couple of questions/things for you to try. I want to try to get a good understanding of this issue, so I can report it to the team that works on HAXM and our system images.

First, can you tell me what happens when you start an Intel image in the emulator when Hyper-V is disabled (in Control Panel in Windows)? I understand that you used to be able to run the emulators with Hyper-V active (though the HAXM accelerator wouldn't have been working - it requires exclusive access to the VT-x hardware, which conflicts with Hyper-V). If disabling Hyper-V stops the crashing, I'm inclined to think it might be a HAXM issue.

Second, can you tell me exactly which version of the x86 system image you're using? You can find this in the Android SDK Manager window. The most current version (last time I looked) is API 19, rev. 4 (for the version with Google APIs) or rev 2 (for the image with no Google APIs). The reason I ask is that there's a known issue with OpenGL is the rev 4 image that causes some crashes and other weird behavior. We have upstreamed the fix to Google, and they're testing now. We're waiting for the updated image to be released - not sure when that will be, but it might help with this problem if your crashes are related to that issue.

Lastly, and this is kind of an obvious one, but make sure you check for updates for the Android ADT components in Eclipse by going to the Help menu, and choosing Check for Updates. It sounds like you might have done this already, but it shouldn't hurt to try again.

Again, I'm sorry you're having these crashes. If you'd be willing to try the suggestions above, and let me know the results, we can go from there, and I'm pretty confident we can find a solution for you. You can reply here, or contact me via private message if you prefer. Thanks for your help! :-)



Gael Hofemeier (Intel) escreveu:

 You might want to check out this blog:

You need to disable Hyper-V. Let us know if it still does not work.

Thank you,

Thank without answering my loving you solved my problem 1 hour wait 6 minutes.
I'll explain the solution:
My problem with Intel GPU support has not been resolved. But if the iso without Intel GPU, it's something.
I have run "CrystalCPUID.exe" and honestly I've fixed my problem.
Say I had a problem of production (intel). Was next, had "Internal Clock = 900" CPU1 and "Internal Clock = 900" CPU2.
I used the Intel Enhanced SpeedStep and fixed tool, I increased "New Multipler" at normal 11x 12x is put my Microprocessor but even should bear does not.
I understand that my processor is always faulty, but did not know it until you need to make this computer programming.


When I disable the Hyper-V Service the emulator still crashes, however, when I turn off the  Hyper-V feature completely the Android emulator comes up with no problem. Does this mean there is an issue with HAXM given turning off the Hyper-V feature completely enables the Android Intel emulator to load?

Also, you are correct that while I was able to run the emulators side by side before with Hyper-V enabled; HAXM was not working and it would note that HAX could not be started when I started the Android x86 emulator.  Please note; Previously this did not hinder my ability to run the Android Intel emulator even though HAXM was not able to start when Hyper-V was on.    

It also should be noted that the reason I installed the HAXM rev. 4 was that I was getting  app crashes when trying to run the Android Intel emulator and I believed that installing the latest rev. of HAXM would resolve this.  It did not. 

Regarding the x86 image I was using, I ran the emulator with 4 different x86 images with Hyper-V enabled they all crashed.  The x86 images that I ran in troubleshooting this issue were:

  • API 14 - Host GPU enabled
  • API 14 - Host GPU disabled
  • API 17 - Host GPU enabled
  • API 17 - Host GPU disabled
  • API 18 - Host GPU enabled
  • API 18 - Host GPU disabled
  • API 19 - Host GPU enabled
  • API 19 - Host GPU disabled

All failed with an AppCrash status on emulator-x86.exe.

Thoughts?  I develop projects which have several platforms in one project to be tested which would include the Windows Phone project which requires Hyper-V installed as well as an Android project which would need to run the Android Intel x86 image.  It would be highly unproductive for me to have to disable Hyper-V and reboot/restart to run the Android Emulator to test my application only to have to re-enable Hyper-V and then reboot/restart in order to run the Windows Phone emulator. 


Hi, you should download all updates for it, and try to configure the virtual device or you trying to connect and use your phone.

Hi ..


I have submitted my queries here : I am still unable to fix it on my mac even after following up the instructions

Thanks for the help!

Leave a Comment

Please sign in to add a comment. Not a member? Join today