HAXM installation failure on Windows 7

HAXM installation failure on Windows 7

I have an Intel i5-3570K @ 3.4GHz and an Asus P8Z77-V LK motherboard with 16GB of RAM. The Intel Processor Identification Utility reports:

Execute Disable Bit: Yes
Intel(R) Virtualization Technology: Yes

In the BIOS I have Intel Virtualization and Execute-Disable Bit Capability enabled and I am running the BIOS version 0403.

The message I am getting is:

'This computer meets the requirements for HAXM, but Intel Virtualization (VT-x) is not turned on. HAXM cannot be installed until VT-x is enabled. Please refer to the Intel HAXM documentation for more information.'

The first time I attempted the installation Intel Virtualization was not turned on. I have enabled it in the BIOS, shut the system down for 10 minutes with power removed, and reattempted the installation several times with the same error message.

I have attached the HAXM install log and the complete Processor Identification Utility report.

I'm at a loss where to go next.

Downloadtext/plain PIU.txt1.14 KB
Downloadtext/plain haxm_install_log_6.txt259.38 KB
26 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Are you running any virtualization, possibly  Hyper V?  Please see https://software.intel.com/en-us/blogs/2014/03/14/troubleshooting-intel-haxm

1) I am not running any virtualization.

2) I followed all the instructions at  https://software.intel.com/en-us/blogs/2014/03/14/troubleshooting-intel-haxm before posting the first time.

3) I tried all the same troubleshooting steps again, with the same results.

4) One anomaly I failed to mention in the first post: When I run the HAXM installer it asks for administrator permission, then it starts and disappears completely. Starting the executable a second time the installer runs as expected, until it halts with the error mentioned above.

I'm attaching the Crystal CPUID output from today. I'm at a loss as to how to proceed. 


Downloadimage/png CPUID_14JUL2014.png27.76 KB

Well it seems as if you are doing things correctly, so we'll need to try some other methods to see why the settings are seen as wrong.

Are you getting haxm showing as installed that you could right click and choose run as admin?

If running Windows, can you make sure the XD/ND is also enabled in Windows (not just the BIOS)?

For the CPU setting, if you're running Windows, they have a tool for checking CPU Virtualization at http://www.microsoft.com/en-us/download/details.aspx?id=592.

Have you made an alternate boot entry to make sure no hypervisor is starting?   (Event Viewer> go down to Applications/Services Logs, expand Microsoft and make sure there is no Hyper...listing. 

If you're running Linux instead of Windows, see this post http://unix.stackexchange.com/questions/89714/easy-way-to-determine-virtualization-technology

1) HAXM is not getting installed.

2) NX is AlwaysOn. I don't know how to check XD/ND in Windows.

3) The Microsoft tool is reporting that Hardware virtualization is not enabled. The BIOS says otherwise, as does CPUID and the Intel Processor Identification Utility.

4) Yes. There is no Hyper... listing in the serviced log.

5) I am running Windows 7 SP1


Downloadimage/png bcdedit_0.PNG34.24 KB
Downloadimage/png HAV_1_0.PNG24.6 KB

For the disable bit in the Control Panel >  System > Advanced system settings > Advanced tab > Performance section, Options (or Settings) button > Data Execution Prevention tab.   (So it's called DEP in Windows).

For the VT bit...have you done a cold cold reboot? (Totally power off before rebooting). 

If you could do a cold boot and then go into the BIOS and send me a picture of the BIOS setting for VT?  (pix from your phone perhaps?)

We'll have to figure out why it shows on but isn't.......



1) I have attached a screen shot of the DEP screen. According to bcdedit the nx is AlwaysOn.

2) I have done a cold reboot twice, including just now. No change.

3) BIOS screen shot attached.


Downloadimage/png DEP.PNG38.88 KB
Downloadimage/jpeg BIOS.jpg800.72 KB

Do you have any antivirus enabled - particularly bitdefender?  See this thread (external website) http://forum.bitdefender.com/lofiversion/index.php/t28066.html

remember to do cold reboot after changes (sometimes 2 even).

I run Avast Anti-virus and Windows Firewall. I disabled both and did two cold boots with no success. Virtualization looks further and further away :(

Do you have the latest BIOS from Asus? (1402 I think?)
Have you tried disabling both, cold boots and then resetting?
If that doesn't clear it up, I think you need to contact the motherboard/BIOS manufacturer and say that the BIOS settings aren't being seen by the OS.

Good luck.

BIOS is now upgraded to the latest. Two more cold boots and no luck. When I have a chance tomorrow I will disable everything, do two cold boots, enable everything, then two more cold boots. In the meantime I will also open a ticket with Asus.

Thanks for your assistance!

Best Reply


I had the same problem with a similar processor, core i5 m430, in my HP laptop.  VT was also enabled on the BIOS and the problem was fixed when I uninstalled the avast anti-virus(no disabling the protection) and so I could finish the HAMX installation. After that, I installed the Avast software again.

I hope this issue can help more people.



Thank you. This solved the issue. Uninstalling Avast, installing HAXM, then installing Avast was just the ticket. All is good!

I've just wasted 2 hours of my life and I still don't have a solution!!!! I've been to these pages:



No one has a fix. Yes, I've checked the BIOS, I've run this command:HaxInst64.exe /i intelhaxm.inf 1 and here's the output

HaxInst64.exe /i intelhaxm.inf 1
INFO: Install Option "/i"
INFO: Input file "C:\Users\aschmidt\Downloads\h
INFO: Flags 0x1 (1)

DIFXDRVINSTALL: installing driver package.
LOG: 1, ENTER:  DriverPackageInstallW
LOG: 1, RETURN: DriverPackageInstallW  (0xA)
ERROR: failed with error code 0x0000000A

Does anyone know if other anti-virus software clobbers the install???


Another comment in another group stated to use sfc /scannow. OK, I did this, rebooted and ran the command and it looks like it installed. The android sdk STILL won't start up the emulator. It says the HAXM is not installed.

Have you read the first post thread at this site https://software.intel.com/en-us/forums/topic/520384. The error looks like a driver fail or fail to install.You can check your haxm_install_log.txt especially around Component: DIFxAPI_64.dll; and intelhaxm.inf


Hello everyone. I had exactly the same problem. And this is how I could fix it.

Step 1: Turn virtualization on in BIOS settings.

Step 2: Control Panel -> "Programs" -> "Turn Windows features on or off" (under "Programs and Features") and locate "Hyper-V", uncheck, reboot.

Step 3: In Avast->Settings->Troubleshooting. Uncheck "Enable hardware-assisted virtualization" & "Enable avast self-defense module"

Final step and the main: Go to MyPC / right click / Advanced System Settings / Advanced / In Performance click SETTINGS / Data Execution Prevention and enable DEP for all programs and services.

The last step helped me to solve this problem. Hope you too.

I have been trying to get HAXM installed off and on for a couple of months now with no luck.
System is Windows 7 SP1 with a second gen i7 processor.

Error is: "Failed to configure driver: unknown error. Failed to open driver."

CPU supports VT and  NX(XD) and seems to be configured correctly in the BIOS and bcdedit settings.

Not using AVAST and no Hyper-V installed.
Virus protection is via "System Center Endpoint Protection"

Attached are screen shots showing verification of configuration settings and a log file showing the installation failure.
(Error is on line 935 of log file).

If anyone is able to help or suggest something to try I would be grateful.



There is a 1603 error associated in the log file, which usually means something went wrong with the .msi file.
I'd try closing the install, checking in installed programs that it didn't leave remnants (uninstall if there), reboot, and try downloading and installing again. 

I have found the solution to the problem,

Go to MyPC / right click / Advanced System Settings / Advanced / In Performance click SETTINGS / Data Execution Prevention and enable DEP for all programs and services. Then restart your pc go to your bios and ensure that virtualization is enable in the bios setting under advance tab. 

I went for all the steps described but the only solution was :

If you are using AVAST, you have to go to settings tab -> troubleshooting : you should uncheck "enable hardware-assisted virtualization"


Error Message from Intel Hardware Accelerated Execution Manager Setup :

" Failed to configure driver: unknown error. Failed to open driver. "

My computer is :

Windows 7 Pro SP1

Processeur: Intel(R) Core(TM) i3-4030U CPU @ 1.90GHz 1.90 Ghz

RAM : 4,00 Go

64 bits


Audit from computer :

CMD ->   bcdedit /set nx AlwaysOn


CMD ->   bcdedit /set hypervisorlaunchtype off


CMD ->   sc query intelhaxm

don't work

CMD ->   Bcdedit -set TESTSIGNING ON


CMD ->   Bcdedit -set TESTSIGNING ON




log is join

Intel Processor Identification join



Can you help me ?


Olivier L. FRANCE




Downloadtext/plain haxm_install_log.txt245.42 KB
Downloadimage/png intel_proc.PNG107.05 KB

Even if you have enabled the Virtualization(VT) in BIOS settings, some antivirus options prevent HAXM installation.

If you have antivirus e.g Avast Go into its settings and turn it off for a suitable period of time.

and then start installation again . I hope that this will work.

Best .


I have enabled the Virtualization(VT) in BIOS settings.

I don't have antivirus on the PC.

but update intel are block.

Thx Harron for your response.

How can i do ?

Best .


I find my problem.

The Proxy stop C:\Users\olouet\AppData\Local\Android\sdk\extras\intel\Hardware_Accelerated_Execution_Manager\intelhaxm-android.exe

now it s work.


Intel update is a other problem.





Leave a Comment

Please sign in to add a comment. Not a member? Join today