Getting my emulator (AVD) started

Getting my emulator (AVD) started

I have just started programming in Android, and have downloaded Android SDK API level 20.

I wrote a short application, which was OK-eyed by the Eclipse environment,

configured an AVD to match my API level and tried to run it using Debug Configuration, but without success.

I tried rerunning it, waiting, and several different configurations on the AVD, but each time I came up with the same result.

I attach a file with my AVD configuration and the error messages that appeared on the console. Thanks!



7 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi Joseph,

there are a couple of things you can try:

  1. Check the file permissions of your AVD folder. It's located in c:\users\<your user name\.android\avd . Right click on it select properties and remove the "read only" property. Restart the Emulator.
  2. Add an SD card to your AVD. Shouldn't have an impact but for some users it helps...
  3. The advanced :-) method of solving this would be:
    adb shell
    mount -o rw,remount rootfs /

    Which changes the way the file system of the emulator mounted. If you reboot the emulator you have to apply this again

Hope one of the options solves your issue!

 Thanks for your reply, Alex!

I haven't been able to implement it though:

option 1:  whenever I cancel the read_only setting in my Avd folder, after pressing OK,

it always reverts back to read only again, so when I run emulator I get the same error message.I cant understand this.

option 2: my Avd emulator has an SD card of 16GB already.

option 3: where do I type this code?

Best regards


Hi Joseph,

Option 3 would go to a command line. The adb executable is located in the {Android SDK}/platform-tools/. 


Hi Alex,

I am still trying to run Android applications on my emulator, but without success.

I am working through Android tutorials, but without being able to run simple examples, progress is hard.

I am hoping to work in this field in order to support my family, so all help is appreciated.

Please find attached a file containing the latest error messages on the Console of Eclipse when I tried to run my application.

Thanks for your patience!



Downloadapplication/vnd.openxmlformats-officedocument.wordprocessingml.document Error messages in Console.docx16.29 KB

Dear Alex, 

While on the subject, here are some more error messages.

If you could give your take on these, that would be great!



Downloadapplication/vnd.openxmlformats-officedocument.wordprocessingml.document more error messages.docx13.54 KB

Anyone who is having problems getting their Android emulator running , like me,

might well be advised to try the website - Android emulator and see 

thousands of Q&A on this topic.

Leave a Comment

Please sign in to add a comment. Not a member? Join today