*** FIX *** HAXM 1.1.1 on Windows 7 64bit

*** FIX *** HAXM 1.1.1 on Windows 7 64bit


For people having install issues with HAXM - specifically this issue:  "Failed to configure driver: unknown error. Failed to open driver".
I discovered that the issue is the digital signed catalog for the 64bit driver is named wrong in the install.
It is named IntelHaxm_x64.cat in the inf file for the driver: CatalogFile.ntamd64=IntelHaxm_x64.cat
but the file that is in the folder is named  intelhaxm_x86.cat - this is the name for the 32bit OS driver.

So this is what I did to fix it.

1. Download the Hardware Accelerated Execution Manager via the android SDK tools or this file  haxm-windows_r05.zip (1.1.1)

2. Extract the install file to folder intelhaxm using 7zip or some archive program
    Note: for Android-sdk the install file is intelhaxm-android.exe located here:
    <android-sdk location>\extras\intel\Hardware_Accelerated_Execution_Manager
    For haxm-windows_r05 the install file is intelhaxm.exe (haxm-windows_r05) 

3. Go into folder intelhaxm and extract hax64.msi to folder hax64

4. Go into folder hax64 and remove all ".win7_64" from the file names of the inf, sys, and cat files for your OS (win7 or vista)

5. Rename file intelhaxm_x86.cat to IntelHaxm_x64.cat

6. Open a command window in that folder and run this command to install the driver
  HaxInst64.exe /i intelhaxm.inf 1 
  There should be no ERROR reported
  (UPDATE: As the comments below have pointed out, you might have to run "sfc /SCANNOW" and reboot your PC to get past this step. I didn't have to but it's worth a shot)

7. Go up one folder (intelhaxm) and run setup.exe - it should complete now with no errors

8. run this command to verify that it is working
   sc query intelhaxm
  it should return with a state of 4 (Running)

And you are done.

Hopefully someone from intel will fix this issue.

If after all this you are still not able to install, I would double check that your CPU/ BIOS / MOBO are compatible to get this to work.
 

Good luck.

15 posts / 0 new

If, by any chance, anybody is stuck at the sixth step (installing using the .inf file), and the output error is 0xA:

run

sfc /SNANNOW

from the command line (might require administrator's privileges). Worked wonders for me, after a reboot of course.

Taken from a similar topic


Hey, I've done absolutely everything there is on the internet for making this work. EVERYTHING. I even unistalled the 2010 haxm that was pre-installed in my PC to see if that was making any errors during the install. I changed the BIOS, I tried several and different "fixes" on the internet just for installing a program that should come ready and running on every pc on the world, yet my PC looks just unable to do this simple work. I did everything of this tutorial with no problems, until I got to step 6, where the CMD told me I should restart my PC, which I did, and returned to run the setup.exe, just to find myself infront of the same error message I've been having since 3 days. PLEASE, this should be fixed immediately!!! I need help. I really do.


Hi Dee and Rafal,

Thank you both. I was struggling all day with this and these two posts helped me get this resolved.
Just a quick note, it should be: sfc /SCANNOW

Once I ran that and rebooted, I was able to continue with Dee's step 6 and complete the install.

Emulation is now working for me in Android Studio.

Thank you both!

-Kevin


What does this mean:

4. Go into folder hax64 and remove all ".win7_64" from the inf, sys, and cat files for your OS (win7 or vista)

Does this mean delete the files?

Does it mean rename the files so that they do not include the substrings ".win7_64"?

The instruction as provided is ambiguous.


Quote:

Jeffrey D. wrote:

What does this mean:

4. Go into folder hax64 and remove all ".win7_64" from the inf, sys, and cat files for your OS (win7 or vista)

Does this mean delete the files?

Does it mean rename the files so that they do not include the substrings ".win7_64"?

The instruction as provided is ambiguous.

I did say from the file, but I see what you mean; so I've updated the step to reflect that you should rename the files.

 


In step 4, there should be a file named cab1.cab in the folder hax64. Extract it (7-zip may not work, winzip works) and go to folder cab1 before going to step 5.


I did all the steps above, but still get LOG: 3, Unable to open service 'IntelHaxm' to start it because of error 0x424 when installing the driver in step 6.

DIFXDRVINSTALL:
INFO: Install Option "/i"
INFO: Input file "G:\Downloads\haxm-windows_r05\haxm-windows_r05\intelhaxm\hax64\cab1\intelhaxm.inf"
INFO: Flags 0x1 (1)

DIFXDRVINSTALL: installing driver package.
LOG: 1, ENTER:  DriverPackageInstallW
LOG: 1, intelhaxm.inf: checking signature with catalog 'G:\Downloads\haxm-windows_r05\haxm-windows_r05\intelhaxm\hax64\cab1\IntelHaxm_x64.cat' ...
LOG: 1, Driver package 'intelhaxm.inf' is Authenticode signed.
LOG: 1, Copied 'intelhaxm.inf' to driver store...
LOG: 1, Copied 'IntelHaxm_x64.cat' to driver store...
LOG: 1, Commiting queue...
LOG: 1, Copied file: 'G:\Downloads\haxm-windows_r05\haxm-windows_r05\intelhaxm\hax64\cab1\IntelHaxm.sys' -> 'C:\Windows\system32\DRVSTORE\intelhaxm_05C23FA36D840F567DDC1AA519DD99C244311943\IntelHaxm.sys'.
LOG: 1, Installing INF file "C:\Windows\system32\DRVSTORE\intelhaxm_05C23FA36D840F567DDC1AA519DD99C244311943\intelhaxm.inf" of Type 1.
LOG: 1, Installing legacy driver 'C:\Windows\system32\DRVSTORE\intelhaxm_05C23FA36D840F567DDC1AA519DD99C244311943\intelhaxm.inf'
LOG: 3, Unable to open service 'IntelHaxm' to start it because of error 0x424
LOG: 0, Installation completed with code 0x0.
LOG: 1, RETURN: DriverPackageInstallW  (0x0)
SUCCESS: installed package G:\Downloads\haxm-windows_r05\haxm-windows_r05\intelhaxm\hax64\cab1\intelhaxm.inf.
INFO: Machine will have to be rebooted to complete install.


Quote:

Ricky L. wrote:

In step 4, there should be a file named cab1.cab in the folder hax64. Extract it (7-zip may not work, winzip works) and go to folder cab1 before going to step 5.

I extracted the contents of hax64.msi using 7-zip and I see no such file - are you using the file I lined in my original post?


Quote:

Ricky L. wrote:

I did all the steps above, but still get LOG: 3, Unable to open service 'IntelHaxm' to start it because of error 0x424 when installing the driver in step 6.

DIFXDRVINSTALL:
INFO: Install Option "/i"
INFO: Input file "G:\Downloads\haxm-windows_r05\haxm-windows_r05\intelhaxm\hax64\cab1\intelhaxm.inf"
INFO: Flags 0x1 (1)

DIFXDRVINSTALL: installing driver package.
LOG: 1, ENTER:  DriverPackageInstallW
LOG: 1, intelhaxm.inf: checking signature with catalog 'G:\Downloads\haxm-windows_r05\haxm-windows_r05\intelhaxm\hax64\cab1\IntelHaxm_x64.cat' ...
LOG: 1, Driver package 'intelhaxm.inf' is Authenticode signed.
LOG: 1, Copied 'intelhaxm.inf' to driver store...
LOG: 1, Copied 'IntelHaxm_x64.cat' to driver store...
LOG: 1, Commiting queue...
LOG: 1, Copied file: 'G:\Downloads\haxm-windows_r05\haxm-windows_r05\intelhaxm\hax64\cab1\IntelHaxm.sys' -> 'C:\Windows\system32\DRVSTORE\intelhaxm_05C23FA36D840F567DDC1AA519DD99C244311943\IntelHaxm.sys'.
LOG: 1, Installing INF file "C:\Windows\system32\DRVSTORE\intelhaxm_05C23FA36D840F567DDC1AA519DD99C244311943\intelhaxm.inf" of Type 1.
LOG: 1, Installing legacy driver 'C:\Windows\system32\DRVSTORE\intelhaxm_05C23FA36D840F567DDC1AA519DD99C244311943\intelhaxm.inf'
LOG: 3, Unable to open service 'IntelHaxm' to start it because of error 0x424
LOG: 0, Installation completed with code 0x0.
LOG: 1, RETURN: DriverPackageInstallW  (0x0)
SUCCESS: installed package G:\Downloads\haxm-windows_r05\haxm-windows_r05\intelhaxm\hax64\cab1\intelhaxm.inf.
INFO: Machine will have to be rebooted to complete install.

 

I'm stumped on this one, you using the 64bit drivers on a 64bit OS? 

You could try using flag 8 to see what the log says i.e. HaxInst64.exe /i intelhaxm.inf 8
if the log looks good, try using flag 4 HaxInst64.exe /i intelhaxm.inf 4 to force install.
Good luck


Quote:

Dee A. wrote:

Quote:

Ricky L. wrote:

 

I did all the steps above, but still get LOG: 3, Unable to open service 'IntelHaxm' to start it because of error 0x424 when installing the driver in step 6.

DIFXDRVINSTALL:
INFO: Install Option "/i"
INFO: Input file "G:\Downloads\haxm-windows_r05\haxm-windows_r05\intelhaxm\hax64\cab1\intelhaxm.inf"
INFO: Flags 0x1 (1)

DIFXDRVINSTALL: installing driver package.
LOG: 1, ENTER:  DriverPackageInstallW
LOG: 1, intelhaxm.inf: checking signature with catalog 'G:\Downloads\haxm-windows_r05\haxm-windows_r05\intelhaxm\hax64\cab1\IntelHaxm_x64.cat' ...
LOG: 1, Driver package 'intelhaxm.inf' is Authenticode signed.
LOG: 1, Copied 'intelhaxm.inf' to driver store...
LOG: 1, Copied 'IntelHaxm_x64.cat' to driver store...
LOG: 1, Commiting queue...
LOG: 1, Copied file: 'G:\Downloads\haxm-windows_r05\haxm-windows_r05\intelhaxm\hax64\cab1\IntelHaxm.sys' -> 'C:\Windows\system32\DRVSTORE\intelhaxm_05C23FA36D840F567DDC1AA519DD99C244311943\IntelHaxm.sys'.
LOG: 1, Installing INF file "C:\Windows\system32\DRVSTORE\intelhaxm_05C23FA36D840F567DDC1AA519DD99C244311943\intelhaxm.inf" of Type 1.
LOG: 1, Installing legacy driver 'C:\Windows\system32\DRVSTORE\intelhaxm_05C23FA36D840F567DDC1AA519DD99C244311943\intelhaxm.inf'
LOG: 3, Unable to open service 'IntelHaxm' to start it because of error 0x424
LOG: 0, Installation completed with code 0x0.
LOG: 1, RETURN: DriverPackageInstallW  (0x0)
SUCCESS: installed package G:\Downloads\haxm-windows_r05\haxm-windows_r05\intelhaxm\hax64\cab1\intelhaxm.inf.
INFO: Machine will have to be rebooted to complete install.

 

 

 

I'm stumped on this one, you using the 64bit drivers on a 64bit OS? 

You could try using flag 8 to see what the log says i.e. HaxInst64.exe /i intelhaxm.inf 8
if the log looks good, try using flag 4 HaxInst64.exe /i intelhaxm.inf 4 to force install.
Good luck

I got the intelhaxm running now. The hint is error 0x424. The root cause is the driver signature problem. I disabled driver signature enforcement in Boot up menu (press F8 when start up) first and install the driver without error.
Thank you all for your help!


good is hard, i dont now really :(


hello,
this is what i did to install haxm 1.1.4 on win 8.1 Pro 64-bit.
you may test it with or without admin-privileges, i've done it with them :-|
(this means to start cmd and any other exe in admin mode)

I. Preparing---------------------------------------------------------
(Optional: check or change your BIOS settings for Intel VT, disable hyper-v, ... as mentioned in other answers.)

1. download and extract the file to a folder
2. cmd -> sfc /SCANNOW
3. reboot
4. cmd -> Bcdedit -set TESTSIGNING ON
5. reboot

II. Installation-----------------------------------------------------
1. start install-android.exe in the folder of the extracted file and install
1.1 if you don't get an error the previous steps have handled the error - continue to III.
1.2 if you get an error DO NOT click OK when the error occurs
3. go to C:\Program Files\Intel\HAXM and copy all files, except *.tmp to a new folder
4. then continue/finish the setup (click OK and finish)
5. copy the files from the new folder to C:\Program Files\Intel\HAXM and delete *.tmp
6. go to C:\Program Files\Intel\HAXM, right-click on the inf-file and choose install
a window with driverinstallation should appear. install driver. it should says ok then..

hint: this is what made the difference for me!
Starting "HaxInst64.exe /i intelhaxm.inf 1" as well as with parameter 4 in the console did
not pop up the driverinstallation-window

III. Test------------------------------------------------------------
1. cmd -> sc query intelhaxm
it should show the service
2. reboot
3. cmd -> sc query intelhaxm
it should says service running..

IV. Reset------------------------------------------------------------
1. cmd -> Bcdedit -set TESTSIGNING OFF
2. reboot

sorry for my english :-)


Hi,

All the tutorials I've found misses something. I've spend many hours trying to install intel haxm.

When I download the zip-file mentioned here, There is no hax64.msi file and no intelhaxm.inf file.

Also, I need a digitally signed version of this, if there exists one. Because even when I follow the guides to install digitally unsigned programs, Windows fails. So Ricky L's solution does not help me either. 
See this issue : http://answers.microsoft.com/en-us/windows/forum/windows_10-hardware/dig....

I don't know what else to do.

 


Quote:

Reiner T. wrote:

hello,
this is what i did to install haxm 1.1.4 on win 8.1 Pro 64-bit.
you may test it with or without admin-privileges, i've done it with them :-|
(this means to start cmd and any other exe in admin mode)

I. Preparing---------------------------------------------------------
(Optional: check or change your BIOS settings for Intel VT, disable hyper-v, ... as mentioned in other answers.)

1. download and extract the file to a folder
2. cmd -> sfc /SCANNOW
3. reboot
4. cmd -> Bcdedit -set TESTSIGNING ON
5. reboot

II. Installation-----------------------------------------------------
1. start install-android.exe in the folder of the extracted file and install
1.1 if you don't get an error the previous steps have handled the error - continue to III.
1.2 if you get an error DO NOT click OK when the error occurs
3. go to C:\Program Files\Intel\HAXM and copy all files, except *.tmp to a new folder
4. then continue/finish the setup (click OK and finish)
5. copy the files from the new folder to C:\Program Files\Intel\HAXM and delete *.tmp
6. go to C:\Program Files\Intel\HAXM, right-click on the inf-file and choose install
a window with driverinstallation should appear. install driver. it should says ok then..

hint: this is what made the difference for me!
Starting "HaxInst64.exe /i intelhaxm.inf 1" as well as with parameter 4 in the console did
not pop up the driverinstallation-window

III. Test------------------------------------------------------------
1. cmd -> sc query intelhaxm
it should show the service
2. reboot
3. cmd -> sc query intelhaxm
it should says service running..

IV. Reset------------------------------------------------------------
1. cmd -> Bcdedit -set TESTSIGNING OFF
2. reboot

sorry for my english :-)

Thank you sooo much, it worked for me too. i am using Windows 8 64bit. And one thing to add as of HAXM 1.1.5 there will be no .temp file. but i did what you said along with you all the way. One more thing i could't find Hyper-V instead i found that VT-D is the same kind of thing that needs to be disabled. Thanks again.... :) P.S i made this account for this comment..lolz..

Leave a Comment

Please sign in to add a comment. Not a member? Join today