VCPU shutdown request

VCPU shutdown request

Just moved to a new machine running a 7th gen processor and can't seem to run any emulators that utilize haxm. Most recent version and from what I can tell I have the same settings on my old machine with a 6th gen processor.

Emulators work on hyper v and if I use the arm image but not x86 via the android emulator. The message below repeats over and over.

Hax is enabled
Hax ram_size 0x60000000
HAX is working and emulator runs in fast virt mode.
emulator: Listening for console connections on port: 5554
emulator: Serial number of this emulator (for ADB): emulator-5554
VCPU shutdown request
EAX=00748cea EBX=5ffadb60 ECX=00000000 EDX=00000000
ESI=00000000 EDI=00000000 EBP=00000000 ESP=00006d38
EIP=5ffb6921 EFL=00010082 [--S----] CPL=0 II=0 A20=1 SMM=0 HLT=0
ES =0010 00000000 ffffffff 00c09300 DPL=0 DS   [-WA]
VCPU shutdown request

Any help would be most appreciated, just spent two days trouble shooting and trying different suggestions.

Cheers,
James

18 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

 

Before you use intel haxm to launch emulator, eg, x86 or x86_64, make sure "Hyper-V", a Windows feature, is not installed/enabled on your system. See https://software.intel.com/en-us/blogs/2014/03/14/troubleshooting-intel-... And Hyper-V sometimes may be re-activated by Windows 10 system update. 

Hyper V has been tured off and removed from programs and features.

Which is your CPU?

FYI. Make sure all VT features are enabled in the BIOS. A good utility to check your system's capabilities is: Crystal CPUID

Best Reply

Here is the bug https://code.google.com/p/android/issues/detail?id=226174 , and we are fixing it. I will notify you as long as it is fixed. 

Thanks Jun.

This is a workaround: 

In a Command Prompt window, run:
cd C:\Users\<username>\AppData\Local\Android\Sdk\Tools\
emulator.exe -avd <x86_avd_name> -accel off -verbose -show-kernel -gpu off -qemu -smp 1
'-qemu -smp 1' is equivalent to turning 'multi-core' off in AVD manager.

Thanks Jun but I'm not sure I'd call that a workaround. Using the ARM image is significantly faster yet still horribly slow. Unfortunately we're shelving the 7th gen machines until we get an update...just too slow to operate.
Is there a time frame on when we can expect a fix?

Any updates or a time frame we can work toward? We'd really like to start using the new machines and we're actively advising against fellow developers upgrade until this is resolved.

It still is under debugging. 

Any updates Jun? I'm seeing more and more people struggling with this.

It still is under debugging. 

Can you provide a time frame? Just need to know if we should return 7th gen laptops as 30 day option is coming up.

After deep investigation, we have already root caused this issue. Then we will do the new release ASAP. See progress here: https://code.google.com/p/android/issues/detail?id=226174

We have fixed this bug. HAXM 6.0.5 for Windows is now being tested by Google and should be released later this week. If you can't wait, please download it from https://code.google.com/p/android/issues/detail?id=226174#c51

HAXM 6.0.5 is release via Google. And it is the same with I gave you before. 

Leave a Comment

Please sign in to add a comment. Not a member? Join today