Source Browser Problems

Source Browser Problems

When I use Source Browser, the source code line that the cursor jumps to does not contain the variable I am looking for. This does not happen with other projects. It seems the source browser data base is out of sync with the source code listing.

I have tried doing a rebuild all. I also went into each source file and made a small change to trick Visual Studio into recompiling each source file. Neither of these had an affect on my problem.

Does anyone have a suggestion?
I am using Visual Fortran version 6.5

Thank you.

4 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

I believe I have tracked down my problem. I will post it here as it may be of use to others.

When I first invoked the source browser I was prompted that the browser information was not available for my project, and to click to have build settings altered and browser information generated. I clicked and was able to use the browser with no problem. But after editing the source code the browser no longer was in sync with the code even though the source was recompiled.

Checking ?Generate Source Browse Info? under the Project-Settings-Fortran tab, cleared everything up. I guess the above prompt about having build settings automatically altered is true only for the FIRST browse session. After editing one?s source code, you must manually change the build settings for the browser info to be updated.

I don't quite follow what you did - but I could imagine that if you managed to set the source browser option on the individual source file rather than the project, then this might happen. In the typical case, once you have set the option, you don't need to touch it again.


Retired 12/31/2016

I have tried to recreate my problem with another project, but I can't. The source browser seems to always be in sync with my source code now. I do know I was having a problem before, but since I can't replicate it I don't know what I was doing wrong.

I am glad it is working good as usual.

Leave a Comment

Please sign in to add a comment. Not a member? Join today