tmp during link

tmp during link

When I compile and link via dos command line I get the message,
TMP directory C:windows emp does not exist use local directory.
and I can hear the program trying to access the a: drive. It then goes about its way and does the link OK.

How can I fix this? I plan to do quite a few compiles and links and don't want it to give this warning

6 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

You have the TMP system environment variable pointing to a non-existent directory. Best and easiest thing to do is create C:Windows emp. Alternative is to change the definition of TMP (and TEMP) to point to some other directory that exists.

Steve

Steve - Intel Developer Support

Created c: mp c: emp and c:windows mp The directory it is looking for is
c:windows emp see attached.

I also changed the dfvars.bat file to micros~1 and have rebooted with same results. see old path from dfvars.bat

D:AESWorking FoldersAspen Plus 10.2>path

PATH=D:AESASPENP~2.2ENGINEXEQ;D:MICROSOFT VISUAL STUDIOCOMMONMSDEV98BIN;

D:MICROSOFT VISUAL STUDIODF98BIN;D:MICROSOFT VISUAL STUDIOVC98BIN;D:MICRO

SOFT VISUAL STUDIOCOMMONTOOLS;D:MICROSOFT VISUAL STUDIOCOMMONTOOLSWIN95;C:

PROGRA~1COMMON~1ASPENT~2;C:NOVELLCLIENT32;C:WINDOWS;C:WINDOWSCOMMAND;C:

PROGRA~1E!PC;Z:.

At this point, I don't know what's wrong and am not sure why you changed DFVARS.BAT (or what you changed it to.) From a command prompt, do a SET command - what does it show as the values for TMP and TEMP?

Steve

Steve - Intel Developer Support

Steve,
I am attaching the list of the set command. I checked the set and it looked OK to me. That is why I can't understand it. It says it cannot find c:windows emp when it is there and I can see files in that directory. this is part of a program called Aspen and I am in contact with them about this.

TMP=C:WINDOWSTEMP
TEMP=C:WINDOWSTEMP
PROMPT=$p$g
winbootdir=C:WINDOWS
COMSPEC=C:COMMAND.COM
DF_TOOLS=MSVC
CPU=i386
IMSLNT_F90=d:Micros~1DF98IMSL
INCLUDE=d:Micros~1DF98IMSLINCLUDE;d:Micros~1DF98INCLUDE;d:Micros~1VC98INCLUDE;
LIB=d:Micros~1DF98IMSLLIB;d:Micros~1DF98LIB;d:Micros~1VC98LIB;
VNI_F90_MSG=d:Micros~1DF98IMSLMESSAGE
LINK_F90=imsl.lib imsls_err.lib imslmpistub.lib
windir=C:WINDOWS
BLASTER=A220 I5 D1
NWLANGUAGE=English
WINDOWS_LOGIN=0
ASPTOP=D:AESASPENP~2.2ENGINE
PATH=D:AESASPENP~2.2ENGINEXEQ;D:MICROS~1COMMONMSDEV98BIN;D:MICROS~1DF98BIN;D:MICROS~1VC98BIN;D:MICROS~1COMMONTOOLS;D:MICROS~1COMMONTOOLSWIN95;C:PROGRA~1COMMON~1ASPENT~2;C:NOVELLCLIENT32;C:WINDOWS;C:WINDOWSCOMMAND;C:PROGRA~1E!PC;Z:.

Sorry, I'm out of ideas. If you still have the problem after upgrading to the current supported version, 6.6, let us know at vf-support@compaq.com

Steve

Steve - Intel Developer Support

Leave a Comment

Please sign in to add a comment. Not a member? Join today