Whether is there any offline installation package?

Whether is there any offline installation package?

12 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Dear All,

I found the current installation is based on Web mode, I have to spend a very long time to download and install these packags, especially, installing Cygwin, whether is there offline installation package or other flexible mechanism can be provided for the developers in bad network environments?


Another suggestion is, is it possible to provide the option for user to choose existing third-party tools while online installing?

For example, I have ADT bundle, SDK and NDK (etc.) on my machine, while I am trying to use this BeaconMountain_websetup.exe, it will download all these again. If it can provide an option for me to choose existing tools, and only download other tools, that will be great!



Thank you for the suggestions!  We will consider these features (offline install, and partial install)


I encountered the same problem with yi-yang. I live in Indonesia where internet connection is mostly not fast, partial install (since I already have ADT installed in my laptop, I prefer to have an option to not install another ADT in Beacon Mountain installation) or offline installation package will be much appreciated.

An option to not install the ADT is under consideration.  Internet connections are required for installer as we install packages (like the ADT) from their servers (http://developer.android.com).  The installer would still need a decent internet connection to download the ADT (even if you didn't want to install it). 

Sorry to hear you are having connectivity issues.  It is tough to be a developer without good connectivity.

same with firman, I can't install it, I try several times and get same error on downloading cygwin

Hi Aulia,

    I am sorry you are having problems with Cygwin installing. Cygwin recently changed their installer, which might be contributing to your issue.   Please post your log files so we can investigate further.

Here is a link on how to access the log files:




Hi Chuck,

here's my log files, i've downloaded the 0.6.1 version still same error on cygwin



Downloadapplication/zip log.zip737.43 KB

Hi Aulia,

     We posted a new version this morning that works with the latest Cygwin installer.  Please try this latest one, and let me know how it goes.

Link: http://software.intel.com/en-us/vcsource/tools/beaconmountain



Hi Chuck,

Finally installed on my computer, now its time to code around...,


Awesome!  Thanks for letting me know.


Leave a Comment

Please sign in to add a comment. Not a member? Join today