Failed to load the JNI shared library

Failed to load the JNI shared library

Hi

i just completed installing the Beacon Mountain program but a "Failed to load the JNI shared library" popped up.

i am pretty sure i have installed the correct java: 

jdk-7u21-windows-x64.exe   for my window x64, so i am not sure what the problem is.

thanks!

2 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi,

I'm assuming that you also installed a 32bit version of Java and the 32bit version comes first in the path. In order to solve this issue you can explicitely point to the 64Bit version of the JDK:

Edit the eclipse.ini file in c:\intel\BeaconMountain\ADT\eclipse.
Add the parameter vm which points to your 64 bit java installation (you might need to adjust the path):  

-vm 
C:\Program Files\Java\jdk1.7.0_01\bin\javaw.exe

The position of the parameter is important. It needs to be placed between the parameters showsplash and launcher.XXMaxPermSize

My complete eclipse.ini file:

-startup
plugins/org.eclipse.equinox.launcher_1.3.0.v20120522-1813.jar
--launcher.library
plugins/org.eclipse.equinox.launcher.win32.win32.x86_64_1.1.200.v20120522-1813
-product
com.android.ide.eclipse.adt.package.product
--launcher.XXMaxPermSize
256M
-showsplash
com.android.ide.eclipse.adt.package.product
-vm 
C:\Program Files\Java\jdk1.7.0_01\bin\javaw.exe
--launcher.XXMaxPermSize
256m
--launcher.defaultAction
openFile
-vmargs
-Dosgi.requiredJavaVersion=1.6
-Xms40m
-Xmx768m
-Declipse.buildId=v21.1.0-569685

Hope this helps!
Alex 

Leave a Comment

Please sign in to add a comment. Not a member? Join today