Missing icon in AppUp beta test

Missing icon in AppUp beta test

We uploaded an application and started the beta test, and are having two problems. 1. The app installs and launches correctly, but on one of two test machines, it fails to authorize. (Returns ADP_NOT_AUTHORIZED from ADP_IsAuthorized() call). 2. On both machines, there is no app icon in the My Apps section of AppUp Center; only a green arrow, with the program name pop-up when hovering there. Screen shots are also not visible, even though the "1 of 2" text appears for them. Description text is okay. (Icons and screen shots appear correctly when editing the app from the Developer Program Dashboard).
9 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.


1.) Are you positive your app / required libraries are not cached or executing an old version?

2.) You may want to either kill the "Service Manager" process and re-launch AppUp, or simply re-install AppUp again.

This is an option as well if you have the time to configure a more dedicated test environment:


Thanks for the response Brian.

Unfortunately, several combinations of re-installs and reboots did not seem to change any of the results.

Hi John,

Please try deleting the images on C/programs/Documents and Settings/Application Data/Intel/IntelAppStoreBeta/download before downloading the new version.


Hal G.

Intel® Atom™ Developer Program

Thanks Hal,

I cleared the download directory, killed the process, and re-ran AppUp. After selecting My Apps, I can see a shadowed area for the icon with the text "loading", but nothing shows up when the loading is complete. (When the dir repopulates, I can see valid images for the program as 150.png, etc.)

Perhaps the problem is being caused by having two copies of the various images. The app has both a Demo and a Full version, and I uploaded the same icon and screen shot images for both apps. But I did try uninstalling the full version so that only the Demo was present in the list, and redoing the above, and I still get the same results. (I also tried un/re-installing the problem app).

I'll go ahead and create duplicates of the images with different names, remove the old images, and add the new ones. Maybe that will take care of it.

On the other matter of failed authorization, I found out that the second beta account used "cancel" for the credit card info when registering. However, that looks like the accepted procedure for foreign beta testers anyway, so it doesn't seem like that would cause his ADP_NOT_AUTHORIZED failure.

-- update --
I had some trouble re-uploading new images. I had to do the icon twice before it appeared in the dashboard. (Sent the icon, nothing, sent the first screen shot, and the latter appeared but still not the icon. Sent the icon again, and then it appeared). Then I when I uploaded the second screen shot, I received the message, "Flash : The upload task is interrupted! io". Did that one a second time, and then it appeared.

I then redid the above sequences to reload the app, and the icon and screen shots are still blank.

Unfortunately, the Screenshot text now says "1 of 3", so the interrupted upload may have added yet another corruption. (There are only two shots visible in the dashboard). :-(

Hello All,

there was a unexpected downtime of the backend system for a couple of hours yesterday.

Best Regards,

Andre B.

Technical Support Team
Intel® Atom™ Developer Program
Intel® AppUp(SM) Center

On a good note, with every downtime usually comes a few bug fixes for this site. It just keeps getting better. Thanks Andre

I have an answer to the "missing icon" problem, and it's actually at the bottom of the "Beta Testing" article.

Until the application has been published in the store, the product icon and screen shots won't be visible.

The confusion happened because one of our beta tests was actually an update of a published product, and so its icon was visible. That made the missing one seem more anomalous.


Thanks John, that is a nice to know item :)

Leave a Comment

Please sign in to add a comment. Not a member? Join today