Application does not appear at AppUp for beta test

Application does not appear at AppUp for beta test

Hi, I have invited 4 persons to test (Beta Test) my application but only one person received application for testing at AppUp. Where as for other testers application does not appear in 'Pending download' section. tried many times but no luck. Need help.
8 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi opkus,

Thank you for your query.

There have been some issues reported to us regarding the beta testing invitation features. There are currently some minor glitches which we are aware of and the back-end team is working on a fix. The invitation email might not work as well, so the beta testers may not receive the email invitation to beta test your app, but in general when they log-in to the AppUp(SM) they should see your app under the pending downloads.

In the meantime, please make sure that the other testers are not using the same machine to use the AppUp(SM) Center unless you are using virtual machines.

Also make sure that you are using Internet Explorer 8 to do the beta testing invitation. I have personally see a better performance with IE8 compare to other browsers. Also it should be noted that if your application is targeted for Windows XP (for example), any users using the AppUp(SM) on Windows 7 will not be able to see the app unless the app is for both XP and 7.


Intel Technical Support
Intel® Atom™ Developer Program
Intel AppUp(SM) Center

DG Rooven


Were you able to get your beta testing underway?

I have the the same problem. I've sent 3 invites but the download is simply not available in AppUp.

There's also a problem with the beta testing guide ( ) maybe this is the reason for the problem in my case:

I'm outside the US or Canada so I'm trying to register an AppUp account as explained. The problem is step 3:
"When prompted for location, register as a US resident. "
I'm never prompted for location. The registration process simply claims that I'm from Germany (which is correct) and doesn't let me choose. There also doesn't seem to be a possibility to change the location later or in AppUp.

Yes, we managed to complete the beta testing.
The app is published now.

Hello UnrealSoftwareDev,

Unfortunately the BETA testing guide has not been updated since Germany and other countries were added to supported list. The fact that you are registered from Germany should not cause an issue. As Rooven stated, we are aware of this issue and are working on a resolution.

By the way, if you have not tried the latest client (2.5) please do.

Hal G.
Technical Support Team
Intel® Atom™ Developer Program
Intel AppUp(SM) Center

Thank you for the information. I'm already using the latest client (I also tried re-installing it now but it didn't change anything).

Edit: Problem seems to be solved. I installed AppUp on another system (English Win 7 Pro 64 Bit, I was using a German version of Win 7 Home with 32 Bit at the other one) and I'm now able to download and install my app for beta testing.

Good to hear you found a solution. I heard mention at IDF that additional language support may be coming this year to AppUp. Best of luck going forward.

Leave a Comment

Please sign in to add a comment. Not a member? Join today